[indicator] + [dialog] Silent Mode causes no indication of a change in [icon] state.

Bug #1367818 reported by James Mulholland on 2014-09-10
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Thomas Strehl
Ubuntu UX
High
Matthieu James
indicator-sound (Ubuntu)
High
Ted Gould
indicator-sound (Ubuntu RTM)
High
Ted Gould

Bug Description

- "When the sound is muted, the volume icon to the left of the volume slider should have a red "/" running through it."
- "Add an explicit "Mute" button to the sound indicator menu."
- "Pressing and holding the icon to the left of the volume slider should mute volume straight away."

------------------------------

Desired resolution: Once the sound is muted icon should change but not the colour. We have an icon for muted
https://www.dropbox.com/work/Apps%20and%20Platform%20Team/9.%20Icons/Suru%20Icon%20Theme/status/81?preview=volume-min.png
The behaviour has already been illustrated by MPT

Related branches

tags: added: rm-14
tags: added: rtm-14
removed: rm-14
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
tags: added: rtm14
removed: rtm-14
Thomas Strehl (strehl-t) on 2014-09-29
Changed in indicator-sound (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
tags: added: touch-2014-10-30
Ted Gould (ted) on 2014-10-02
Changed in indicator-sound (Ubuntu):
assignee: Charles Kerr (charlesk) → Ted Gould (ted)
status: New → Confirmed
Ted Gould (ted) on 2014-10-02
summary: - Mute causes no indication of a change in [icon] state.
+ Silent Mode causes no indication of a change in [icon] state.
Ted Gould (ted) on 2014-10-02
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress

I have just discussed this with James. He had transcribed three suggestions here:

1. If the minimum-volume icon had red through it all the time, it would risk being the most prominent item in the menu (at least when music wasn't playing/paused), and it would be inconsistent with System Settings (cf. bug 1376286) and with the volume OSD. If the minimum volume icon should be changed everywhere, that's an issue for the theme, not the indicator.

2. A Mute button in the indicator menu would be too similar to Silent Mode. We should, however, have a Silent Mode switch as the first item in the Sound menu.

3. Currently tapping on the icon to the left of the slider sets the volume to zero -- but pressing and holding does not. This should be fixed.

Ted Gould (ted) on 2014-11-10
Changed in indicator-sound (Ubuntu):
status: In Progress → Triaged
John McAleely (john.mcaleely) wrote :

Can this be triaged onto a milestone for canonical-device-system image?

Pat McGowan (pat-mcgowan) wrote :

Can we get a clarification, the title is about silent mode and the description and comments pertain to mute
Do we want the indicator to show silent mode is enabled?

Ted Gould (ted) on 2015-02-19
Changed in indicator-sound (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Paty Davila (dizzypaty)
assignee: Paty Davila (dizzypaty) → nobody
assignee: nobody → Matthew Paul Thomas (mpt)
summary: - Silent Mode causes no indication of a change in [icon] state.
+ [indicator] + [dialog] Silent Mode causes no indication of a change in
+ [icon] state.
tags: added: bq usability
removed: rtm14 touch-2014-10-30
Pat McGowan (pat-mcgowan) wrote :

Be nice to land this since we wanted it for release originally

Changed in canonical-devices-system-image:
assignee: nobody → Thomas Strehl (strehl-t)
importance: Undecided → High
milestone: none → ww13-ota
status: New → Confirmed
Ted Gould (ted) on 2015-04-01
Changed in indicator-sound (Ubuntu RTM):
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+15.04.20150402~rtm-0ubuntu1

---------------
indicator-sound (12.10.2+15.04.20150402~rtm-0ubuntu1) 14.09; urgency=medium

  [ Ted Gould ]
  * When in silent mode show muted icon on the panel (LP: #1367818)
 -- CI Train Bot <email address hidden> Thu, 02 Apr 2015 20:31:03 +0000

Changed in indicator-sound (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
John Lea (johnlea) on 2015-04-08
Changed in ubuntu-ux:
assignee: Matthew Paul Thomas (mpt) → Paty Davila (dizzypaty)
John McAleely (john.mcaleely) wrote :

@pat, what is the behaviour we should see, since it seems not to be the exactly requested behaviour in the bug description.

Pat McGowan (pat-mcgowan) wrote :

When silent mode is enabled the icon in the top panel changes to show that mode
Users were forgetting they enabled silent mode

The icon does not change when muted. One could argue it should also change in that case but that was not the design direction that was understood. I assume that is because increasing volume will rectify that when actively using the phone, whereas with silent mode you can miss calls and texts.

John McAleely (john.mcaleely) wrote :

@pmcgowan I note that the UX task is still triaged. On the OTA3 image, you get a little cross for 'silent mode' next to the indicator.

For the volume OSD, the visual language is different, where as you take the volume down to zero, you get a cross. Which is confusing.

@patty davilla, is there still work to be done in this area, or is your task in need of an update.

John Lea (johnlea) on 2015-07-30
Changed in ubuntu-ux:
assignee: Paty Davila (dizzypaty) → Alex Milazzo (digitalalex)
Alex Milazzo (digitalalex) wrote :

Desired resolution updated in the description. Icon needs to change but not the colour.

description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Released
Changed in ubuntu-ux:
status: Fix Released → Fix Committed
John McAleely (john.mcaleely) wrote :

please open a new bug, rather than commenting on a long-closed one.

Changed in ubuntu-ux:
assignee: Alex Milazzo (digitalalex) → Matthieu James (tiheum)
Matthieu James (tiheum) on 2015-10-23
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers