User name shown as [Invalid UTF-8] in live session

Bug #837246 reported by Otus on 2011-08-30
112
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Medium
Conor Curran
Unity Foundations
High
Conor Curran
indicator-session (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Using the beta iso testing image 20110830 the user name displayed in unity-2d panel is [Invalid UTF-8]. Clicking the indicator still shows Guest Session in the menu.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.3.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CasperVersion: 1.280
Date: Tue Aug 30 09:27:41 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110830)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-session
UpgradeStatus: No upgrade log present (probably fresh install)

Otus (jan-varho) wrote :
tags: added: iso-testing
Conor Curran (cjcurran) on 2011-08-30
Changed in indicator-session:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.3.4
Changed in indicator-session (Ubuntu):
status: New → In Progress
Changed in indicator-session (Ubuntu Oneiric):
importance: Undecided → Medium
Conor Curran (cjcurran) on 2011-08-30
Changed in indicator-session:
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2011-08-31
Changed in unity-foundations:
milestone: none → oneiric-beta-2
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-session:
status: Fix Released → Fix Committed
Conor Curran (cjcurran) on 2011-09-01
Changed in indicator-session:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.4.1-0ubuntu1

---------------
indicator-session (0.3.4.1-0ubuntu1) oneiric; urgency=low

  [Ken VanDine]
  * New upstream release.
    - in a Guest session user menu is not visible (LP: #834948)
    - User name shown as [Invalid UTF-8] in live session (LP: #837246)
    - "Reboot Required" menu opens Update Manager, doesn't reboot (LP: #837658)
    - indicator-session-service crashed with SIGSEGV in
      g_str_hash() (LP: #824243)
    - indicator-session-service crashed with SIGSEGV in
      g_variant_unref() (LP: #833965)
  * +debian/patches/revert_icon_change.patch
    - revert the icon change in greeter mode until a UIF exception is
      approved
  * +debian/source/format

  [Ted Gould]
  * debian/control: Adding a depend on gnome-settings-daemon to ensure that
    the required schemas are available. (LP: #833965)
 -- Ken VanDine <email address hidden> Thu, 01 Sep 2011 13:53:50 -0400

Changed in indicator-session (Ubuntu Oneiric):
status: In Progress → Fix Released
Guy Stone (stoneguy3) wrote :

Booted fresh Beta-1 Live DVD from iso dd'd to 4GB USB key. Username shows as [Invalid UTF-8]
System is ASUS eeePC-900 with external KVM

Nathan Haines (nhaines) wrote :

Guy, as noted in the Beta 1 release notes, this was not fixed in time for Beta 1 and is fixed for Beta 2.

Conor Curran (cjcurran) on 2011-09-05
Changed in unity-foundations:
status: Fix Committed → Fix Released
Richard Peake (yourtechfriend) wrote :

- User name shown as [Invalid UTF-8] in live session (LP: #837246)

I upgraded today from 11.04 to 11.10 and the [Invalid UTF-8] shows up rather than the User_account_name.
This is an issue for all user accounts. I haven't changed any user IDs or group IDs, nor have I added or removed or changed users or user group memberships. I didn't do anything but upgrade to 11.04 to 11.10. My installation is completely up to date and there's nothing left to do in the way of installing new updates -- so this bug isn't fixed. It's very much alive and kicking for me.

$ dpkg -s indicator-session|grep Version
Version: 0.3.6-0ubuntu2

$ env | grep LANG
LANG=en_US.UTF-8

similar notes on
https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/834137

Niklas Fischer (niklasfi) wrote :

This affects me, too. If you want any particular info, I will provide it to you.

0dB (nbaatz) wrote :

I have this bug, too. Performed a dist-upgrade a few days after the 11.10 release, did not change anything otherwise.

Ofer Cohen (oc666) wrote :

Unfortunately, the bug affect me too.

I'm affcted, too. Any workarounds available?

OK, you can use this workaround (taken from Bug #834137 which seems to handle the same issue):

You have to ensure that your user id is above or equal to the value of UID_MIN in /etc/login.defs (1000 per default).

In my case the user id was 501 so I set the UID_MIN to 500 (the Debian style).

Niklas Fischer (niklasfi) wrote :

@#10 Thanks, that fixed it for me.

Steven Lindsey (lindss2) wrote :

I still have the problem if there are more than 41 lines in /etc/passwd (of which 6 are non-system accounts)
I can swap in/out working users, but if I add more, it goes back to "Invalid UTF-8" for names even after picking up the latest updates a couple of minutes ago.

jhouse (jhouse) wrote :

Just (today) upgraded from 10.10 to 11.10 and I have this problem. All my user ids are above 1000 and I have 38 lines in /etc/passwd .

Ace (linuxrawkstar) wrote :

also affected. tweaking /etc/login.defs is not an acceptable solution and could lead to big problems. we need to get this fixed folks.

Richard Peake (yourtechfriend) wrote :

Upgraded.
michael@saturn:~$ dpkg -s indicator-session|grep Version
Version: 0.3.7.1-0ubuntu1.1

The package manager version sets /etc/login.defs to 500; but it is not needed on my system. I had more than 6 users defined on this system -- and the new version is working just fine with /etc/login.defs set to 1000.

It's all fixed as far as I can see. Thanks, folks!

0dB (nbaatz) wrote :

Fixed since last upgrade, thanks.

Steven Lindsey (lindss2) wrote :

I couldn't seem to get the latest version of the package manager with a normal update, but after re-installing the OS, I got the newer version and was able to get things working. (Just in case anyone else is having trouble).

Ken Pratt (kenpratt) wrote :

Bug is in indicator-session-0.3.7.1

I'm using Ubuntu 11.10 64bit. My account info comes from NIS. Perhaps indicator is not NIS aware? I guessed this may be the problem so created an override in /etc/passwd for my account GECOS field.

Here is my entry

+kpratt::::Ken Pratt:/mnt/home/users/kpratt:

I still get [Invalid UTF-8] as the indicator displayed user name.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers