User accounts experience fragmented

Bug #834830 reported by Jono Bacon on 2011-08-26
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
Matthew Paul Thomas
Session Menu
Fix Released
Medium
Unassigned
gnome-control-center
New
Undecided
Unassigned
Baltix
Undecided
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
indicator-session (Ubuntu)
Undecided
Unassigned

Bug Description

Today we have a problem in how different user accounts are presented in Ubuntu. For a typical user they will need to configure the following accounts:

 * System (e.g. login accounts).
 * Email (e.g. Gmail IMAP in Thunderbird).
 * IM (e.g. MSN, Facebook etc in Empathy).
 * Broadcast (e.g. Twitter in Gwibber).

Today we expose the following places to configure these accounts in the System Settings:

 * Online Accounts - a limited functionality means of configuring global accounts for Evolution/Empathy (only Google supported).
 * Messaging and VoIP Accounts - Empathy IM and VoIP accounts.
 * User Accounts - system accounts (e.g. your login accounts).

We don't expose Broadcast Accounts for Gwibber and Email Accounts for Thunderbird in System Settings; they are configured in the app.

This bug has two issues:

 1. The current way in which we present the existing tools is confusing (e.g. the Me Menu shows Online Accounts and User Accounts and neither is clear which configures what). Also, Online Accounts presumes you can set up accounts such as Twitter and Email, but it doesn't serve that purpose.
 2. From a design perspective, this functionality is scattered all over the system - we should have a single integrated configuration tool, or alternatively, a consistent in-app means of configuring these services.

Francesco Ferraro (ferraro96) wrote :

I think it's a high importance bug. New users may be confused with all this things to do.
A "User" option in gnome-control-center for configuring everything from Login to Broadcast services would be great.

Bilal Akhtar (bilalakhtar) wrote :

Blocked on design for now.

tags: added: needs-design
Changed in indicator-session:
status: New → Incomplete
Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Fix Committed
Changed in indicator-session:
status: Incomplete → Triaged
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

Thanks for this insightful report, Jono.

I discussed this with Stewart Wilson, who is designing Web accounts integration. He said that in Ubuntu 12.04, the "Online Accounts" panel will not be installed by default (except, in an upgrade, if anyone has used it already).

So, I think this bug will be fixed when that removal is implemented, and when the "Online Accounts" item is removed from the user menu. <https://wiki.ubuntu.com/DeviceMenuAndUserMenu#cleanup>

Further integration of account types -- e.g. a Yahoo account that works with both Empathy and Thunderbird, or the long-discussed ability to log in to Ubuntu using your Ubuntu One account -- should be, I think, out of the scope of this bug report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Hi, I looked at this a bit today and it looks to me like gnome-control-center depends on gnome-online-accounts (specifically libgoa-1.0-0 but that's the important piece anyway) if it builds the goa panel. If it doesn't build the goa panel, then you can't even use goa, which is a requirement for gnome-documents, gnome-contacts, and even gnome-shell unless we patch out the link in the usermenu.

Changed in ayatana-design:
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

Fixed in Ubuntu Q. "Online Accounts" is now in the system menu only when an account has had an authentication failure. And that panel is also used for setting up accounts in Empathy.

Changed in indicator-session:
status: Triaged → Fix Released
Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints