indicator-session-service crashed with SIGSEGV in g_str_hash()

Bug #824243 reported by Andrew James Vincent Powell on 2011-08-11
208
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
High
Conor Curran
Unity Foundations
High
Conor Curran
indicator-session (Ubuntu)
Undecided
Conor Curran

Bug Description

latest update to the indicator-session program (0.3.1.0ubuntu1) is once again causing this bug. It seems to happen when I'm playing with the unity launcher or running another program which crashes, like UbuntuOne. I'm not sure what else to add, sorry. Have to log out with CTRL+ALT+Delete as the session menu button no longer displays any entries once it has crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
Date: Thu Aug 11 10:08:59 2011
ExecutablePath: /usr/lib/indicator-session/indicator-session-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
ProcCmdline: /usr/lib/indicator-session/indicator-session-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xf017ea <g_str_hash+10>: movzbl (%ecx),%edx
 PC (0x00f017ea) ok
 source "(%ecx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-session
StacktraceTop:
 g_str_hash () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 g_list_foreach () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: indicator-session-service crashed with SIGSEGV in g_str_hash()
UpgradeStatus: Upgraded to oneiric on 2011-08-10 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public
description: updated
Changed in indicator-session (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2011-08-11
Changed in indicator-session (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-session:
status: New → Triaged
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.3.2
importance: Undecided → Medium
Conor Curran (cjcurran) on 2011-08-18
Changed in indicator-session:
importance: Medium → High
Conor Curran (cjcurran) on 2011-08-18
Changed in indicator-session:
milestone: 0.3.2 → none
lidex (mh40) wrote :

This happens on desktop load for me. Running '/usr/lib/indicator-session/indicator-session-service' in terminal produces attached output. Also including coinciding dmesg output.

lidex (mh40) wrote :

I have an icon in the unity panel, but no functionality. Another oddity is the lightdm screen is missing a section right where the indicators would appear and the time shows there.

jerrylamos (jerrylamos) wrote :

The crash claims it is a "classic" crash while Unity 3D is in fact running and not classic?.

Note the top right button no longer does anything so logout, shutdown, .,. are not accessible. I do a command line reboot or halt.

I've seen this before. I resort to Unity-2D which doesn't have this problem.

Jerry

lidex (mh40) wrote :

After today's updates (oneiric), the icon changed but still no functionality. Still have black rectangle in lightdm. Output from '/usr/lib/indicator-session/indicator-session-service' is drastically reduced:

~$ '/usr/lib/indicator-session/indicator-session-service'

(process:2826): LIBDBUSMENU-GLIB-CRITICAL **: dbusmenu_menuitem_property_set_variant: assertion `DBUSMENU_IS_MENUITEM(mi)' failed

(process:2826): LIBDBUSMENU-GLIB-CRITICAL **: dbusmenu_menuitem_property_remove: assertion `DBUSMENU_IS_MENUITEM(mi)' failed
(process:2826): Indicator-Session-DEBUG: Unable to get lock screen shortcut.
Segmentation fault (core dumped)

lidex (mh40) wrote :

Core dump from segfault in comment five

jerrylamos (jerrylamos) wrote :

Crash happens seconds after I open Firefox.

Contrary to my comment #4 I'm running Unity 2D this time.

Note last night after such a crash I had to resort to terminal strip power off. Nothing else worked.

Jerry

StacktraceTop:
 g_strjoinv (separator=0x6c20c4 "\201\303D]", str_array=0x8f2bea0) at /build/buildd/glib2.0-2.29.16/./glib/gstrfuncs.c:2647
 ?? ()

Changed in indicator-session (Ubuntu):
status: Confirmed → Invalid
Download full text (5.6 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.6.1-6ubuntu2 required, but 1:4.6.1-7ubuntu2 is available
outdated debug symbol package for libavahi-common3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for libslang2: package version 2.2.4-2ubuntu1 dbgsym version 2.2.2-4ubuntu2
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
lsb-base version 4.0-0ubuntu13 required, but 4.0-0ubuntu14 is available
fontconfig version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
outdated debug symbol package for libnih1: package version 1.0.3-4ubuntu2 dbgsym version 1.0.3-1ubuntu1
outdated debug symbol package for dpkg: package version 1.16.0.3ubuntu3 dbgsym version 1.16.0~ubuntu7.1
libpam-modules version 1.1.3-1ubuntu3 required, but 1.1.3-2ubuntu1 is available
libgtk-3-common version 3.1.10-0ubuntu3 required, but 3.1.12-0ubuntu1 is available
outdated debug symbol package for libgpg-error0: package version 1.10-0.3ubuntu1 dbgsym version 1.10-0.2ubuntu1
libpam0g version 1.1.3-1ubuntu3 required, but 1.1.3-2ubuntu1 is available
outdated debug symbol package for dbus: package version 1.4.12-4ubuntu2 dbgsym version 1.4.6-1ubuntu6.1
libpam-modules-bin version 1.1.3-1ubuntu3 required, but 1.1.3-2ubuntu1 is available
outdated debug symbol package for busybox-initramfs: package version 1:1.18.4-2ubuntu1 dbgsym version 1:1.17.1-10ubuntu1
libfontconfig1 version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
indicator-session version 0.3.1-0ubuntu1 required, but 0.3.2-0ubuntu1 is available
outdated debug symbol package for libk5crypto3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
libindicator3-6 version 0.3.92-0ubuntu1 required, but 0.3.93-0ubuntu1 is available
libudev0 version 172-0ubuntu5 required, but 173-0ubuntu3 is available
udev version 172-0ubuntu5 required, but 173-0ubuntu3 is available
outdated debug symbol package for libavahi-client3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for passwd: package version 1:4.1.4.2+svn3283-3ubuntu2 dbgsym version 1:4.1.4.2+svn3283-3ubuntu1
outdated debug symbol package for libkrb5-3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
libldap-2.4-2 version 2.4.25-1.1ubuntu2 required, but 2.4.25-1.1ubuntu4 is available
fontconfig-config version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libklibc version 1.5.22-1ubuntu1 required, but 1.5.22-1ubuntu2 is available
libglib2.0-0 version 2.29.14-0ubuntu1 required, but 2.29.16-0ubuntu2 is available
outdated debug symbol package for libdbus-1-3: package version 1.4.12-4ubuntu2 dbgsym version 1.4.6-1ubuntu6.1
libcups2 version 1.5.0-1ubuntu1 required, but 1.5.0-5 is available
libc-bin version 2.13-16ubuntu1 required, but 2.13-17ubuntu2 is available
libgtk-3-0 version 3.1.10-0ubuntu3 required, but 3.1.12-0ub...

Read more...

tags: removed: need-i386-retrace
Bernd Schlapsi (bernd-sch) wrote :

Before closing this bug could someone explain what I should do to report this bug correctly?

I installed Ubuntu Onieric 11.10 a few days ago (of course with all the updates). After I turne on my PC and logg into my account the system crashes 3-4 times, every time!
I reported all this crashes with YOUR bug tracking/collecting tools. This errors are reproducible because they occur every time I boot my maschine.

Every day I start
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
and there are no new packages to install.
If my system is outdated then there is only one reason. You/Ubuntu don't provide newer version of the needed software.

So could someone please explain me how I could update my system correctly or report the bugs so that they are useful to others?
Ubuntu Onieric is the most unstable Ubuntu/Linux version I have ever tried and I use Ubuntu since Ubuntu 5.04 - Hoary Hedgehog. And it's not the first time I installed a Alpha/Beta version to help improving the system.

Conor Curran (cjcurran) wrote :

Hi,
Thanks for reporting this. Our retracers were broken up until this week hence why the automatic bug closing mechanism. It does seem like a valid bug and you are not the first to have reported it. Do you experience this continuously ?

Conor

Changed in indicator-session:
status: Triaged → In Progress
jerrylamos (jerrylamos) wrote :

Still occurring on daily build 25 August.

Linux version 3.0.0-9-generic (buildd@zirconium) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-7ubuntu1) ) #14-Ubuntu SMP Tue Aug 23 17:02:50 UTC 2011

Will try on 26 August.

This occurs on every single boot shortly after the full desktop appears.

ATI Technologies Inc RC410 [Radeon Xpress 200]

Jerry

After the last few updates this still affects me. Every boot, even just at the LightDM the Power/Session button just simply displays a small blank rectangle. Shutting down/rebooting the machine must be done via the command line because of this.

The interesting thing is I've seen videos and articles on the latest updates to Oneric (say OMG Ubuntu for example) and they don't seem to always have this problem.

Running the terminal command still spits out this output even after the last few updates:
$ /usr/lib/indicator-session/indicator-session-service

(process:5349): LIBDBUSMENU-GLIB-CRITICAL **: dbusmenu_menuitem_property_set_variant: assertion `DBUSMENU_IS_MENUITEM(mi)' failed

(process:5349): LIBDBUSMENU-GLIB-CRITICAL **: dbusmenu_menuitem_property_remove: assertion `DBUSMENU_IS_MENUITEM(mi)' failed
(process:5349): Indicator-Session-DEBUG: Lock screen shortcut: <Control><Alt>l
Segmentation fault (core dumped)

lidex (mh40) wrote :

Exact same as #15. After 8/26 updates.
Output of /usr/lib/indicator-session/indicator-session-service has changed from
 "(process:2826): Indicator-Session-DEBUG: Unable to get lock screen shortcut."
to
"(process:2572): Indicator-Session-DEBUG: Lock screen shortcut: <Control><Alt>l"
Clearly something has changed, but it still segfaults.

jerrylamos (jerrylamos) wrote :

Brand new 27 August daily build live on real hardware. Boot up, wait a few seconds, error pops up. A few seconds later, error pops up again. .....

3.33 gHz Compaq ati radeon xpress 200.

jerrylamos (jerrylamos) wrote :

For comment #17

Linux version 3.0.0-9-generic (buildd@zirconium) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-7ubuntu1) ) #14-Ubuntu SMP Tue Aug 23 17:02:50 UTC 2011

oneiric-desktop-i386.iso 27-Aug-2011 08:23 695M Desktop CD for PC (Intel x86) computers (standard download)

Do note the top right indicator (?) the power off switch doesn't display anything.

Jerry

The problem, in my case, is that g_udev_client_query_by_subsystem (mgr->client, video4linux_subsystem)[1] is returning devices that are not video devices (webcams). I have a PCTV board instaled in my system, and this method is returning (wrongly) /dev/radio0 as a video4linux device.

The crash is happening in udev_mgr_handle_webcam, because both 'vendor' and 'product' are null (again, because the device is not a webcam).

The attached patch solves the crash in my system.

[1] this call is in udev_mgr_new method, in udev-mgr.c

tags: added: patch
Richard Somlói (ricsipontaz) wrote :

How can I test this patch? I tried to find the udev-mgr.c file, but no luck.

Richard Somlói (ricsipontaz) wrote :

Okay, I did it and it is works for me:

Edgardo Fredz (edgardo-fredz) wrote :

#21: How did you do it?

renbag (renbag) wrote :

Like reported in comment #19, the indicator session crashes on my desktop machine in presence of the following multimedia card:

02:07.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
Subsystem: ASUSTeK Computer Inc. My Cinema-P7131 Hybrid
Flags: bus master, medium devsel, latency 64, IRQ 21
Memory at fbfff800 (32-bit, non-prefetchable) [size=2K]
Capabilities: [40] Power Management version 2
Kernel driver in use: saa7134
Kernel modules: saa7134

02:07.0 0480: 1131:7133 (rev d1)

This card is uncorrectly recognized by cheese as a webcam.
Removing the card from the computer restores the full indicator-session-service.

lidex (mh40) wrote :

Edgardo
Have a look here:
http://ubuntuforums.org/showpost.php?p=11200596&postcount=23
At the end you will find the rebuilt package in the is_build folder.
I can confirm the patch from comment #19 solved my problem.
03:07.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
03:07.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)
03:07.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)
(ATI HDTV Wonder card)

Same here, patch in comment #19 solved the problem for me too.

Turns out I also have a device acting like a webcam, a Winfast DTV1000 TV PCI Tuner Card:

06:01.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
06:01.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)

With the patch applied all session menus and functionality is restored. Thank you.

Conor Curran (cjcurran) wrote :

thanks guys, will merge that in now.

Changed in indicator-session (Ubuntu):
status: Invalid → In Progress
Changed in indicator-session:
milestone: none → 0.3.4
Conor Curran (cjcurran) on 2011-08-30
Changed in indicator-session:
milestone: 0.3.4 → 0.3.3
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2011-08-31
Changed in unity-foundations:
status: New → Fix Committed
Changed in indicator-session:
status: Fix Released → Fix Committed
milestone: 0.3.3 → 0.3.4
Changed in unity-foundations:
milestone: none → oneiric-beta-2
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → High
Conor Curran (cjcurran) on 2011-09-01
Changed in indicator-session:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.4.1-0ubuntu1

---------------
indicator-session (0.3.4.1-0ubuntu1) oneiric; urgency=low

  [Ken VanDine]
  * New upstream release.
    - in a Guest session user menu is not visible (LP: #834948)
    - User name shown as [Invalid UTF-8] in live session (LP: #837246)
    - "Reboot Required" menu opens Update Manager, doesn't reboot (LP: #837658)
    - indicator-session-service crashed with SIGSEGV in
      g_str_hash() (LP: #824243)
    - indicator-session-service crashed with SIGSEGV in
      g_variant_unref() (LP: #833965)
  * +debian/patches/revert_icon_change.patch
    - revert the icon change in greeter mode until a UIF exception is
      approved
  * +debian/source/format

  [Ted Gould]
  * debian/control: Adding a depend on gnome-settings-daemon to ensure that
    the required schemas are available. (LP: #833965)
 -- Ken VanDine <email address hidden> Thu, 01 Sep 2011 13:53:50 -0400

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
Dmitry-Kogura (dmitry-kogura) wrote :

I made upgrade to beta 1 (indicator-session 3.3.4), session menu became visible. Thank you.
But error indicator-session-service crashed with SIGSEGV in g_str_hash() occurs again and again

tags: added: iso-testing
Conor Curran (cjcurran) on 2011-09-02
Changed in unity-foundations:
status: Fix Committed → Fix Released
David Horváth (chronos-hun) wrote :

I just upgraded to 11.10 and have this problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers