[oneiric] Optionally hide user name in panel

Bug #812728 reported by Jean-Baptiste Lallement on 2011-07-19
114
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Wishlist
Conor Curran
Unity Foundations
Wishlist
Conor Curran
indicator-session (Ubuntu)
Wishlist
Unassigned
Oneiric
Wishlist
Unassigned

Bug Description

Oneiric up to date

Since the latest update, the user name is displayed on the panel.
1. This information _never_ changes and generally the user knows who he is, and the account he logged into
2. It uses lot of precious panel space, nearly 15% in the case of the screenshot attached.

This is a regression from Ubuntu 10.10 and 11.04. There used to be an undocumented gconf setting to either hide the username, show the username, or show the user's full name. This needs to be returned as a gsettings schema. Please see bug 604506 where the previous functionality was discussed.

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: indicator-session 0.2.93-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic i686
Architecture: i386
Date: Tue Jul 19 09:21:57 2011
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bashSourcePackage: indicator-session
UpgradeStatus: Upgraded to oneiric on 2011-07-12 (6 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Omer Akram (om26er) wrote :

its a bug not a feature, indicator-session did not add any such features, It could be one of the left outs of indicator-me or you are not using the latest unity that totally does not look for libme.so

Jean-Baptiste Lallement (jibel) wrote :

I'm using :
$ apt-cache policy unity
unity:
  Installed: 4.2.0-0ubuntu4

(-0ubuntu5 being an ABI bump on compiz, we can consider it is the latest)

Also note that indicator-me is not installed.

Sebastien Bacher (seb128) wrote :

The idea there is that:

- the name is only displayed if you have several users
- clicking on it will display the user switching menu (i.e the switch to another user, start a guest session, etc)

The issue there is that menu doesn't display as it should, it does work on the unity greeter though so it's somewhat an issue under an unity desktop environment

Changed in indicator-session (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in indicator-session:
importance: Undecided → High
status: New → Confirmed
Changed in indicator-session (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Ted Gould (ted) on 2011-07-19
summary: - Displaying user name in panel is pointless and wastes space.
+ User Menu is not getting its menu from the service
Changed in indicator-session:
assignee: nobody → Conor Curran (cjcurran)
David Barth (dbarth) on 2011-07-20
Changed in indicator-session (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Conor Curran (cjcurran)

This bug was fixed in the package indicator-session - 0.3.0-0ubuntu1

---------------
indicator-session (0.3.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - fixed bug where the user menu wouldn't open in unity (LP: #812728)
    - Include apt, settings and device menus
  * debian/rules
    - Updated gtk configure args
 -- Ken VanDine <email address hidden> Fri, 22 Jul 2011 13:41:08 -0400

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

@Ted, thanks for fixing another bug (which was actually the bug you marked as dup) and changing the title to something that maybe suit more with what you wanted to fix but it is really not what the purpose of this report is.

The description is about how pointless it is to show me my name and the space is uses on the panel. My name alone uses more space than the time/date, sound, battery and message indicator together.

I understand it is a design decision to show the user name when there are more than 1 account on the system, even if it is arguable, but at least make it configurable.

For example, even if more than one person uses this system, they never (_never_) switch session but always uses the login menu, and they usually know who they are.

Thanks.

Changed in indicator-session (Ubuntu):
status: Fix Released → Triaged
summary: - User Menu is not getting its menu from the service
+ Displaying user name in panel is pointless and wastes space.
Jeremy Bicha (jbicha) on 2011-08-05
summary: - Displaying user name in panel is pointless and wastes space.
+ Optionally hide user name in panel
summary: - Optionally hide user name in panel
+ [oneiric] Optionally hide user name in panel
Changed in indicator-session (Ubuntu):
importance: High → Wishlist
description: updated
tags: added: regression-release
Conor Curran (cjcurran) wrote :

This is a design issue, please take it up with MPT

Changed in indicator-session:
assignee: Conor Curran (cjcurran) → Matthew Paul Thomas (mpt)
Changed in indicator-session (Ubuntu):
assignee: Conor Curran (cjcurran) → nobody
status: Triaged → Confirmed
Changed in indicator-session:
importance: High → Wishlist
Paul Collins (pjdc) wrote :

I would up hacking indicator-session locally to omit the label.

In case it's of interest, here's the change I made and a screenshot of the result.

Paul Collins (pjdc) wrote :
Rocko (rockorequin) wrote :

My indicator-session shows the name even though there is only one user in the system (presumably it considers 'Guest' to be the second user??!).

So the current incarnation of indicator-session does not meet the design requirement, ie which is to only show the name if there are several users as per Sebastien's comment (comment #4).

Matthew Paul Thomas (mpt) wrote :

Rocko, that is not accurate (see <https://wiki.ubuntu.com/DeviceMenuAndUserMenu#User_menu>) and more importantly, not related to this bug report. If you think the visibility of the menu should be changed, please report that bug separately. Thanks.

Rocko (rockorequin) wrote :

@Matthew: OK, I was relying on what Sebastien said in comment #4 - he is almost always reliable in these cases.

But in any case, for the record, I *would* prefer to the option to *not* show an icon of a pawn and my username in the session menu. It would be better if this menu were a separate application, ie so that I could remove without removing the 'suspend', 'shutdown', 'system settings', etc. options. Like in the old days when the username was in the indicator-me application. Why does Canonical appear to be so against users having configuration options these days, anyway?

Matthew Paul Thomas (mpt) wrote :

It was a Canonical engineer who implemented all the clock configuration options in the Time & Date Settings, and another Canonical engineer who implemented the "Show Time in Menu Bar" option in the battery menu. In contrast, nobody outside Canonical has bothered to fix bug 829690, bug 829673, bug 829664, bug 811769, or bug 829648, to give just five examples. So your "why won't you people give me more free stuff?" question would make more sense (though not much more) if addressed to people who don't work for Canonical rather than people who do.

To return to the topic of this bug report, an option for whether to show the account icon instead of the account name probably should be presented in a similar way to that "Show Time in Menu Bar" option in the battery menu. Maybe two radio items in the menu. But I haven't figured out yet how they would be worded. For example,

    ◉ Name as Menu Title
    ○ Icon as Menu Title

is dull because it repeats "as Menu Title". But without those three words, there would be no clue as to what the items were for. "Menu Title:" could be put in a header, but headers in menus are a bit lame too.

Rocko (rockorequin) wrote :

Having that as an option sounds great. Rather than two menu buttons, I think we would only need one (checkbox) option, "Show Name In Menu Title" or similar. The battery menu's option "show time in menu bar" acts as a checkbox rather than a radio button, so having one option here would be consistent.

If the user selects not to show the name, is there a better title perhaps that we could use for the menu? The menu seems to have two purposes: (1) to switch between users, (2) provide quick access to the User system settings and to the Online Accounts user settings, so some word that encompasses both might do. Failing that, the icon would be sufficient, notwithstanding my slight objection that it resembles a pawn.

TH (thaugseth) wrote :

A checkbox sound best in my opinion, like the battery-option. To make it consistent with the battery-indicator, the option should be placed right above "Online Accounts" but in the same group, and the text should probably be "Show Name in Menu Bar".

If you hide the name, only the icon would be visible. I don't think it's necessary with some alternate text. A part of the "problem" as I see it is that the text takes up unnecessary space in the panel.

Regarding the icon: I think the current icon resembles user-relations more than a pawn among most users :-) Google uses a similar icon in Google+, Facebook uses it to indicate friends (as opposite to public). It has also been the previous default "avatar" in the Evolution address book. Anyway, it's not easy to make an icon that small without loosing some details.

Rocko (rockorequin) wrote :

Apologies in advance if this is slightly off-topic: reading the blueprint, a theoretical workaround is to disable the guest account (ie since the menu appears whenever the system allows a guest session *or* when there is more than one user account).

However, I cannot find a way to do this (I looked in the user-admin and the old users & groups admin as well as the dash but without success; looking in Synaptic I thought that gdm-guest-session might be providing this functionality, but it isn't, and ubuntu-questions hasn't been able to provide an answer yet.) Does somebody here know how to disable the guest account?

TH (thaugseth) wrote :

@Rocko: See Bug #835084

Matthew Paul Thomas (mpt) wrote :

Nice thinking, Rocko. "✓ Show Name in Menu Bar" it is, then. Specification updated. <https://wiki.ubuntu.com/DeviceMenuAndUserMenu?action=diff&rev2=13&rev1=12>

Changed in indicator-session:
assignee: Matthew Paul Thomas (mpt) → nobody
Conor Curran (cjcurran) wrote :

This could also be a gsetting which will remove the need for a checkbox.

Just to clarify,

"When unchecked, the menu title is the generic user icon "
i.e. just the icon, no text ?

Matthew Paul Thomas (mpt) wrote :

Yes. When unchecked, just the icon. When checked, just the full name.

Conor Curran (cjcurran) wrote :

For this release I will create a new gsettings boolean entry 'show-real-name-on-panel'. This will toggle the visibility of the text.
For next cycle the maintainer can complete this task.

Changed in indicator-session:
status: Confirmed → In Progress
Changed in unity-foundations:
status: New → In Progress
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-session:
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.3.5
Changed in unity-foundations:
milestone: none → oneiric-beta-2
importance: Undecided → Wishlist
Conor Curran (cjcurran) on 2011-09-08
Changed in indicator-session:
status: In Progress → Fix Released
Changed in unity-foundations:
status: In Progress → Fix Released
Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Committed
Conor Curran (cjcurran) on 2011-09-09
Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
aloisam (a-musil) wrote :

fix released? Ok. So how can i hide user name in panel? Thanks.

@aloisam (a-musil)
You need to install dconf-editor (sudo apt-get install dconf-editor) then launch it and go to apps -> indicator-session.

And uncheck the show-real-name-blah-blah-blah checkbox.

aloisam (a-musil) wrote :

@moigagoo Thank you. You saved my day. :)

Vincenzoml (vincenzoml) wrote :

The package is now named "dconf-tools" I guess. It would be lovely if these options could be set based on the percentage of the panel that stays free: a netbook easily becomes unusable; there is too few space for the application menus in oneiric by default. Let me know if this is not already into consideration, then I could open a bug report or a feature request or whatever is appropriate.

@vincenzoml Au contraire, the needed package is called dconf-editor, and it was previously named gconf-editor.
Which doesn't necessarily mean there's no such package as dconf-tools :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers