Change "Restart Required..." to "Restart To Complete Update..."

Bug #586928 reported by Wouter Stomp on 2010-05-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
One Hundred Papercuts
Low
Vish
Session Menu
Fix Released
Low
Cody Russell
indicator-session (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: indicator-session

The 'restart required' menu item seems a little odd, formulated as a message to the user instead of an action like the other items. A better text would be 'restart (required)...'.
-----
Suggestion to reword to "Restart To Complete Update..." from:
https://lists.launchpad.net/ayatana/msg03335.html

Related branches

Omer Akram (om26er) on 2010-05-28
Changed in indicator-session (Ubuntu):
importance: Undecided → Wishlist

  status triaged
  assign mpt

Changed in indicator-session (Ubuntu):
status: New → Triaged
Vish (vish) on 2010-07-31
summary: - Change "Restart Required..." to "Restart (Required)...
+ Change "Restart Required..." to "Restart To Complete Update..."
description: updated
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-8-potpourri
status: New → In Progress
description: updated
Changed in hundredpapercuts:
assignee: nobody → Vish (vish)
Cody Russell (bratsche) wrote :

mpt, can you comment on this? The code is ready, but I'd like to get design approval before I merge this in. The SessionMenu wiki page still says it should read "Restart Required..."

Changed in indicator-session (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Cody Russell (bratsche) on 2010-08-02
Changed in indicator-session:
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

Did anybody consider non english translations in that suggestion? "Neu starten, um Aktualisierung abzuschließen..." has been suggested on IRC as a possible german translation, it's quite verbose and will make the menu odd if the label is not ellipsized. Would be nice to stay on short labels for menus action if you can...

Sense Egbert Hofstede (sense) wrote :

Agreed. Dutch would be something like "Herstarten om het bijwerken af te maken", which is quite long, not something that fits in the menu without making it ridiculously wide.

Sense Egbert Hofstede (sense) wrote :

Also, using the suggested menu label would mean the menu item would break the consistency of the menu. Instead of listening actions -- which in e.g. Dutch are translated using infinitives -- it lists also ONE entry that gives a further description of the Restart item.

In English you can nicely paste the addition after Restart and the form of the verb stays the same, also because the used word is the same as the noun 'restart'. In Dutch, and probably in most other languages as well, this is not the case, and therefore the breakage of the menu's consistency, only superficially visible in English, becomes awkward, confusing and ugly.

Vish (vish) wrote :

The translators usually dont always use a literal translation, and probably shouldnt.[some of the words never work the same in every language]
The same concern was raised for Home folder naming <https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/382703#line-24>

Translations must not blindly done verbatim.

Vish (vish) wrote :

Also, even if the menu ends up longer for a translation, this is not a permanent menu item and is displayed only when a restart is
required. Which is better than having an ambiguous menu item which user would not easily understand. [If the user notices the start icon turning red , there is no indication why.]

A red Restart required can be mistaken even for system burning up and hence requiring a restart too. ;)

frizzle21 (frederik-nnaji) wrote :

At some point, hopefully, we will Command Metaphors for every control and button in the system, just like Visual Metaphors make things easier for icon development.

Once we start developing Command Metaphors, translation will no longer be a big issue.
Problems like the ones we're facing here would be easily traced back to the root of their regression.

Cody Russell (bratsche) on 2010-08-02
Changed in indicator-session:
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in ayatana-design:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.2.9-0ubuntu1

---------------
indicator-session (0.2.9-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Change "Restart Required..." to "Restart To Complete Update..."
      (lp: #586928)
    - Ellipsized strings.
 -- Sebastien Bacher <email address hidden> Thu, 05 Aug 2010 12:45:37 +0200

Changed in indicator-session (Ubuntu):
status: Triaged → Fix Released
Changed in indicator-session (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
frizzle21 (frederik-nnaji) wrote :

I think the interaction path becomes clear, when the color of the menu item (Restart..) corresponds with the state it has, and with the color of the indicator icon on top of the menu it is in, as suggested here:
https://lists.launchpad.net/ayatana/msg03343.html

once indicator icon and menu item both equally reflect the special state the system is in, a visible interaction path affords itself to the user from the top of the menu (symbolic indicator icon) down to the item that needs to be pressed in order to make the interaction happen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers