Indicator session menu uses 'switch off' instead of 'shut down'

Bug #1029036 reported by Nicholas Skaggs on 2012-07-25
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Medium
Unassigned
indicator-session (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

My locale is en-us. However, the indicator session menu has replace the american english term of 'shut down' for the british english 'switch off'. I would argue the 'shut down' term should remain for american english as it's universally understand; and has been the previous standard language in ubuntu.

$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES=en_US.UTF-8
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: indicator-session 12.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu5
Architecture: amd64
Date: Wed Jul 25 13:49:19 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: indicator-session
UpgradeStatus: Upgraded to quantal on 2012-07-20 (4 days ago)

Related branches

Nicholas Skaggs (nskaggs) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2012-09-12
Changed in indicator-session (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

"Switch Off" is not valid idiomatic American English, which is the baseline for open source software. I'm patching the Ubuntu package to change this back to "Shut Down" so that it's understood.

As far as I'm concerned it's entirely reasonable to use "Switch Off" when in an en_GB locale (what do I know, I'm American), but the appropriate means of doing this is adding that into an en_GB translation file - there is an en_GB translation team for localizing software, there is not an en_US translation team.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.2-0ubuntu2

---------------
indicator-session (12.10.2-0ubuntu2) quantal; urgency=low

  * Change the menu to say 'Shut Down' instead of 'Switch Off' by default,
    since the latter is completely non-idiomatic in American English; and
    update the translations for commonwealth English in the package to
    preserve the preferred wording for en_GB. LP: #1029036.
 -- Steve Langasek <email address hidden> Wed, 12 Sep 2012 11:50:03 -0700

Changed in indicator-session (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in indicator-session:
status: New → Fix Committed
Jeremy Bicha (jbicha) wrote :

By the way, GNOME Shell 3.6 uses "Power Off".

On Thu, Sep 13, 2012 at 01:12:56AM -0000, Jeremy Bicha wrote:
> By the way, GNOME Shell 3.6 uses "Power Off".

As an en_US speaker, I'd be perfectly fine with Power Off as well. But I'm
not proposing any further changes here; "Shut Down" is perfectly idiomatic
to me and I have no preference between the two, so if someone else has a
preference and wants to make a case for one over the other they're welcome
to do so, it's specifically Switch Off that fails the native speaker test.

Charles Kerr (charlesk) on 2012-09-13
Changed in indicator-session:
milestone: none → 12.10.3
Charles Kerr (charlesk) on 2012-09-19
Changed in indicator-session:
status: Fix Committed → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers