Empty session menu in ltsp client

Bug #1028972 reported by Jean-Baptiste Lallement on 2012-07-25
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
LTSP
Medium
Alkis Georgopoulos
Session Menu
Confirmed
High
Charles Kerr
indicator-session (Ubuntu)
High
Charles Kerr

Bug Description

Quantal Alternate 20120724.3

In an LTSP client the indicator session menu is empty. On the server side the menu is correct.

Screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: indicator-session 12.10.0-0ubuntu1
ProcVersionSignature: User Name 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
Date: Wed Jul 25 17:49:52 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.3)
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-session
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Changed in ltsp (Ubuntu):
importance: Undecided → High
Changed in indicator-session (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

Marking LTSP task invalid as we're not doing any explicit desktop configuration or override.

I believe this bug should be reproducable for anyone using unity-2d (and possibly 3d) over the network (DISPLAY=<ip>).

Changed in ltsp (Ubuntu):
status: New → Invalid
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1028972

tags: added: iso-testing
Stéphane Graber (stgraber) wrote :

I was hoping something as simple as:

Xephyr :1 -ac
env DISPLAY=<local ip>:1 LIBGL_ALWAYS_INDIRECT=true dbus-launch unity-2d-panel

Would reproduce it, but apparently it's more complex than that...

Starting to wonder if it could be related to the graphic card in use as I can't reproduce with Xephyr but definitely saw that bug in kvm.

Jean-Baptiste Lallement (jibel) wrote :

For reference I tested in Virtualbox without the vboxvideo module and got the same result.

Alkis Georgopoulos (alkisg) wrote :

Works fine for me in Virtualbox without any vbox modules (using ltsp trunk, not the version in 12.04, but I don't think there were any related changes since then except maybe for the dbus machine id).

Can you try with a new user, to verify that it's not related to broken gconf/dconf settings for this user?

Changed in indicator-session (Ubuntu):
assignee: nobody → Ted Gould (ted)
Omer Akram (om26er) on 2012-09-11
affects: ltsp (Ubuntu) → indicator-session
Changed in indicator-session:
status: Invalid → New
Omer Akram (om26er) on 2012-09-12
tags: added: pspriority
Omer Akram (om26er) on 2012-09-12
Changed in indicator-session (Ubuntu):
assignee: Ted Gould (ted) → nobody
Changed in indicator-session:
assignee: nobody → Charles Kerr (charlesk)
Omer Akram (om26er) on 2012-09-12
Changed in indicator-session (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-session:
status: New → Triaged
Changed in indicator-session (Ubuntu):
status: New → Triaged
Charles Kerr (charlesk) wrote :

I'm not able to reproduce this issue, and the session menu's been rewritten in the interim for 12.10.

jibel, could you retest this on your setup with 12.10 beta 1 or higher?

Changed in indicator-session:
status: Triaged → Incomplete
Changed in indicator-session (Ubuntu):
status: Triaged → Incomplete
tags: removed: rls-q-incoming
Stéphane Graber (stgraber) wrote :

It's still the case. Booting Edubuntu, then starting ltsp-live will give you an empty session menu, at least under kvm.

Changed in indicator-session (Ubuntu):
status: Incomplete → New
Beeresh (beeresh) wrote :

Having similar issue after updatign image (edubuntu 12.04) from thin client -> fat client.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Eugene San (eugenesan) wrote :

Same or similar happens in VNC/NX sessions: https://bugs.launchpad.net/indicator-session/+bug/1134169

Changed in indicator-session:
status: Incomplete → Confirmed
Shahar Or (mightyiam) wrote :

Can anyone please provide a work-around?

We hit this problem after upgrade from 12.04 to 13.04.

In 12.04, the session menu would appear empty only sometimes, and the problem could be easily resolved by restarting lightdm.
In 13.04, the session menu is always empty, no help.

Now we have our LTSP users sitting in front of their client not knowing how to log out!
(CTRL-ALT-DEL works, but people don't know it.)

Here's a workaround until indicator-session is fixed: Copy the attached file to /usr/share/applications/. This will add a "Log Out" entry to your unity dash / menu->system. You can even copy the file to your users' desktops.

Note: The menu entry will automagically get translated to your locale's language, don't ask be how they do it, it's the magic of gnomes you know...

(Credits: http://askubuntu.com/questions/126909/how-to-get-the-shutdown-restart-icon-back-in-dash)

Here's a possibly related issue:
After users log out, we frequently (always?) find processes of "session-indicator-service" owned by the user, which keep running and will not terminate unless the get manually killed by SIGKILL.
Are these runaway-processes related to the session menu displaying empty?

Is there a chance of this problem being solved in Saucy?

Calcaneo (unicandun) wrote :

I can confirm this problem with trusty.

We did a do-release-upgrade on the server, rebuilt the client image, but logout is not available for users.

Any newer solutions than #15?

Thanks for any help in advance.

Richard Lowe (ocdrichard) wrote :

Confirmed in trusty. Here is my work around:

Create the following file and copy it to your ltsp chroot folder /etc/xdg/autostart/

[Desktop Entry]
Type=Application
Exec=/usr/lib/unity/unity-panel-service
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=gnome-panel
Name=gnome-panel
Comment[en_US]=
Comment=

This bug still persists as today with Ubuntu 14.04.

Alkis Georgopoulos (alkisg) wrote :

I believe this was caused by missing environment variables in the session, like DESKTOP_SESSION, XDG_MENU_PREFIX etc.
I've fixed those upstream in LDM+LTSP and I've released them in the Greek schools PPA.

Can someone check if adding the PPA to their sources, both in their server and in the chroot, solves the issue?

Changed in ltsp:
importance: Undecided → Medium
status: New → Incomplete
Alkis Georgopoulos (alkisg) wrote :

Since noone answered in 4 months, and since the committed fix was addressing such a symptom, I'm marking it fix released.

If anyone sees it in Xenial, reopen the bug report.

Changed in ltsp:
assignee: nobody → Alkis Georgopoulos (alkisg)
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers