65 cups notifier processes running

Bug #959195 reported by Daniel Holbach on 2012-03-19
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
indicator-printers (Ubuntu)
Undecided
Lars Karlitski

Bug Description

I have 65 cups notifier processes running at the same time:

daniel@daydream:~$ ps afxvw | grep cups/notifier | grep -v grep | wc -l
65
daniel@daydream:~$

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cups 1.5.2-8
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
CupsErrorLog:
 W [19/Mar/2012:09:17:51 +0100] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MX870-series-Gray..' already exists
 W [19/Mar/2012:09:17:51 +0100] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MX870-series-RGB..' already exists
 W [19/Mar/2012:09:17:51 +0100] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Canon-MX870-series' already exists
Date: Mon Mar 19 12:17:16 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
Lpstat: device for Canon-MX870-series: usb://Canon/MX870%20series?serial=324A27&interface=1
MachineType: LENOVO 429149G
Papersize: a4
PpdFiles: Canon-MX870-series: Canon PIXMA MX870 - CUPS+Gutenprint v5.2.8-pre1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-19-generic root=UUID=51ab960b-a2da-4841-98ce-c017f0582971 ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: Upgraded to precise on 2012-02-16 (32 days ago)
dmi.bios.date: 05/18/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET46WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 429149G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET46WW(1.16):bd05/18/2011:svnLENOVO:pn429149G:pvrThinkPadX220:rvnLENOVO:rn429149G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 429149G
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO

Related branches

Daniel Holbach (dholbach) wrote :
Hernando Torque (htorque) wrote :

Seeing this on two Precise systems, one shows 52 such processes, the other 100.

Changed in cups (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) wrote :

Argh, cramming dbus into cups' notification system was never a good idea.

I can reproduce this on my system, will try to have a fix before beta2 freeze.

Changed in cups (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
Lars Karlitski (larsu) on 2012-03-20
affects: cups (Ubuntu) → indicator-printers (Ubuntu)
Changed in indicator-printers (Ubuntu):
status: Confirmed → Fix Committed
Lars Karlitski (larsu) wrote :

This was really indicator-printers fault (aka "my fault"). I have some excuses for this, but I'm sure nobody wants to hear them ;)

The problem is, that indicator-printers-service creates cups subscriptions on startup to get dbus notifications to stuff like "somebody is printing something" or "a printer has run out of toner". It correctly cancels those subscriptions when it is terminated. However, apparently indicators aren't terminated gracefully most of the time, so lots of stray subscriptions were left over. CUPS creates a process for each subscription, which are all those processes that you noticed.

I've fixed indicator-printers to create subscriptions with a timeout, which it renews every 15 minutes. If it dies, the subscription will be canceled by cups automatically. This is much more sensible than what I had before.

If you don't have any other subscriptions to cups (email, rss), you can get rid of all those processes by deleting it's subscriptions.conf and cache:

  sudo stop cups
  sudo rm /etc/cups/subscriptions.conf
  sudo rm -r /var/cache/cups
  sudo start cups

Thanks *a lot* for making me aware of this, and sorry for the inconvenience.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-printers - 0.1.5-0ubuntu1

---------------
indicator-printers (0.1.5-0ubuntu1) precise; urgency=low

  * New upstream release.
    - translate accessible description (LP: #957522)
    - set lease durations on cups subscriptions (LP: #959195)
    - draw number of jobs as lozenge
 -- Lars Uebernickel <email address hidden> Tue, 20 Mar 2012 18:50:39 +0100

Changed in indicator-printers (Ubuntu):
status: Fix Committed → Fix Released
Daniel Holbach (dholbach) wrote :

This is still an issue:

daniel@daydream:~$ ps afxvw | grep cups/notifier | grep -v grep | wc -l
66
daniel@daydream:~$

Changed in indicator-printers (Ubuntu):
status: Fix Released → Confirmed
Jamie Strandboge (jdstrand) wrote :

Still an issue for me too. I did what was suggested in comment #4 and it didn't work.

Hernando Torque (htorque) wrote :

It's fixed for me after doing what's suggested in comment #4.

Lars Karlitski (larsu) wrote :

htorque just pointed out to me on irc that CUPS may have multiple subscriptions.conf.

Updated instructions (notice the star at the end of line 2):

  sudo stop cups
  sudo rm /etc/cups/subscriptions.conf*
  sudo rm -r /var/cache/cups
  sudo start cups

This will only get rid of the processes that are currently running. You need the updated package (see comment #5) to make sure no new ones are created.

Daniel Holbach (dholbach) wrote :

I agree with comment #9, this seems to make it work. How can we make sure there are not dozens of subscriptions lying around? (There might be people who don't read the comments on this bug report.)

Lars Karlitski (larsu) wrote :

Daniel, we can't automatically delete subscriptions, as those could have been added manually.

I'm closing this bug now, because my patch for indicator-printer fixed this in precise.

Changed in indicator-printers (Ubuntu):
status: Confirmed → Fix Released
Al Stone (ahs3) wrote :

Hrm. I'm still seeing this on precise with indicator-printers 0.1.6-0ubuntu1 -- I get 45 processes running. Further, trying the suggestions in comment #4 did not help either. So it's not fixed on my system for some reason (everything up to date for precise, including precise-proposed, as of ~05:30 UTC.

Lars Karlitski (larsu) wrote :

Al, do you have multiple subscriptions.conf laying around in /etc/cups/ (see comment #9)?

Al Stone (ahs3) wrote :

@Lars: thanks -- I missed that part of the comments. That does the trick. I'm down to just the one process I expect. Never mind :).

Six years later, this is still a problem in Ubuntu 16.04.3:

$ ps -ef | grep cups
root 478 1 0 14:31 ? 00:00:00 /usr/sbin/cupsd -l
lp 584 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 585 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 586 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 587 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 588 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 589 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
lp 590 478 0 14:31 ? 00:00:00 /usr/lib/cups/notifier/dbus dbus://
tigran 2017 1330 0 14:36 pts/9 00:00:00 grep --color=auto cups

I followed the suggestion in comment #4 and it got rid of the notifier processes BUT in a short time (a day or two) they came back, about one or two processes a day. So, the fix does not appear to be working.

Note that this is not just plain "indicator-printers" setup --- I am running HP notifier "hp-systray" which is part HPLIP (without it my printer wouldn't work as it is a "windows only" printer LaserJet Pro M102a).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers