Power indicator shows battery not present and the actually used battery at the same time

Bug #863518 reported by Ingo Gerth on 2011-09-30
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Upower
Invalid
Undecided
Unassigned
indicator-power
Invalid
Undecided
Unassigned
indicator-power (Ubuntu)
Undecided
Unassigned

Bug Description

See the screenshot, it explains best.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-power 0.9-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CheckboxSubmission: 05c436e63dfa019ccd464d7387e4a841
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Fri Sep 30 20:03:14 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110824)
SourcePackage: indicator-power
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (0 days ago)
---
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CheckboxSubmission: 05c436e63dfa019ccd464d7387e4a841
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110824)
NonfreeKernelModules: nvidia
Package: indicator-power 0.9-0ubuntu2
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Tags: oneiric running-unity
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-10-02 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ingo Gerth (igerth) wrote :
Javier Jardón (jjardon) wrote :

Seems that the upower reports that you have 2 batteries, Is this the case?

Changed in indicator-power:
status: New → Incomplete
Ingo Gerth (igerth) wrote :

No, that is certainly not the case.

Ingo Gerth (igerth) wrote :

I'm using an HP Elitebook 8560w in case that helps.

Javier Jardón (jjardon) wrote :

Hello Ingo,
Seems a bug in upower. Anyway I added a workaround in the indicator-power to try to fix this

Changed in indicator-power:
status: Incomplete → Fix Committed
Ingo Gerth (igerth) wrote :

Javier, thanks a lot for the fix. I'll keep an eye out whether it is fixed once I receive the update.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu):
status: New → Confirmed

I've duplicated a bug report that I opened a couple of weeks ago with this same issue. In my case the bug is critical, as sometimes the wrong battery comes first and the system thinks it has run out of battery and shuts down.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 0.9-0ubuntu2

---------------
indicator-power (0.9-0ubuntu2) oneiric; urgency=low

  * src/indicator-power.c
    - Add a workaround to fix the case when we get a empty bay as a real
      battery. (LP: #863518)
 -- Ken VanDine <email address hidden> Mon, 03 Oct 2011 10:35:48 -0400

Changed in indicator-power (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-power:
status: Fix Committed → Fix Released
Changed in upower:
status: New → Invalid
Ingo Gerth (igerth) wrote :

I'm sorry to report this, but the bug still is not fixed. See screenshot.

The description of your patch stated that it fixed a case where an empty bay was interpreted as a battery. However, I am not aware that my laptop even has a second bay.
http://www.hp.com/hpinfo/newsroom/press_kits/2011/businessmobility/HPEliteBook8560wDatasheet.pdf

-> Setting back to "confirmed".

Changed in indicator-power:
status: Fix Released → Confirmed
Changed in indicator-power (Ubuntu):
status: Fix Released → Confirmed
tags: added: apport-collected
description: updated

apport information

apport information

apport information

Ingo Gerth (igerth) wrote :

Wrong screenshot previously.

In my case I haven't seen this bug any more after the update in indicator-power that included this patch. And I don't have a second battery either, but I had exactly Ingo's screenshot.

Ingo, have you check if you also see this with another user profile in your system? Just to discard that there is not something related to some user file in your profile causing the update to not working in your system.

Javier Jardón (jjardon) wrote :

Hello,

As I said before, this is not a bug in indicator-power (It only shows the data reported by upower), but in the kernel instead.

Changed in indicator-power:
status: Confirmed → Invalid
Changed in indicator-power (Ubuntu):
status: Confirmed → Invalid
casey hyde (caseyjhyde) wrote :

I am still having this problem after the update, and it is also still causing my system to shut down any time I unplug my laptop (even briefly) or resume from suspend.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers