Dual SIM devices show "No SIM" icon in indicators if there is only one SIM installed

Bug #1607291 reported by Michael Zanetti on 2016-07-28
112
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Pat McGowan
Ubuntu UX
Undecided
Paty Davila
indicator-network (Ubuntu)
Undecided
Unassigned

Bug Description

rc-proposed, since about a week I have 2 SIM icons in the indicators panel. One that shows the signal strength for the installed SIM card (which is fine), and then a second one which shows the "no SIM card" icon.

When there is a SIM card installed, the indicator should not show a "no SIM installed" icon, even though there would be a second free slot available.

See attached screenshot.

Michael Zanetti (mzanetti) wrote :
Pat McGowan (pat-mcgowan) wrote :

@michael this was done to meet carrier certification requirements.

Changed in canonical-devices-system-image:
status: New → Incomplete
Changed in indicator-network (Ubuntu):
status: New → Incomplete
Michael Zanetti (mzanetti) wrote :

Ah ok. If this is intentional, then ok. Looked like a mistake to me, but no problem then. I suppose we can close this as invalid then.

Changed in indicator-network (Ubuntu):
status: Incomplete → Invalid
no longer affects: canonical-devices-system-image

Shouldn't we have a setting to "deactivate" the 2nd SIM slot ? So if we want to use one and only one SIM we're not annoyed by this indicator.

Oliver Grawert (ogra) wrote :

well, what about devices like the MXpro5 where when you have an SD card you can not actually use a second sim, it is quite unlogical to show that icon when you have a shared slot that is used in other context ...

could we make this not a conditional thing so that if a carrier requires it it can be turned on (with some gsettings key from the custom tarball) for the phones this carrier offers ?

Hans-Peter (hanspeterg) wrote :

I think the icon for the missing 2nd sim card shouldn't be there. If you pull down at the network icons, the info is shown. In my opinion, this is good enough. The icon provides no useful information and wastes space at the top line.

Guillaume F (marsguo) wrote :

I've been looking at screenshots of dual-SIM Android phones (bq Aquaris 4.5, bq Aquaris X5, Oneplus 3…) and find none that had an empty SIM icons in the panel. Pictures on their respective websites show two (working) network icons, to emphasize the fact that those phones are capable of doing this. But if you look at reviews, hands-on etc, sometimes there is no SIM inserted (you only see the WiFi icon) and most of the time there's only one. And I could not find any picture with an empty SIM in the top panel.
Maybe someone who owns such a phone could confirm?
If I'm not mistaken, then how could Android not meet carrier certification requirements?
And how could carriers require an operating system to display useless information like that? Dual-SIM is just a feature that's becoming fairly standard, but it doesn't mean you have to use it. It would be just as silly to always display a Bluetooth icon when you just don't use it, a WiFi icon so that you are reminded that your phone is capable of Wifi, an icon for your GPU saying "hey, you're not using me right now!", etc. The top panel is small and should not be cluttered.

Ivo Xavier (ivoxavier) wrote :

And the bar indicator is getting very populated. For the network indicator we now have 3 icons, the wifi indicator can convergence between wifi connection and mobile data. The first time I saw it was confusing, because I was thinking that my only SIM card was having problems. We are repeating information...the user see the icon, then swipe down, and then see the same info. If the purpose is to warning the user, why not set this as a notification? Then people could enable or disable it in notifications panel. I think it would be a more elegant way of doing this.

1) turn on the phone;
2) insert SIM PIN;
3) A notification bobble appears saying NO SIM2 is detected;
4) User dismiss the notification.
5) If is annoying doing this on every reboot, disable system-settings notifications in notifications panel.

With this you match carriers requirements, and still provide a elegant way for that. As the way it is, the user is being 'almost forced' to add a second SIM card. Hope you're mind change on this

Guillaume F (marsguo) wrote :

@Ivo Xavier Very good idea! Same as SD cards. I find it annoying to have a notification for my SD card every time I boot my phone, but if I really don't want them, I can easily disable them in the notifications panel.

Michael Zanetti (mzanetti) wrote :

re-adding canonical-devices-system-image given the large amount of interest this brought up after the OTA-13 release.

Changed in indicator-network (Ubuntu):
status: Invalid → Incomplete
Andrea Bernabei (faenil) on 2016-09-22
Changed in ubuntu-ux:
assignee: nobody → Paty Davila (dizzypaty)
Pat McGowan (pat-mcgowan) wrote :

Perhaps we can make this an option that is enabled via config in custom tarball

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Pat McGowan (pat-mcgowan)
milestone: none → cta
Jeroen Hoek (mail-jeroenhoek) wrote :

If this becomes an option in 'custom tarball', does that mean I can access that option with the regular OTA updates?

Not sure what is the exact requirement for carrier certification but in my opinion showing the SIM Icons for each detected SIM cards is equally functional as showing the empty icons. That said, the only extra information that the empty SIM icon is adding is to tell the user that this phone is actually capable of using more than 1 card.

If the requirement is to always give a hint of the number of SIMs the phone is capable of, then a possible space-efficient solution would be to show which SIM is the indicator refering to. This could include the total number of slots like the page counters in a document: 1/2, 2/2. This means a user with only the second slot being used will have an indicator showing 2/2, a user using only the first slot will have 1/2, and a user with both will have 1/2 in one indicator and 2/2 in the other. For single SIM support it doesn't harm to show 1/1, but it could also default to not showing it explicitly.

Just an opinion... because I think showing both indicators all the time is a misuse of the limited space.

Best Regards,
Felipe.

Android doesn't seem to have this issue..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers