"Hide This Menu" item is missing

Bug #829664 reported by Matthew Paul Thomas on 2011-08-19
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Matthew Paul Thomas
Messaging Menu
Invalid
High
Unassigned
0.5
Won't Fix
Undecided
Unassigned
0.6
Invalid
High
Unassigned
indicator-messages (Ubuntu)
High
Unassigned
Nominated for Quantal by Matthew Paul Thomas

Bug Description

indicator-messages 0.4.94-0ubuntu1, Ubuntu Ocelot

1. Open the messaging menu and choose "Hide This Menu…"

What happens: The item isn't there.

What should happen: A confirmation alert appears explaining the function, and how to get the menu back if you change your mind.

<https://wiki.ubuntu.com/MessagingMenu#hide>

[Originally reported by "Eustace" in <http://www.omgubuntu.co.uk/2011/08/power-cog-icon-oneiric/#comment-291049247>.]

description: updated
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
importance: Undecided → High
Changed in indicator-messages:
status: New → Triaged
Omer Akram (om26er) on 2012-01-22
Changed in indicator-messages (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

Isn't it a bit inconsistent that no other indicator has a "hide this menu" option in the menu itself?

Not that there's any where else for this option to go...

Jani Uusitalo (uusijani) wrote :

Confirming the issue of not being able to get rid of indicator-messages apart from uninstalling it system-wide, but not agreeing with stuffing the menu with another item just for solving this. IMHO Indicator-messages should be de-/selectable in Startup Applications preferences (like indicator-multiload for instance is).

According to an answer on Ask Ubuntu [1], blacklisting all message-providers should hide indicator-messages altogether, but this doesn't seem to work in 12.04, apparently because status-providers (which are different from message-providers) are still using the menu. (U1 Control Panel also seems to still occupy it despite being blacklisted.)

I've even tried overriding indicator-messages' dbus service file with a hackish solution [2], but the envelope still insists on appearing (though without the associated menu).

* [1] http://askubuntu.com/a/15616/34756
* [2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=544483#42

Sebastien Bacher (seb128) wrote :

This bug is in contradiction with what is done of other indicators, is there any reason for that?

Olli Ries (ories) wrote :

according to John this is not per the spec/design, thus invalid

Changed in indicator-messages:
status: Triaged → Invalid
Matthew Paul Thomas (mpt) wrote :

John was misinformed. It is per the design, and defined in the specification at <https://wiki.ubuntu.com/MessagingMenu#hide>.

Other indicator menus end with a "Settings…" item that goes to the settings panel where you can turn the menu off. There is no settings panel for messaging in general, which is why the function stands alone in this case.

Changed in indicator-messages:
status: Invalid → Triaged
Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Triaged
Olli Ries (ories) wrote :

as John requested the change I would like to hear his final feedback before we proceed

tags: added: backlog
Matthew Paul Thomas (mpt) wrote :

Too late to fix this for P now, so let's track it in Q.

Changed in ayatana-design:
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

Now that the messaging menu (a) will be showing only those applications that are registered, and (b) won't show at all when no applications are registered, we don't need the "Hide This Menu" item at all any more. Hurrah! <https://wiki.ubuntu.com/MessagingMenu?action=diff&rev2=83&rev1=82>

Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in indicator-messages (Ubuntu):
status: Triaged → Invalid
John Lea (johnlea) wrote :

Closing bug because this option has been removed from the new indicator IA, see mpt's comment above

Changed in ayatana-design:
status: Fix Released → Invalid
John Lea (johnlea) on 2012-04-20
Changed in indicator-messages:
status: Triaged → Invalid
Pavlo Verba (pavlo.s.verba) wrote :

Ability to do this is one of the things crucial to GNU/Linux and one thing that Unity is missing at the moment; please reconsider about the "won't fix" status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.