Messaging menu should not be shown if all default apps say not to use it and no other apps say to use it

Bug #661059 reported by Iain Farrell on 2010-10-15
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Fix Released
High
Lars Karlitski
Unity
Invalid
Undecided
Unassigned
indicator-messages (Ubuntu)
Low
Unassigned

Bug Description

From the test case at <https://wiki.ubuntu.com/MessagingMenu#Menu_presence>:
1. Log in to a guest session.
2. In Thunderbird, set up an e-mail account.

What happens:
1. The messaging menu is present by default.

What should happen:
1. The messaging menu is not present by default.
2. The messaging menu immediately appears, containing Thunderbird but no chat status items or other applications.

Related branches

description: updated
tags: added: design
removed: natty sabdfl
Changed in unity:
status: New → Confirmed
Alex Launi (alexlauni) on 2010-11-16
Changed in unity:
status: Confirmed → Invalid
Changed in indicator-messages:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Invalid
Omer Akram (om26er) wrote :

opened ubuntu task as there was a duplicate bug.

affects: unity (Ubuntu) → indicator-messages (Ubuntu)
Changed in indicator-messages (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Ted Gould (ted) wrote :

I believe that this is fixed in the current builds. Please reopen if not. Thanks!

Changed in indicator-messages:
status: Confirmed → Fix Released
Changed in indicator-messages (Ubuntu):
status: Triaged → Fix Released
DAP (akadap) wrote :

Not really unity, This bug needs to be re-opened, but the other two options say fix-released, and it won't let me change them.

Changed in unity:
status: Invalid → New
DAP (akadap) wrote :

Somehow my first attempt at a comment got eaten

I just updated to 11.04. The menu under the envelope is empty, but the envelope is still there.

Why is the sound preference indicator part of the completely unrelated message notification indicator? These are unrelated items, and I do not want that envelope on my panel since it does not work with Thunderbird.

Omer Akram (om26er) on 2011-05-08
Changed in indicator-messages (Ubuntu):
status: Fix Released → New
Changed in unity:
status: New → Fix Committed
status: Fix Committed → Invalid
Bilal Akhtar (bilalakhtar) wrote :

Provided default apps use it now, does this mean this change is no longer needed?

Changed in indicator-messages:
status: Fix Released → Incomplete
Changed in indicator-messages (Ubuntu):
status: New → Incomplete
description: updated
Changed in indicator-messages:
status: Incomplete → New
Changed in indicator-messages (Ubuntu):
status: Incomplete → New
Bilal Akhtar (bilalakhtar) wrote :

Thank you MPT for adding that test case to the wiki page. Triaging bug.

Changed in indicator-messages:
status: New → Confirmed
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in indicator-messages (Ubuntu):
status: Confirmed → Triaged
Lars Karlitski (larsu) on 2012-09-04
Changed in indicator-messages:
milestone: none → 12.10.3
status: Triaged → In Progress
importance: Low → High
assignee: nobody → Lars Uebernickel (larsu)
Changed in indicator-messages:
status: In Progress → Fix Committed
Changed in indicator-messages (Ubuntu):
status: Triaged → Fix Committed
Lars Karlitski (larsu) on 2012-09-19
Changed in indicator-messages:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 12.10.3-0ubuntu1

---------------
indicator-messages (12.10.3-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - hide indicator when no application shows in the menu (lp: #661059)
    - remove apps as soon as they are uninstalled (lp: #864545)
    - make generated .gir compatible with vala (lp: #104496)
    - draw counts as lozenges (lp: #1046331)
    - show separators (lp: #1048245)
    - show chat presence in the panel (lp: #859905)
    - improve documentation
  * debian/control:
    - build-dep on latest libgtk-3-dev
 -- Didier Roche <email address hidden> Wed, 19 Sep 2012 10:23:43 +0200

Changed in indicator-messages (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints