Ubuntu

The text field should receive focus automatically

Reported by Conscious User on 2010-02-26
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Cody Russell
The Me Menu
Wishlist
Cody Russell
gwibber (Ubuntu)
Low
Cody Russell
Lucid
Low
Cody Russell
indicator-me (Ubuntu)
Low
Canonical Desktop Experience Team
Lucid
Low
Canonical Desktop Experience Team

Bug Description

Binary package hint: indicator-me

In Lucid Alpha 3, this is a problem with both the Me Menu and Gwibber itself. When Gwibber/MeMenu is opened, the focus is not on the text field. Thus, I cannot simply open it and start typing. Automatically focusing on the text field would improve usability.

In my opinion, this fills all the requirements of a paper cut.

ProblemType: Bug
Architecture: i386
Date: Fri Feb 26 10:06:15 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: indicator-me 0.2.4-0ubuntu3
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: indicator-me
Uname: Linux 2.6.32-14-generic i686

Conscious User (conscioususer) wrote :
Vish (vish) wrote :

Thanks for reporting this bug. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in indicator-me (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Vish (vish) wrote :

not a bug in gwibber

Changed in gwibber (Ubuntu):
status: New → Invalid
affects: gwibber → indicator-me
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Conscious User (conscioususer) wrote :

I think this *is* a bug in Gwibber too. If the user chooses not to use the MeMenu for posting, he will face the same problem when opening Gwibber: the text field does not receive focus automatically. He cannot just open Gwibber and start typing.

Vish (vish) wrote :

ConsciousUser , agreed , gwibber doesnt focus on the text field either.
But you have clumped two different apps in the same bug . Ideally if the bugs are separate it would have been better.

Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
David Barth (dbarth) wrote :

Will try.

Changed in indicator-me:
assignee: nobody → David Barth (dbarth)
importance: Undecided → Wishlist
milestone: none → ubuntu-10.04-beta-1
status: New → Triaged
Changed in indicator-me (Ubuntu Lucid):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Cody Russell (bratsche) on 2010-03-11
Changed in indicator-me:
assignee: David Barth (dbarth) → Cody Russell (bratsche)
Cody Russell (bratsche) on 2010-03-12
Changed in indicator-me:
status: Triaged → In Progress
Cody Russell (bratsche) on 2010-03-13
Changed in indicator-me:
status: In Progress → Fix Committed
Changed in indicator-me (Ubuntu Lucid):
status: Triaged → Fix Committed
Cody Russell (bratsche) on 2010-03-17
Changed in hundredpapercuts:
assignee: nobody → Cody Russell (bratsche)
status: Triaged → Fix Committed
David Barth (dbarth) on 2010-03-17
Changed in gwibber (Ubuntu Lucid):
status: Triaged → In Progress
status: In Progress → New
Cody Russell (bratsche) on 2010-03-17
Changed in gwibber (Ubuntu Lucid):
assignee: nobody → Cody Russell (bratsche)
status: New → In Progress
Cody Russell (bratsche) on 2010-03-17
Changed in gwibber (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-me - 0.2.5-0ubuntu2

---------------
indicator-me (0.2.5-0ubuntu2) lucid; urgency=low

  * Backport upstream fixes for this issues:
    - "The text field should receive focus automatically" (lp: #528302)
    - "status changes to offline on updates" (lp: #538923)
 -- Sebastien Bacher <email address hidden> Mon, 15 Mar 2010 16:09:06 +0100

Changed in indicator-me (Ubuntu Lucid):
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

Released in 0.2.5

Changed in indicator-me:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2010-03-24
Changed in indicator-me:
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
David Barth (dbarth) on 2010-03-24
Changed in gwibber (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Changed in indicator-me (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.93-0ubuntu1

---------------
gwibber (2.29.93-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Use MAX_MESSAGE_LENGTH for max length instead of hard coding 140
    - Changed the views to not emit the entire doc as a value
    - Set default focus to the text input widget (LP: #528302)
    - Made a string translatable, requested by the translations
      team (LP: #534667)
    - Patch from Gabor Kelemen setting translation domain for .ui
      files (LP: #538846)
    - Mark strings translatable, thanks Kelemen Gábor (LP: #520462)
    - Added X-GNOME-Gettext-Domain to allow translations of the desktop
      files to be loaded at runtime (LP: #538851
    - Use the desktopcouch API for excluding the DB and handle
      errors (LP: #539583)
    - Set window icons properly so they scale nicely
    - Set account IDs in desktopcouch to force merging on sync instead of
      creating dupes (LP: #535263)
  * debian/patches/lp_report_to_ubuntu.patch
    - File bugs against the package (LP: #551132)
 -- Ken VanDine <email address hidden> Wed, 17 Mar 2010 13:20:24 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Vish (vish) on 2010-03-30
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Conscious User (conscioususer) wrote :

This bug is now back in Maverick. Probably has something to do with the new feature of showing which accounts you are posting to in the field.

Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
Omer Akram (om26er) wrote :

this is the problem with indicator-me not gwibber for which I have reported bug 641453

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers