Ubuntu

datetime indicator won't show today's date if you've ever clicked on any others

Reported by Nick Moffitt on 2010-09-28
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Low
Karl Lattimer
Unity Foundations
Low
Karl Lattimer
indicator-datetime (Ubuntu)
Low
Karl Lattimer
Natty
Low
Karl Lattimer

Bug Description

Binary package hint: indicator-datetime

If you click on the date/time indicator and scroll through to any other month or day, it remains where you left it even after you click elsewhere and then back to re-open it. This means that if I browse January 1970, I can never learn from this tool what today's date is, as it will always show January 1970.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-datetime 0.0.6-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Tue Sep 28 14:09:17 2010
EcryptfsInUse: Yes
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-datetime

Nick Moffitt (nick-moffitt) wrote :
Ted Gould (ted) wrote :

Marking as wishlist as you can see what today's date is (it's written right above) but there's no way to move the calendar back to today's date.

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in indicator-datetime:
importance: Undecided → Wishlist
status: New → Confirmed
Nick Moffitt (nick-moffitt) wrote :

Oh wow, I didn't notice today's date was in there, because it was written in black on dark grey in the default theme. Nobody I'd asked in person about this could read that either.

Ted Gould (ted) wrote :

Adding an Ayatana Design task as we probably need to address the issue of having a button or some other way to return to today's date in the calendar on the menu.

Changed in ayatana-design:
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

Perhaps the date should simply be reset when the indicator menu is closed (for a few seconds).

David Barth (dbarth) on 2011-01-24
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Changed in indicator-datetime:
assignee: nobody → Karl Lattimer (karl-qdh)
Ben West (bwsithspawn00) wrote :

Having just missed turning in a homework because I thought it was last week, I would like to testify as to this bug's importance. I wouldn't expect it to keep highlighting the old date after the widget is closed, so I don't think a "clear" button is necessary: it can just remove the old date.

Karl Lattimer (karl-qdh) wrote :

This will require a fix to ido for "set date" which will have to be invoked on "about to show" in the indicator datetime.

Changed in indicator-datetime:
status: Confirmed → Triaged
Karl Lattimer (karl-qdh) wrote :

attached ido calendar menu item update which is half of a fix for this bug

Karl Lattimer (karl-qdh) on 2011-03-06
Changed in indicator-datetime (Ubuntu):
status: Confirmed → In Progress
Karl Lattimer (karl-qdh) wrote :

added some code to reset the calendar after a while yesterday, I'm testing that at the moment to make sure it works as expected, apparently mterry is going to be a hero and get a dbusmenu close signal in which would make this a lot better.

Karl Lattimer (karl-qdh) wrote :

mterry's opened/closed signal has been merged so will hook into that and ditch the timer.

Karl Lattimer (karl-qdh) wrote :

Setting this bug back to confirmed after testing seems to not work with toplevel menus, dbusmenu changes required.

Changed in indicator-datetime (Ubuntu):
status: In Progress → Confirmed
Karl Lattimer (karl-qdh) wrote :

I've created the following bug to group these calendar widget related issues;

"IDO calendar should replace GtkCalendar wrapper with a grid layout menu"
https://bugs.launchpad.net/ubuntu/+source/ido/+bug/742370

Sebastien Bacher (seb128) wrote :

Karl is that one likely to be fixed for natty?

Changed in indicator-datetime (Ubuntu):
importance: Wishlist → Low
Changed in indicator-datetime:
importance: Wishlist → Low
Karl Lattimer (karl-qdh) wrote :

I'll discuss with mterry if we can get the closed signal sent on menu close, that way we don't have to mess around with strange timers which might mess up the user experience more.

Karl Lattimer (karl-qdh) on 2011-04-08
Changed in indicator-datetime:
status: Triaged → In Progress
David Barth (dbarth) on 2011-04-12
Changed in unity-foundations:
milestone: none → unity-3.8.6
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Low
status: New → In Progress
Ted Gould (ted) on 2011-04-13
Changed in indicator-datetime:
status: In Progress → Fix Committed
milestone: none → 0.2.3
Ted Gould (ted) on 2011-04-14
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Changed in indicator-datetime (Ubuntu Natty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.3-0ubuntu1

---------------
indicator-datetime (0.2.3-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Use GTK directly for detecting when the menu appears and disappears
      to reset the date (LP: #649800)
    ∘ Handle items being removed from the locations list by choosing
      another item in the list (LP: #740948)
    ∘ Check for resume in the service and update the label as well
      (LP: #759854)
 -- Ted Gould <email address hidden> Thu, 14 Apr 2011 14:51:20 -0500

Changed in indicator-datetime (Ubuntu Natty):
status: Fix Committed → Fix Released
Karl Lattimer (karl-qdh) on 2011-04-15
Changed in unity-foundations:
status: In Progress → Fix Released
Sylwester (ubuntulinux-org) wrote :

After upgrading to saucy I have this problem so it seems to have resurfaced, version 13.10.0+13.10.20131023.2-0ubuntu1

I can confirm that. It's quite confusing.

Matthew Paul Thomas (mpt) wrote :

I don't know whether this was ever successfully fixed, but it is now tracked in bug 793450.

no longer affects: ayatana-design
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints