indicator-datetime shows all-day events one day too early

Bug #1000182 reported by Frederik Elwert on 2012-05-16
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
High
Unassigned
indicator-datetime (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Impact:
In the event list, indicator-datetime shows all-day events one day too early. In the calendar view, however, the correct days are marked as having events (bold).

Test Case:
When selecting a bold date with an all-day event, the event does not show in the list. When selecting the previous day, the event shows in the list, but with the wrong date (one day too early).

The attached screenshot shows this.

Regression potential:
Check that full day events are displayed on the correct day in the calendar widget and in the list bellow it

Related branches

Bilal Akhtar (bilalakhtar) wrote :

I don't have this issue. Seems like a localization (time format?) issue. Can anyone with the same locale as the reporter (German?) confirm this issue?

Ulrich Zeller (uzeller) wrote :

I can confirm this happening on all my Ubuntu (12.04) machines. As soon as I choose time settings for Berlin (German timezone or earlier/east), I get all events shown a day early. If I change my time settings to Greenland or farther west, the events are displayed with the correct day.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
philinux (philcb) wrote :

Just seen this bug. With London England birthdays were showing up a day early. Changing to rekjavik solves the problem.

It may be due to British summertime. I'll check end of this month when clocks go back to GMT

Tom Jaeger (thjaeger) wrote :

Trivial fix. Is indicator-datetime still being maintained?

The attachment "fix" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

@Tom: thanks for the fix, yes it's being actively maintained ...

is there any chance you could put up a merge request for that fix? Those are usually nicer for review and increase chances that somebody picks it up for review in a reasonable timeframe (though there might be a bit of delay in the next weeks to the Ubuntu Developpers Summit and people travelling)

Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
Changed in indicator-datetime:
importance: Undecided → High
Charles Kerr (charlesk) wrote :

So, the issue here is that the appointments returned to us by EDS have a timezone associated with them.

Tom's patch is a good improvement over the current code, since most appointments are probably going to be in the local time.

It might be better, though, if we check the tz that EDS gives us, and handle the display accordingly.

Charles Kerr (charlesk) wrote :

So after testing use cases a bit further it looks like EDS is sees all-day events like this, and the timezone is irrelevant:

> BEGIN:VEVENT
> UID:20121026T095149Z-3681-1000-3631-132@sita
> DTSTAMP:20121026T094847Z
> DTSTART;VALUE=DATE:20121031
> DTEND;VALUE=DATE:20121101
> TRANSP:TRANSPARENT
> SEQUENCE:3
> SUMMARY:Halloween
> CLASS:PUBLIC
> CREATED:20121026T095207Z
> LAST-MODIFIED:20121026T101948Z
> END:VEVENT

Also in non-all-day events, the begin & end times coming from e_cal_client_generate_instances_sync() are already adjusted from the entry's timezone to UTC. So I don't think there's any path where we need look at the ECalComponent's dtstart/dtend times' timezones.

Changed in indicator-datetime:
status: New → Fix Committed
Changed in indicator-datetime (Ubuntu Quantal):
importance: Undecided → High
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.2-0ubuntu4

---------------
indicator-datetime (12.10.2-0ubuntu4) raring; urgency=low

  * Backported r192 and r193, fix:
    - "shows all-day events one day too early" (lp: #1000182)
    - "Bogus insensitive events after clicking on different date"
       (lp: #1069177)
 -- Sebastien Bacher <email address hidden> Mon, 05 Nov 2012 17:23:13 +0100

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released

Hello Frederik, or anyone else affected,

Accepted indicator-datetime into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-datetime/12.10.2-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-datetime (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

the update displays all day events fine for me

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 12.10.2-0ubuntu3.1

---------------
indicator-datetime (12.10.2-0ubuntu3.1) quantal-proposed; urgency=low

  * Backported r192 and r193, fix:
    - "shows all-day events one day too early" (lp: #1000182)
    - "Bogus insensitive events after clicking on different date"
       (lp: #1069177)
 -- Sebastien Bacher <email address hidden> Mon, 05 Nov 2012 17:23:13 +0100

Changed in indicator-datetime (Ubuntu Quantal):
status: Fix Committed → Fix Released
Phil Wyett (u-k-i-t) wrote :

Could we have this fix ported back to 12.04 LTS.

Charles Kerr (charlesk) on 2013-09-09
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Wolf (drechsel) wrote :

On ubuntu 15.04, using evolution 3.16.10 pim, all contact birthdays are displayed one day too early. Several people from the evolution mailing list seem to be affected as well.

This didnt occur in ubuntu 14.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches