Input method config is completely translated in Saucy in Russian but shows untranslated

Bug #1225305 reported by Igor Zubarev on 2013-09-14
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
im-config (Debian)
Fix Released
Unknown
im-config (Ubuntu)
Low
Unassigned

Bug Description

Input method config is completely translated in Saucy in Russian but shows untranslated.
See attached screenshot, https://translations.launchpad.net/ubuntu/saucy/+source/ibus/+pots/ibus/ru/44/+translate and https://translations.launchpad.net/ubuntu/saucy/+source/im-config/+pots/im-config/ru/+translate?batch=10&show=all&search=input+method

It seems the string Input Method is from ibus package but not marked as translatable in im-config package.

Igor Zubarev (igor.zubarev) wrote :
Dmitry Shachnev (mitya57) wrote :

Desktop file comes from upstream, please submit a bug upstream about adding a russian translation:

Name=Input Method
Name[ja]=入力メソッド
Name[zh_TW]=輸入法
Name[zh_HK]=輸入法
Name[zh_CN]=输入法
Name[ko]=입력기
Name[vi]=Trình chuyển cách nhập liệu
Name[fr]=Méthode d'entrée
Name[de]=Eingabemethode

Changed in im-config (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
importance: Medium → Low
Dmitry Shachnev (mitya57) wrote :

Actually upstream in Debian, so submit to BTS using instructions at https://wiki.ubuntu.com/Debian/Bugs.

Yuri Chornoivan (yurchor-gmail) wrote :

im-config desktop file is available for manual translation only:

http://anonscm.debian.org/gitweb/?p=collab-maint/im-config.git;a=blob;f=po/Makefile;h=b20594a4da27e3b1189a1d67958901893e5a19c3;hb=HEAD

http://sources.debian.net/src/im-config/0.22-3/im-config.desktop

So you can send your translation upstream or patch it in Ubuntu. There is no way to translate it with LP/Rosetta now.

Igor Zubarev (igor.zubarev) wrote :

Yuri, I attached the translation of desktop file. Could you patch it in Ubuntu?

Dmitry Shachnev (mitya57) wrote :

Thanks Igor, forwarded that to Debian.

Changed in im-config (Debian):
status: Unknown → New
Igor Zubarev (igor.zubarev) wrote :

Any news? Is it possible to add translation in Saucy?

Changed in im-config (Ubuntu):
status: Triaged → In Progress
Changed in im-config (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package im-config - 0.24-1ubuntu1

---------------
im-config (0.24-1ubuntu1) trusty; urgency=low

  * Dropped patches:
    - 01_modify_system_default.patch (no longer needed)
    - 02_list_installed_input_methods.patch (applied upstream)
    - 03_kdialog_support.path (applied upstream)
  * Merge with Debian unstable, remaining Ubuntu changes:
    - debian/im-config.user-session.upstart
    - debian/rules: Install upstart job script
    - debian/postinst: Additional condition to be met to edit
      80im-switch.
  * The new version includes a bunch of PO files (LP: #1225305).

im-config (0.24-1) unstable; urgency=medium

  * Fix typos in manpage
  * Fix changelog 0.23-1. Closes: #724024, #724309
  * Use safe tmp file kde menu.
  * Add many PO files from Ubuntu translation site.

im-config (0.23-1) unstable; urgency=medium

  * Revert 0.22-2 and 0.22-3 changes to keep things simple since
    it was not a bug.
  * Add -l, -m, and -o options. -l is compatible with the Ubuntu
    change. Closes: #694941
  * Update translation (uk, ru). Closes: #724024, #724309
  * Refined build script.

im-config (0.22-3) unstable; urgency=low

  * Fix typo regression in 0.22-2. Closes: #710969

im-config (0.22-2) unstable; urgency=low

  * Fix wild card match logic error for all IM. Closes: #709921

im-config (0.22-1) unstable; urgency=low

  * Change this to non-native 3.0 (quilt) source/format.
  * KUBUNTU patch to use kdialog too. Closes: #705284
  * Mallit input method support by Michał Zając. Closes: #701831
 -- Gunnar Hjalmarsson <email address hidden> Fri, 10 Jan 2014 10:35:00 +0100

Changed in im-config (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) wrote :

Thanks for the work, everyone involved!

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.