Comment 21 for bug 1726160

Hi sir I'm not sure about any of that, but if you click the drop down
button in the top right then click the button between the
wrench/screwdriver and the lock button and that middle button is the one
that stops the obnoxious screen rotation.

On Tue, Mar 12, 2019 at 9:56 AM Antonello <email address hidden> wrote:

> Problem in Elitebook 840 g2 solved by removing/purging iio sensor
> package after the first installation (Debian) updated to the testing
> version . The problem affected screen and touchpad/mouse. It seems to me
> that it is a unnecessary package for laptop with no position sensors is
> it not?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1726160
>
> Title:
> On login, display rotates to wrong orientation [HP Pavilion]
>
> Status in IIO Sensor Proxy:
> Fix Released
> Status in systemd:
> New
> Status in iio-sensor-proxy package in Ubuntu:
> Invalid
> Status in linux package in Ubuntu:
> Confirmed
> Status in systemd package in Ubuntu:
> Confirmed
>
> Bug description:
> I'm using a laptop, and on 17.04 the display always showed correctly,
> but after upgrading to 17.10, when I log in the display rotates to
> the right (portrait), and I have to open a terminal and run 'xrandr -o
> 1' to get it back to the correct (landscape) orientation. In previous
> versions 'xrandr -o 0' was landscape, and '1' was portrait the other
> way.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: xorg 1:7.7+19ubuntu3
> ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
> Uname: Linux 4.13.0-16-generic x86_64
> NonfreeKernelModules: nvidia_uvm nvidia
> .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory:
> '/proc/driver/nvidia/gpus/0000:01:00.0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.104 Thu Sep 14
> 17:13:13 PDT 2017
> GCC version: gcc version 7.2.0 (Ubuntu 7.2.0-8ubuntu3)
> .tmp.unity_support_test.0:
>
> ApportVersion: 2.20.7-0ubuntu3
> Architecture: amd64
> CompositorRunning: None
> CurrentDesktop: ubuntu:GNOME
> Date: Sun Oct 22 15:15:08 2017
> DistUpgraded: 2017-10-22 14:17:00,381 DEBUG icon theme changed,
> re-reading
> DistroCodename: artful
> DistroVariant: ubuntu
> DkmsStatus:
> bbswitch, 0.8, 4.10.0-37-generic, x86_64: installed
> bbswitch, 0.8, 4.13.0-16-generic, x86_64: installed
> nvidia-340, 340.104, 4.10.0-37-generic, x86_64: installed
> nvidia-340, 340.104, 4.13.0-16-generic, x86_64: installed
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> NVIDIA Corporation GT216M [GeForce GT 230M] [10de:0a28] (rev a2)
> (prog-if 00 [VGA controller])
> Subsystem: Hewlett-Packard Company GT216M [GeForce GT 230M]
> [103c:363c]
> InstallationDate: Installed on 2017-01-11 (284 days ago)
> InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64
> (20161012.2)
> LightdmDisplayLog: (II) Server terminated successfully (0). Closing log
> file.
> MachineType: Hewlett-Packard HP Pavilion dv7 Notebook PC
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-16-generic
> root=/dev/mapper/ubuntu--vg-root ro quiet splash
> SourcePackage: xorg
> Symptom: display
> UpgradeStatus: Upgraded to artful on 2017-10-22 (0 days ago)
> dmi.bios.date: 10/05/2010
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: F.1D
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 363C
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 32.25
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnHewlett-Packard:bvrF.1D:bd10/05/2010:svnHewlett-Packard:pnHPPaviliondv7NotebookPC:pvr039D200002241210000020000:rvnHewlett-Packard:rn363C:rvr32.25:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.family: 103C_5335KV
> dmi.product.name: HP Pavilion dv7 Notebook PC
> dmi.product.version: 039D200002241210000020000
> dmi.sys.vendor: Hewlett-Packard
> version.compiz: compiz 1:0.9.13.1+17.10.20170901-0ubuntu1
> version.libdrm2: libdrm2 2.4.83-1
> version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
> version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
> version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
> version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
> version.xserver-xorg-input-evdev: xserver-xorg-input-evdev
> 1:2.10.5-1ubuntu1
> version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
> version.xserver-xorg-video-intel: xserver-xorg-video-intel
> 2:2.99.917+git20170309-0ubuntu1
> version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/iio-sensor-proxy/+bug/1726160/+subscriptions
>