ifup -a does not start alias interfaces

Bug #114457 reported by Sergey V. Udaltsov on 2007-05-13
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ifupdown (Debian)
New
Unknown
ifupdown (Ubuntu)
Low
LinU
Nominated for Intrepid by nomaps

Bug Description

In my /etc/network/interfaces:

auto eth0
iface eth0 inet dhcp

auto eth0:0
iface eth0:0 inet static
        address 192.168.7.2
        netmask 255.255.255.0
        broadcast 192.168.7.255
# gateway 192.168.7.1

But the interface eth0:0 does not start at reboot. If I switch eth0 and eth0:0 - no effect either.

rhetoric (rhetoric) wrote :

I have this problem on both Feisty ppc and Gutsy x86. If I use "sudo ifup eth0:0" after boot it works although I am affected by this bug: https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/123773. This seems like a major problem. I am unable to share files via NFS between 2 boxes hardwired into a basic hub without manually starting the iface for the alias every time I boot. If someone with more knowledge than myself could suggest a workaround that would be nice.

rhetoric (rhetoric) wrote :

Correction: after boot I have to use ifdown THEN ifup because the interface is supposedly "already configured" although it is NOT working or showing up in ifconfig. I can reproduce this using networking restart. It only seems to work (although bug 123773 shows up) when I use ifup or ifconfig up.

/etc/network/interfaces on gutsy box:

auto lo
iface lo inet loopback

auto eth0:0
iface eth0:0 inet static
address 10.0.0.2
netmask 255.255.255.0

Changed in ifupdown:
importance: Undecided → Low
status: New → Triaged
Changed in ifupdown:
status: Unknown → New
Laurent Dinclaux (dreadlox) wrote :

Same bug in Jaunty since RC.

Ifup eth0:0 after boot brings it up.

No way to have a quick fix?

Laurent Dinclaux (dreadlox) wrote :

I can confirm this bug in jaunty server since RC

Changed in ifupdown (Ubuntu):
status: Triaged → New
LinU (linu-realweb) wrote :

Confirm this bug at Jaunty release.
/etc/init.d/networking brings eth0:0 and eth0:1 up
No errors (as i see) in logs

jfxberns (jfxberns) wrote :

Using Jaunty Server 32 bit.

Here is my /etc/network/interfaces file:

# The primary network interface
auto eth0
iface eth0 inet dhcp

# A static interface
auto eth0:1
iface eth0:1 inet static
address 192.168.222.120
netmask 255.255.255.0
network 192.168.222.0
broadcast 192.168.222.255

eth0 comes up at boot. eth0:1 only comes up after running /etc/init.d/networking from the command line.

cambazz (altineller) wrote :

well, I just upgraded my server to 9.04 and I no longer have eth0:1.
this is a server i am using, are not there any quick fixes? I guess it was not a good idea to use ubuntu for a server to begin with. eth0:1 will come up after running /etc/init.d/networking from command line.

Best.

posi (posi) wrote :

I also have this problem with jaunty/server. My workaround is to comment out the auto line for the alias and us post-up / pre-down to bring the aliases up:

auto eth0
iface eth0 inet static
  address 1.2.3.4
  broadcast 1.2.3.255
  netmask 255.255.255.0
  gateway 1.2.3.1
  post-up ifup eth0:0
  pre-down ifdown eth0:0

# no auto here!
iface eth0:0 inet static
  address 2.3.4.5
  broadcast 2.3.4.255
  netmask 255.255.255.0

LinU (linu-realweb) on 2009-06-19
Changed in ifupdown (Ubuntu):
assignee: nobody → LinU (linu-realweb)
LinU (linu-realweb) wrote :

I solved this problem!
The reason is that networking subsystem does not start at boot. I don't know why Canonical decided to do that)) You can add /etc/init.d/networking manually or by this command

# update-rc.d networking defaults

(i do this by sysv-rc-conf program (you can check by this program if networking script is started), but it must be installed manually by apt-get install)

Changed in ifupdown (Ubuntu):
status: New → Fix Released

jaunty workaround:
https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/123773

(either wpasupplicant or wireless-tools at fault)

Phil Bayfield (philio) wrote :

The work around does not work in jaunty!

Another issue found/resolved: (separate to the one experienced with wpasupplicant)

If the alias interfaces have a broadcast address defined, they fail to come up at boot also.

Could you try putting defining broadcast on the parent interface only, and see if the issue is sorted?

e.g:

auto eth0
iface eth0 inet static
  address 1.2.3.4
  broadcast 1.2.3.255
  netmask 255.255.255.0
  gateway 1.2.3.1

auto eth0:0
iface eth0:0 inet static
  address 1.2.3.5
  netmask 255.255.255.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.