indicator-sound keyboard navigation issues

Bug #1297818 reported by Sebastien Bacher on 2014-03-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Display Objects
Fix Released
Low
Lars Karlitski
ido (Ubuntu)
Low
Unassigned

Bug Description

Using current trusty with https://code.launchpad.net/~larsu/ido/lp733285/+merge/212691 (though the issue is probably not new to those changes)

- get totem added to indicator-sound (use it with the mpris plugin enabled)
- open the indicator
- go to the line of totem controls with the keyboard

-> the play button is selected

- use left/right keys

-> the back/forward buttons get selected, there is no way to go back on the play one

Related branches

Changed in ido (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ido (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) on 2014-03-26
Changed in ido:
status: New → In Progress
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+14.04.20140328-0ubuntu1

---------------
ido (13.10.0+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * debian/*symbols: auto-update new symbols to released version

  [ Lars Uebernickel ]
  * Highlight back/forward buttons when hovering them with the pointer
    Space bar still activates play/pause, unless the mouse pointer
    hovers another button. (LP: #733285)
  * expose idobasicmenuitem, a normal menu item that supports non-square
    icons
  * idoplaybackmenuitem: propagate events in the menu keyrelease handler
    To issue a redraw on the menu items as well. Fixes lp:1297818. (LP:
    #1297818)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 11:27:53 +0000

Changed in ido (Ubuntu):
status: Confirmed → Fix Released
Lars Karlitski (larsu) on 2014-04-11
Changed in ido:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers