Can't “use system keyboard layout” in Saucy

Bug #1235991 reported by Lalo Martins on 2013-10-06
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Undecided
Unassigned

Bug Description

In Saucy, ibus becomes more tightly integrated with the desktop. Configuring it via ibus-setup doesn't affect the instance run by ubuntu. And with the new system, there's no way to replicate the behaviour of the old “use system keyboard layout” option.

When I use, for example, pinyin (Chinese) or anthy (Japanese), I want to type the letters in dvorak. I've been doing that for years, and now in Saucy it's impossible.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu):
status: New → Confirmed
Lalo Martins (lalo.martins) wrote :

Hi ibus-ers,

After the last updates, this is working correctly for me. (For “correctly” defined as, it always uses my keymap; there's still no option to turn that off that I can find, but I don't think many people would want that anyway.)

I'm not 100% sure the bug is fixed, it could just be a combination between something updated in the package and something I fiddled with trying to make it work… so it would be nice if other people with a fresh system could confirm.

David Oftedal (rounin) wrote :

The setting does seem to work somewhat with Saucy and IBus 1.5.3, though switching it on and off again multiple times resulted in it temporarily overriding the system keyboard layout so that it functioned like the Japanese one, and additionally adding a Japanese keyboard layout to the list of available input methods by itself.

However, re-configuring the system keyboard layout in the system settings, removing the Japanese layout and restarting IBus took care of those issues.

Dominik Wujastyk (wujastyk) wrote :

Saucy 3.10, up to date (2013-11-21), with Gnome 3.8. Thinkpads, Acers.

I am a British English user, and have all my locales set to en_GB.UTF-8. I have a UK keyboard. I never use US English for typing (or thinking :-).

I work in Unicode all the time, and use Ibus and m17n, with four or five m17n input methods (IM) available all the time.

Before Saucy It used to be possible to
  a) switch off m17n/ibus handling, so the native "locale" keyboard was active
  b) switch between m17n IMs so that the keys they specifically defined worked, and those that were not defined in the m17n map defaulted to the native locale map. E.g., shift+3 would give the UK pound sign all the time, even when typing Sanskrit or Greek.

In Saucy,
  a) one can't turn off ibus handling, apparently. But the native locale appears as the first item in the ibus menu. In my case it's
  "English (UK)". Okay: one has to retrain one's fingers, but it's manageable.
  b) When I change to one of the m17n-defined IMs, the background default keyboard switches to English (US). So shift+3 gives #. That is unacceptable. Definitely a bug.

I've ripped out the US locale completely from my machine (http://askubuntu.com/questions/58191/how-can-i-uninstall-a-locale-via-command-line, and localepurge), but it makes no difference. Ibus is still fetching the US keyboard from some unknown place.

So, how to make ibus use the locale to set the default "background" keyboard for all non-defined keys?

Hi,

Same for me: the pinyin inputs always use the us keyboard layout even whatever the option for system keyboard in ibus-setup.

I used the following workaround to have the proper azerty (French) keyboard layout configured for pinyin IBus methods:

Choose the right file according to the pinyin solution:
/usr/share/ibus/component/pinyin.xml
/usr/share/ibus/component/sunpinyin.xml
/usr/share/ibus/component/googlepinyin.xml

Edit the layout tag:
change
<layout>us</layout>
to
<layout>fr</layout>

Building on #David Cavaillini, here is the trick for those who want to type Japanese on a non-US keyboard:

copy /usr/share/ibus-anthy/engine/default.xml
to ~/.config/ibus-anthy/engines.xml

change
<layout>jp</layout>
to
<layout>fr</layout>

Zhang Weiwu (zhangweiwu) wrote :

I switched from IBUS to FCITX for this reason and a few others. ibus development is slowing down significantly when FCITX is pacing up - development activity usually predicts future bug number and fix-speed. It seems we are back to the old days of 200x when each region (China, Taiwan, Japan etc) prompts their own input platform intead of their own input methods, and that the hope of a high quality input platform for all input methods is fading away.

FCITX was notorious for its strong personality of insisting on using Simplified Chinese and China Mainland government's encoding instead of UTF-8 for configuration files, repelling non-Chinese users. They changed to English configuration files now, but I don't think they became international and design for other language users - the user interface has toleratable English. Normally I prefer International project over local (culture-speaking) software but in this case fcitx development is much more active.

Lalo Martins (lalo.martins) wrote :

Still happening on 14.04… unfortunately the upgrade killed the work-around. Any chance this could be fixed already?

Daniil Ivanov (daniil-ivanov) wrote :

I had the same problem after upgrade from 13.04 to 13.10. I was able to find a workaround for a problem:
I did "apt-get purge libibus-1.0-0:i386", which was installed along with libibus-1.0-5:i386.
Then I selected option IBus Preferences -> Advanced -> "Use system keyboard layout" and restarted IBus. After restart IBus correctly uses Finnish layout instead of English.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers