Can't change IBus input method using menu in Unity

Bug #1023165 reported by Emmanuel Castro on 2012-07-10
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Undecided
Unassigned

Bug Description

Tested in Ubuntu 12.04 (fresh install):
Changing the input method using the menu in the top bar of Unity does not work when the following preference is set: "Advanced/Global input method settings/Share the same input method among all applications".
Only the keyboard shortcuts work.

When this option is not set, changing the method using the menu works only with GTK enabled application (e.g. gedit, Firefox, Chrome), but not in Java or KDE based application such as VirtualBox.

Workaround: use keyboard shortcut.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus (Ubuntu):
status: New → Confirmed

Confirming that enabling said option breaks changing the input method through the menu in the notification area icon. Although the selected input method shows as checked in the menu, input actually continues to use the previous input method. It similarly breaks the input method changer menu in the separate language panel, except in that case even the checkmark does not change.

Also, even if the "Share the same input method among all applications" option is not set, changing input methods with the GUI (as opposed to the keyboard short-cut) is still flaky--sometimes it just ignores me and stays on the previous input method. The configuration that seems to work the best is "Share the same input method among all applications" = Off and "Show language panel" = "When active", and then I use the language panel at the bottom-right to change input methods. But even that sometimes gets stuck.

Mitsuya Shibata (cosmos-door) wrote :

Can reproduce this bug in raring?

I tried following steps, but always show ibus indicator and change input method.

1. Environment is Japanese/ibus-anthy.
2. Enable "Advanced/Global input method settings/Share the same input method among all applications"
3. Shutdown
4. PowerOn
5. LogOn
6. Repeat 5 times, 3-5.

Rik Shaw (rik-shaw) wrote :

I have had tons of ibus issues with certain programs as well (mainly in 12.04 but confirmed same problems in 12.10 and I would assume 13.04 as well but I have not tested yet).

BUT, I have solved all ibus problems (thanks to help from others) with some manual help, but need additional help from others to konw how to get these changes made known to the ubuntu devs.

     1. stock ibus for Ubuntu 12.04 (version 1.4.1-3ubuntu1) has several difficulties when using the system tray icon GUI to enable or disable keyboards. Sometimes it is not turned on properly even though the icon changes, sometimes it says "no input window" when there is indeed one, and other times it simply seems unresponsive: turning on the keyboard does nothing. This seems across "almost all applications". Same issues exist with the 12.10 ibus (different version, but still has the "ubuntu1" customization).

    Upstream versions of ibus from Debian Sid (version 1.4.1-7) solve all of these problems, and ibus seems to work very very well from the GUI menu with this update (another colleague packaged these for me for 32 and 64 bit: if anyone would like these I would be happy to send them. so please let me know). Note that this new version will not show up in the system tray (notification area) by default, however, so either run this command:

        gsettings set desktop.unity.panel systray-whitelist "['all']"

    or do the same with dconf-editor.

In summary for this first issue, it is WHATEVER Ubuntu is customizing that is causing a great headache for ibus users. Stock ibus from Debian works much better!

    2. Setting ibus as the "keyboard input method" in Language Support will cause unexpected behavior (even with the updated version of ibus from above). Particuarly in some apps (a custom mono based one I use is one example), the window ids of the various windows windows will be confused by ibus, thus resulting in the inablity of ibus to work consistently (again, from the GUI menu). If ibus is started manually, these problems do not appear. Only when started through Language Support. The workaround is to keep Language Support keyboard input method to "none" and have a startup application that runs "ibus-daemon -xrd" on login (can either be user level or system level in /etc/xdg/autostart).

Rik Shaw (rik-shaw) wrote :

Possible duplicate with bug 1007423

Rik Shaw (rik-shaw) wrote :

I have since clarified that problem 2 from comment #4 above is not valid, and was related to the specific application we were using.

So, in summary, there does NOT seem to be any issue with setting ibus as the "keyboard input method" in Language Support.

But, problem 1 from comment #4 above regarding needing to use the Debian versions of ibus instead of the patched Ubuntu versions remains valid and true for Precise, Oneiric, and I am assuming others. Whatever is in the ubuntu patched version BREAKS gui use of ibus!

I have re-packaged ibus from debian in my ppa, so anyone wanting to confirm it solves their problems is welcome to try the packages from the ppa (if you add the ppa, on next dist-upgrade it should pull them in automatically):

https://launchpad.net/~wasta-linux/+archive/wasta

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers