Ubuntu

Newly installed tables don't show up

Reported by Xiaojun Ma on 2013-02-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ibus
Unknown
Unknown
ibus-table (Ubuntu)
Medium
Aron Xu

Bug Description

How to reproduce:
1. Install "ibus-table-cangjie3", "ibus-table-quick-classic", "ibus-table-wubi" into system.
2. Restart IBus by "ibus-daemon -drx"
3. Check "ibus-setup" or IBus Preferences, there is no new input method appear.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ibus-table 1.4.99.20121012-1
ProcVersionSignature: Ubuntu 3.8.0-4.8-generic 3.8.0-rc6
Uname: Linux 3.8.0-4-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 9 00:20:12 2013
InstallationDate: Installed on 2013-02-08 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130202)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ibus-table
UpgradeStatus: No upgrade log present (probably fresh install)

Xiaojun Ma (damage3025) wrote :
Xiaojun Ma (damage3025) wrote :

This bug is introduced by a undocumented new feature: supporting tables in user's home directory.
The location for user table is ~/.ibus/byo-tables, but the current ibus-table would fail when such directory doesn't exist (no such directory after fresh install, for sure).
Reference (Chinese): http://www.ylinux.org/forum/t/417

Upstream of ibus-table already fixed this bug.
Unfortunately, latest ibus-table may depends on IBus 1.4.99+ for some reasons (I can tell why if you want).

I guess the best option for us now is backporting the fix for this particular bug, the patch is here:
https://github.com/mike-fabian/ibus-table/commit/12abcdbdc55aa1f25fcbe725ce70765b8519674e

Jeremy Bicha (jbicha) wrote :

ibus-table 1.5.0 is now in Raring with the patch you pointed to.

Changed in ibus-table (Ubuntu):
status: New → Fix Released
Xiaojun Ma (damage3025) wrote :

Hi, jbicha

I like latest and greatest but ibus-table 1.5.0 may not work with IBus 1.4.2 ...

Since it has been ported to GObject introspection Python binding of IBus.

I hope it will work when "gir1.2-ibus-1.0" is installed.

Changed in ibus-table (Ubuntu):
status: Fix Released → In Progress
Jeremy Bicha (jbicha) wrote :

But it's probably too late to include ibus 1.5 in raring due to the difficulties that you and other people pointed out. So there won't be a gir1.2-ibus-1.0 until 13.10.

Please confirm whether ibus-table 1.5.0 will work or whether we will need to revert to what we had in Quantal. I did see that ibus-table itself only claims to require >= 1.1.0.

Aron Xu (happyaron) wrote :

I'll do detailed testing and report back soon, thanks for the feedback. The version requirement of IBus and friends' build systems aren't always very reliable, this happened before but I'm not quite sure it is the case in this issue.

Changed in ibus-table (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
importance: Undecided → Medium
Aron Xu (happyaron) wrote :

I'm installing VM to verify this issue, and a just FYI that we won't move to ibus 1.5 in Raring, since the new ibus's quality is worrying. We need to start to think about the best plan for next cycle, but it's a bit off topic in this thread.

Aron Xu (happyaron) wrote :

Upstream said 1.5.0 won't work with ibus 1.4.x, so we need to do the revert.

@Ma, do you have other patches that want to be applied to this package (1.4.99+)?

Xiaojun Ma (damage3025) wrote :

Sure,

https://github.com/kaio/ibus-table/commit/12abcdbdc55aa1f25fcbe725ce70765b8519674e
and
https://github.com/kaio/ibus-table/commit/52ec65d94b69f8f4e06325a7cb18f0d8ed4f707a

I would like to ask upstream to release a new version, say 1.4.99.20121112.1 that has these two patches included.

Xiaojun Ma (damage3025) wrote :

Hi,

1.4.99.20121112.1 is released with above patches applied.

http://code.google.com/p/ibus/downloads/list

Xiaojun Ma (damage3025) wrote :

Debian has reverted to 1.4.99.20121112.1, what about Ubuntu?

Aron Xu (happyaron) wrote :

This bug was fixed in the package ibus-table - 1.5.0.is.1.4.99.1-1

---------------
ibus-table (1.5.0.is.1.4.99.1-1) unstable; urgency=low

  * Revert to upstream version 1.4.99.20121112.1

 -- Aron Xu <email address hidden> Fri, 15 Feb 2013 03:32:59 +0800

Changed in ibus-table (Ubuntu):
status: In Progress → Fix Released
Jeremy Bicha (jbicha) wrote :

Aron, could you fix ibus-table so that it's installable in Ubuntu?

Your last upload had this change:
diff -Nru ibus-table-1.5.0/debian/control ibus-table-1.5.0.is.1.4.99.1/debian/control
--- ibus-table-1.5.0/debian/control 2013-02-11 19:28:35.000000000 +0000
+++ ibus-table-1.5.0.is.1.4.99.1/debian/control 2013-02-14 19:34:43.000000000 +0000
@@ -16,7 +16,7 @@

 Package: ibus-table
 Architecture: all
-Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, ibus (>= 1.4)
+Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}, ibus (>= 1.5.0)
 Description: table engine for IBus
  IBus-Table is the IM Engine framework for table-based input methods, such as
  WuBi, ErBi, CangJie and so on.

Jeremy Bicha (jbicha) wrote :

And a similar problem for ibus-chewing. Thanks!

Aron Xu (happyaron) wrote :

Both are uploaded, and they are tested to be working, :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.