Ubuntu

32-bit applications do not start on 64

Reported by Lazy on 2011-09-16
294
This bug affects 64 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
High
Adam Conrad
Oneiric
Undecided
Unassigned
Precise
High
Adam Conrad
ia32-libs (Ubuntu)
High
Scott Ritchie
Oneiric
High
Scott Ritchie
Precise
Undecided
Unassigned

Bug Description

WORKAROUND: reinstall libc6-i386 by running 'sudo apt-get install --reinstall libc6-i386'.
----

After the latest updates Wine does not work at all. Output from the console:
~$ wine
bash: /usr/bin/wine: No such file or directory

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: wine1.3 1.3.28-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Fri Sep 16 20:20:19 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: wine1.3
UpgradeStatus: Upgraded to oneiric on 2011-09-16 (0 days ago)

Lazy (ubuntu-bugs-oittaa) wrote :
Harrison Chapman (hchaps) wrote :

A similar issue happens when trying to run adb (another 32-bit executable). I think it has to do with how a recent gcc/libc or similar package got updated recently (it now also conflicts with the i386 packages and a whole bunch of other garbage).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine1.3 (Ubuntu):
status: New → Confirmed
Jakub Korbel (sirkubador-d) wrote :

Few hours ago I updated ia32-libs, which threw a warning about missing directory (/usr/lib/i386-linux-gnu/gio/modules). After that, wine did not execute anything (it complained about GL not properly installed or so). And now after reinstalling wine, I'm getting this message.

Scott Ritchie (scottritchie) wrote :

bash: /usr/bin/wine: No such file or directory

is an error I would expect if the package weren't actually installed. Did wine1.3 package get uninstalled somehow?

Please:
dpkg -s wine1.3
dpkg -s ia32-libs

It is an issue with 32 bit executables, not just wine. The binary exists but
the message is spit out. It is reminiscent of older posts where people
didn't have ia32-libs installed but we do.
On Sep 16, 2011 6:32 PM, "Scott Ritchie" <email address hidden> wrote:
> bash: /usr/bin/wine: No such file or directory
>
> is an error I would expect if the package weren't actually installed.
> Did wine1.3 package get uninstalled somehow?
>
> Please:
> dpkg -s wine1.3
> dpkg -s ia32-libs
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/852101
>
> Title:
> bash: /usr/bin/wine: No such file or directory
>
> Status in “wine1.3” package in Ubuntu:
> Confirmed
>
> Bug description:
> After the latest updates Wine does not work at all. Output from the
console:
> ~$ wine
> bash: /usr/bin/wine: No such file or directory
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: wine1.3 1.3.28-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic x86_64
> ApportVersion: 1.23-0ubuntu1
> Architecture: amd64
> Date: Fri Sep 16 20:20:19 2011
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
(20101007)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: wine1.3
> UpgradeStatus: Upgraded to oneiric on 2011-09-16 (0 days ago)
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/wine1.3/+bug/852101/+subscriptions

Installing a version of gcc-4.6:i386 and assorted packages of the same version as their amd64 counterparts seems to have fixed this. (I assume this is what happened) This wasn't possible until recently as the i386 version of the package only finished building an hour ago. Hope this helps you..

Jakub Korbel (sirkubador-d) wrote :

It doesn't work for me if I don't want to break my system. These packages conflict with ubuntu-desktop and even xorg.

Lazy (ubuntu-bugs-oittaa) wrote :
Download full text (6.0 KiB)

~$ dpkg -s wine1.3
Package: wine1.3
Status: install ok installed
Priority: optional
Section: otherosfs
Installed-Size: 106504
Maintainer: Scott Ritchie <email address hidden>
Architecture: amd64
Version: 1.3.28-0ubuntu1
Replaces: ttf-symbol-replacement, ttf-symbol-replacement-wine1.3, ttf-tahoma-replacement, wine, wine1.0, wine1.2
Provides: wine
Depends: binfmt-support (>= 1.1.2), procps, debconf (>= 0.5) | debconf-2.0, ia32-libs (>= 1.6), lib32asound2 (>> 1.0.14), libc6-i386 (>= 2.6-1), lib32nss-mdns (>= 0.10-3)
Pre-Depends: dpkg (>= 1.14.12ubuntu3)
Recommends: cups-bsd, gnome-exe-thumbnailer | kdebase-runtime, ttf-droid, ttf-liberation, ttf-mscorefonts-installer, ttf-umefont, ttf-unfonts-core, winbind, wine1.3-gecko (>= 1.3), winetricks, xdg-utils
Breaks: ttf-symbol-replacement, ttf-symbol-replacement-wine1.3, ttf-tahoma-replacement (<< 1.3), wine (<< 1.2.1)
Conflicts: wine1.0, wine1.2
Conffiles:
 /etc/xdg/menus/applications-merged/wine.menu d15dadc3527b2c6dca96023a5351aedc
Description: Microsoft Windows Compatibility Layer (Binary Emulator and Library)
 Wine is a compatibility layer for running Windows applications on Linux.
 Applications are run at full speed without the need of cpu emulation. Wine
 does not require Microsoft Windows, however it can use native system dll
 files in place of its own if they are available.
 .
 This package includes a program loader for running unmodified Windows
 executables as well as the Wine project's free version of the Windows API for
 running programs ported from Windows.
 .
 This package is based on a recent Wine beta. While many more applications will
 work, there may be some loss of functionality compared with the stable release
 provided by the regular wine package.
Homepage: http://www.winehq.org/

~$ dpkg -s ia32-libs
Package: ia32-libs
Status: install ok installed
Priority: extra
Section: libs
Installed-Size: 108524
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 20090808ubuntu22
Replaces: ia32-freeglut3, ia32-lesstif2, ia32-libacl1, ia32-libaio1, ia32-libartsc0, ia32-libasyncns0, ia32-libattr1, ia32-libaudio2, ia32-libaudiofile0, ia32-libcairo2, ia32-libcap2, ia32-libcapi20-3, ia32-libcomerr2, ia32-libcups2, ia32-libdbus-1-3, ia32-libdirectfb-1.2-0, ia32-libdrm2, ia32-libesd0, ia32-libexif12, ia32-libexpat1, ia32-libfltk1.1, ia32-libfontconfig1, ia32-libfreetype6, ia32-libgcrypt11, ia32-libgl1-mesa-dri, ia32-libgl1-mesa-glx, ia32-libglu1-mesa, ia32-libgnutls26, ia32-libgpg-error0, ia32-libgphoto2-2, ia32-libgphoto2-port0, ia32-libgssapi-krb5-2, ia32-libhal1, ia32-libice6, ia32-libieee1284-3, ia32-libjack0, ia32-libjpeg62, ia32-libk5crypto3, ia32-libkeyutils1, ia32-libkrb5-3, ia32-libkrb5support0, ia32-liblcms1, ia32-libldap-2.4-2, ia32-libltdl7, ia32-liblzo2-2, ia32-libnss-ldap, ia32-libpam-ldap, ia32-libpam0g, ia32-libpng12-0, ia32-libpopt0, ia32-libpulse0, ia32-libs-dev (<< 1.6), ia32-libs-openoffice.org, ia32-libsane, ia32-libsasl2-2, ia32-libsdl1.2debian-alsa, ia32-libselinux1, ia32-libsigc++-2.0-0c2a, ia32-libsm6, ia32-libssl0.9.8, ia32-libstdc++5, ia32-libsvga1, ia32-libtasn1-3, ia32-libtiff4, ia32-libusb-0.1-4, ia32-libuuid1, ia32...

Read more...

Jeff Utter (jeffutter) wrote :

I just wanted to mention that I have 2 amd64 installs. One was upgraded from natty and the other a fresh install of beta1. Both are up to date. The upgraded one has this problem and the fresh install does not. I tried removing and re-installing the wine and ia32-libs packages with no success.

I have the same problem:

mrk3004@viny-server:~$ wine
bash: /usr/bin/wine: Arquivo ou diretório não encontrado
mrk3004@viny-server:~$ winecfg
exec: 29: /usr/bin/wine: not found
mrk3004@viny-server:~$

MaxNekludov (macscomp) wrote :

Try to install skype:i386
  sudo apt-get install skype:i386
it will install required i386 packages

in my case:

gcc-4.6-base:i386 libasound2:i386 libaudio2:i386 libavahi-client3:i386
  libavahi-common-data:i386 libavahi-common3:i386 libc6:i386 libcomerr2:i386
  libcups2:i386 libdbus-1-3:i386 libexpat1:i386 libffi6:i386
  libfontconfig1:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386
  libglib2.0-0:i386 libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386
  libice6:i386 libjpeg62:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386 libmng1:i386 libpcre3:i386
  libpng12-0:i386 libqt4-dbus:i386 libqt4-declarative:i386 libqt4-network:i386
  libqt4-script:i386 libqt4-sql:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386
  libqtcore4:i386 libqtgui4:i386 libselinux1:i386 libsm6:i386 libstdc++6:i386
  libtasn1-3:i386 libtiff4:i386 libuuid1:i386 libx11-6:i386 libxau6:i386
  libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxi6:i386 libxrender1:i386
  libxss1:i386 libxt6:i386 libxv1:i386 skype:i386 zlib1g:i386

Danerd (danee) wrote :

I think I new to do a fresh installation .. There is no fix for this problem? :S

msznapka (bigmartin) wrote :

Thank you Max Nekludov, installing skype:i386 solved this problem.

Danerd (danee) wrote :

Nice, it solves my problem. :)

summary: - bash: /usr/bin/wine: No such file or directory
+ 32-bit applications do not start on 64
Changed in wine1.3 (Ubuntu):
importance: Undecided → High
description: updated
Steve Langasek (vorlon) wrote :

You don't need to install skype to fix this problem. 'sudo apt-get install --reinstall libc6:i386' should be sufficient to restore the 32-bit ELF loader.

Steve Langasek (vorlon) wrote :

Sorry, I meant 'sudo apt-get install --reinstall libc6-i386'.

Steve Langasek (vorlon) on 2011-09-29
description: updated
affects: wine1.3 (Ubuntu Oneiric) → ia32-libs (Ubuntu Oneiric)
Changed in ia32-libs (Ubuntu Oneiric):
assignee: nobody → Scott Ritchie (scottritchie)
status: Confirmed → In Progress
tags: added: rls-mgr-o-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu25

---------------
ia32-libs (20090808ubuntu25) oneiric; urgency=low

  * Create an ia32-libs-multiarch package to depend on i386 versions of
    libraries that were dropped over the last cycle
    - Should ease transitional issues
    - Recommended (but not depended by) ia32-libs
    - Makes it less likely to have no handler for 32 bit (LP: #852101)
  * Libraries for ia32-libs-multiarch are:
    - qt4-x11: libqtcore4, libqtgui4, libqt4-dbus, libqt4-network,
      libqt4-opengl, libqt4-qt3support, libqt4-script, libqt4-scripttools,
      libqt4-sql, libqt4-svg, libqt4-test, libqt4-xml, libqt4-xmlpatterns
    - acl: libacl1
    - attr: libattr1
    - libcupsimage2: libcups2, libcupsimage2
    - curl: libcurl3
    - gdbm: libgdbm3
    - nss: libnss3
    - nspr: libnspr4
    - openssl: libssl1.0.0
    - libxss: libxss1
  * ia32-libs-multiarch also recommends libgl1-mesa-glx (LP: #821100)
  * debian/rules: create special dh_gencontrol for i386 to avoid build failure
  * Readd libqtwebkit4 to ia32-libs
    - while qtwebkit-source was Multi-Arched, it still depends on libgstreamer
      which has not yet been multiarched and resides in ia32-libs
 -- Scott Ritchie <email address hidden> Wed, 28 Sep 2011 23:47:04 -0700

Changed in ia32-libs (Ubuntu Oneiric):
status: In Progress → Fix Released
Steve Langasek (vorlon) on 2011-09-30
Changed in eglibc (Ubuntu Oneiric):
status: New → Won't Fix
Sworddragon (sworddragon) wrote :

> - libxss: libxss1

If i want to start Skype I get the message "skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory". Is this a problem with the ia32-libs?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed

On Thu, Oct 06, 2011 at 12:46:06PM -0000, Sworddragon wrote:
> > - libxss: libxss1

> If i want to start Skype I get the message "skype: error while loading
> shared libraries: libXss.so.1: cannot open shared object file: No such
> file or directory". Is this a problem with the ia32-libs?

No. You need to install the skype:i386 package.

If you have previously installed skype:i386 and are now getting this error,
you were affected by bug #863675. This bug is now fixed, so you should
upgrade dpkg first and then reinstall skype:i386.

Changed in eglibc (Ubuntu Precise):
status: New → Confirmed
Changed in ia32-libs (Ubuntu Precise):
status: New → Invalid
tags: removed: rls-mgr-o-tracking
quequotion (quequotion) wrote :

>>Scott Richie

Have you updated the wine packages in your PPA to depend on the fix for Oneiric? Is it necessary to do so?

I ask because there's also the possibility my dpkg is broken and doesn't understand the dependency chain (been happening a lot lately).

Sworddragon (sworddragon) wrote :

I have today remove all i386 packages and disabled multiarch support. After this Wine couldn't be executed again. But the workaround with "sudo apt-get install --reinstall libc6-i386" worked. It seems this problem is not complete fixed.

Changed in ia32-libs (Ubuntu Precise):
status: Invalid → New
Changed in eglibc (Ubuntu Precise):
status: Confirmed → Triaged
importance: Undecided → High
Changed in ia32-libs (Ubuntu Precise):
status: New → Won't Fix
Scott Ritchie (scottritchie) wrote :

The issue as noted above is that there isn't always a 32 bit loader present if you add and then remove packages in certain orders. ia32-libs (and things that depend on it like Wine) only slightly work around this problem by pulling in ia32-libs-multiarch which forces an install of the multiarch libc, which in turn installs a loader. If you remove it manually you break it again, however.

The fix belongs in the eglibc package, which should make this situation impossible (probably by dpkg-diversions).

Sworddragon (sworddragon) wrote :

The reinstalling of libc6-i386 hasn't installed any other packages. This means where was no loader missing or the loader isn't explicitly a package. Why is the loader "activated" if libc6-i386 is reinstalled? Why was the loader "deactivated" after I uninstalled skype:i386 with all it's dependencies? Or does the deleting of /etc/dpkg/multiarch which included "foreign-architecture i386" disable it?

The behaviour is a little strange that the loader can be disabled if an installed package like Wine depends on it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ia32-libs (Ubuntu):
status: New → Confirmed
barbobot (deadlyh) wrote :

sudo apt-get install --reinstall libc6-i386 fixed it for me also!

Changed in ia32-libs (Ubuntu):
status: Confirmed → Fix Released
oldos2er (oldos2er) wrote :

This bug affects my system (Kubuntu 11.10 64-bit) specifically with Google Earth. No matter how I try to install GE, whether from the 64-bit deb from Google, or using the googleearth-package installer, trying to start GE in terminal results in "/usr/bin/google-earth: 43: ./googleearth-bin: not found"

ASLok (fst-mail) wrote :

$ adb
/home/aslok/bin/adb: строка 2: /opt/Android-SDK/platform-tools/adb: Нет такого файла или каталога
$ sudo apt-get install --reinstall libc6-i386
$ adb
Android Debug Bridge version 1.0.26

Many thanks, thanks and thanks again!

Tom (teeks99) wrote :
Download full text (3.2 KiB)

> This bug affects my system (Kubuntu 11.10 64-bit) specifically with Google Earth. No matter how I try to install GE, whether from the 64-bit deb from Google, or using the googleearth-package installer, trying to start GE in terminal results in "/usr/bin/google-earth: 43: ./googleearth-bin: not found"

I'm in the same boat here, I think one compounding issue is that Google Earth also depends on the lsb-core libraries, however sudo apt-get install lsb-core:i386 causes all sorts of crazy dependency problems (I think this shouldn't happen).

$ sudo apt-get install lsb-core:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lsb-core:i386 : Depends: libncurses5:i386 but it is not going to be installed
                 Depends: at:i386 but it is not going to be installed
                 Depends: bc:i386 but it is not going to be installed
                 Depends: binutils:i386 but it is not going to be installed
                 Depends: bsdmainutils:i386 but it is not going to be installed
                 Depends: cpio:i386 but it is not going to be installed
                 Depends: cron:i386 but it is not going to be installed
                 Depends: ed:i386 but it is not going to be installed
                 Depends: file:i386 but it is not going to be installed
                 Depends: locales:i386 but it is not installable
                 Depends: cups-bsd:i386 but it is not going to be installed or
                          lpr:i386
                 Depends: lprng:i386 or
                          cups-client:i386 but it is not going to be installed
                 Depends: m4:i386 but it is not going to be installed
                 Depends: mailx:i386 or
                          mailutils:i386 but it is not going to be installed
                 Depends: make:i386 but it is not going to be installed
                 Depends: man-db:i386 but it is not going to be installed
                 Depends: mawk:i386 but it is not going to be installed or
                          gawk:i386 but it is not going to be installed
                 Depends: ncurses-term:i386 but it is not installable
                 Depends: patch:i386 but it is not going to be installed
                 Depends: pax:i386 but it is not going to be installed
                 Depends: procps:i386 but it is not going to be installed
                 Depends: psmisc:i386 but it is not going to be installed
                 Depends: rsync:i386 but it is not going to be installed
                 Depends: alien:i386 (>= 8.36) but it is not installable
                 Depends: python:i386 but it is not installable
                 Depends: lsb-base:i386 but it is not installable
                 Depends: time:i386 but it is not going to be installed
E: Unable to correct problems...

Read more...

Alexander (roth-a) wrote :

I had the same problem and can confirm that the command:
sudo apt-get install --reinstall libc6-i386

does solve the issue.
Thanks!!!!

This worked on Ubuntu Precise:

apt-get install --reinstall libc6-i386

theWRM (thewrm20) wrote :

after

"apt-get install --reinstall libc6-i386"

skype still doesn't work

"thewrm@game:~$ skype
skype: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory"

What wrong, I don't understand?

ehcpdeveloper (ehcpdeveloper) wrote :

  sudo apt-get install skype:i386

this helped for me too. now, wine working.
by the way, how can I install wine 64 bit? why it is using 32 bit even if I have 64 bit Ubuntu ?

> why it is using 32 bit even if I have 64 bit Ubuntu ?
Because most of Windows applications in fact is 32 bit applications.

Sworddragon (sworddragon) wrote :

It seems the dependency problems with ia32-libs (Precise) are mostly solved. On VirtualBox my guest system is already working fine. But on my host system there is one dependency issue remaining:

libcairo2:i386 1.10.2-6.1ubuntu2 cannot be configured because libcairo2:amd64 is in a different version (1.11.3+git20120119.0f40cdea-0ubuntu0ricotz~precise2)

Sworddragon (sworddragon) wrote :

I have figured out that this version isn't in the official repository (maybe it was from the wine ppa which I had enabled before). I have installed the correct version and all is working fine. The ia32-libs problem is solved for precise and 32 bit applications are starting without a problem.

Steve Langasek (vorlon) on 2012-03-23
Changed in eglibc (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)
tags: added: rls-mgr-p-tracking
Adam Conrad (adconrad) wrote :

Due to an unfortunate bug in dpkg (debian bug 588077), this is proving slightly more difficult to fix than we'd first assumed. We could, perhaps, work around the i386-specific case (which seems to be the one people trip over the most) with postrm hacks to manipulate/recreate /lib/ld-linux.so.2 based on the existence of the two known i386 PIs?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.15-0ubuntu9

---------------
eglibc (2.15-0ubuntu9) precise; urgency=low

  * debian/debhelper.in/libc.preinst: Brown paper bag fix; when we
    upgrade from older versions, we don't have our linker in place
    before unpacking, however the preisnt wants one, so create a
    temporary linker symlink in the new location for one-time use
 -- Adam Conrad <email address hidden> Sun, 15 Apr 2012 14:46:48 -0600

Changed in eglibc (Ubuntu Precise):
status: Triaged → Fix Released
bpb (bpb21) wrote :

Here's what happens for me (still not working)...

me@mylaptop:/usr/local/android-sdk-linux/platform-tools$ sudo apt-get install --reinstall libc6-i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/3,998 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 312129 files and directories currently installed.)
Preparing to replace libc6-i386 2.15-0ubuntu10 (using .../libc6-i386_2.15-0ubuntu10_amd64.deb) ...
Unpacking replacement libc6-i386 ...
Setting up libc6-i386 (2.15-0ubuntu10) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
me@mylaptop:/usr/local/android-sdk-linux/platform-tools$ ./adb
./adb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

What am I missing here?

Steve Langasek (vorlon) wrote :

On Sat, Apr 28, 2012 at 11:38:01PM -0000, bpb wrote:
> me@mylaptop:/usr/local/android-sdk-linux/platform-tools$ ./adb
> ./adb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

> What am I missing here?

The libncurses5:i386 package.

bpb (bpb21) wrote :

I appreciate the tip! After installing libncurses5:i386, then libstdc++5:i386 and libstdc++6:i386 it looks like adb is now operational, or at least recognized by the system and the command runs.

Joe (Zhou) Yu (nap-yu) wrote :

I got the same problem on my newly upgraded x86_64bit Precise. And I 'sudo apt-get install' and/or 'sudo apt-get install --reinstall" libc6-i386 and other i386 libraries, but the problem was still there. Then I checked with the i386 'ld' problem, and found that 'adb' depends on /lib/ld-linux.so.2, and then I created a symbol link with 'sudo -ln -s /lib/i386-linux-gnu/ld-linux.so.2 /lib/ld-linux.so', the problem went away:

$ /lib/i386-linux-gnu/ld-linux.so.2 --list /opt/android-sdk-linux_x86/platform-tools/adb
 linux-gate.so.1 => (0xf77a8000)
 librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7775000)
 libncurses.so.5 => /lib/i386-linux-gnu/libncurses.so.5 (0xf7753000)
 libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7737000)
 libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf7652000)
 libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7626000)
 libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7608000)
 libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7463000)
 libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf745d000)
 libtinfo.so.5 => /lib/i386-linux-gnu/libtinfo.so.5 (0xf743e000)
 /lib/ld-linux.so.2 => /lib/i386-linux-gnu/ld-linux.so.2 (0xf77a9000)
$ sudo -ln -s /lib/i386-linux-gnu/ld-linux.so.2 /lib/ld-linux.so.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers