Ubuntu

skype crashes after signing in

Reported by Gerwin on 2010-09-24
404
This bug affects 90 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
High
egidijus
Maverick
High
Unassigned

Bug Description

Binary package hint: skype

On Maverick (10.10), amd64, Skype (2.1.0.81-1ubuntu5) crashes right after I login.

Until a few days ago Skype worked fine, so I guess the problem is caused by an update.

I get this error:

$ skype

(<unknown>:10982): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:10982): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:10982): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:10982): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:10982): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:10982): Gtk-WARNING **: Loading IM context type 'ibus' failed
Inconsistency detected by ld.so: dl-open.c: 612: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
---
Architecture: amd64
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
Package: skype 2.1.0.81-1ubuntu5
PackageArchitecture: amd64
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

mlx (myxal-mxl) wrote :

In that case it must be an update to the libraries - my skype works fine (Kubuntu Maverick amd64). Run " apport-collect 646862 " to attach necessary info to this report.

apport information

tags: added: apport-collected
description: updated
Gerwin (gerwin-kramer) wrote :

Maybe the difference between our systems is that i have "pre-released" updates activated? (and also xorg-edgers and mozilla's ppa), so maybe newer libraries you don't have yet.

Bader Aljishi (baderfgt) wrote :

The same exact thing is happening to me, except that I'm using Ubuntu 10.10 since Alpha 2 and skype was working fine for me. I'm on Dell with core i3

Martin Th. (ma-th) wrote :

same problem for me... skype worked fine on maverick alpha. now with ubuntu 10.10 beta it crashes when sending a chat message. Exits with the same error as stated above.

Knarfix (frankkurian) wrote :

same here. Was working until last update.

Changed in skype (Ubuntu):
status: New → Confirmed
picou (picou) on 2010-09-24
description: updated

Hi. It is related to the ia32-libs latest update. Reverting back from ia32-libs_20090808ubuntu5 to ia32-libs_20090808ubuntu4 fixes the problem.

Kostis (kkyzir) wrote :

Hi. When I go to the package manger and force a previous version I have the current one (20090808ubuntu5) and the previous one (20090808ubuntu4+maverick~xorgedgers2). None of the work... the previous one (20090808ubuntu4) did work, but I can't select it from force version. Where can I get it?

Zorael (zorael) wrote :

Googling, I found this:
    http://mirrors.cytanet.com.cy/linux/ubuntu/archive/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu4_amd64.deb

I downloaded it, installed it with dpkg -i, and now Skype starts again.

Jacob Litewski (hackhalotwo) wrote :

I had this problem, and downgrading ia32-libs to 20090808ubuntu4 worked. I'm going to send the Skype developers a message describing this problem so they can fix this awesome program to work with 20090808ubuntu5. Props to Zorael for the link since I couldn't force the version.

Also, I locked the version of ia32-libs to ubuntu4 until this problem is fixed since Maverick Beta likes updating chunks at once.

Peace75 (markspost) wrote :

The problems with the new ia32-libs breaks more than just skype, I am having problems with flash (no sound), and the application 'Secondlife' won't start (complains about wrong architecture, and installing ia32-libs). Downgrading fixe's all my problems, the bug is with ia32-libs being broken.

I have the same problems but after installing the following updates:
This is the log that I have, apparently, after doing the upgrade of this package, skype no longer works.
I have Kubuntu 10.10 amd64

2010-09-25 13:54:35 startup archives unpack
2010-09-25 13:54:35 install libindicator1 <none> 0.3.14-0ubuntu1
2010-09-25 13:54:35 status half-installed libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:36 status unpacked libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:36 status unpacked libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:37 upgrade libappindicator1 0.2.8-0ubuntu1 0.2.9-0ubuntu1
2010-09-25 13:54:37 status half-configured libappindicator1 0.2.8-0ubuntu1
2010-09-25 13:54:37 status unpacked libappindicator1 0.2.8-0ubuntu1
2010-09-25 13:54:37 status half-installed libappindicator1 0.2.8-0ubuntu1
2010-09-25 13:54:38 status half-installed libappindicator1 0.2.8-0ubuntu1
2010-09-25 13:54:38 status unpacked libappindicator1 0.2.9-0ubuntu1
2010-09-25 13:54:38 status unpacked libappindicator1 0.2.9-0ubuntu1
2010-09-25 13:54:38 upgrade indicator-application 0.2.8-0ubuntu1 0.2.9-0ubuntu1
2010-09-25 13:54:38 status half-configured indicator-application 0.2.8-0ubuntu1
2010-09-25 13:54:38 status unpacked indicator-application 0.2.8-0ubuntu1
2010-09-25 13:54:38 status half-installed indicator-application 0.2.8-0ubuntu1
2010-09-25 13:54:39 status half-installed indicator-application 0.2.8-0ubuntu1
2010-09-25 13:54:39 status unpacked indicator-application 0.2.9-0ubuntu1
2010-09-25 13:54:39 status unpacked indicator-application 0.2.9-0ubuntu1
2010-09-25 13:54:40 startup packages configure
2010-09-25 13:54:40 configure libindicator1 0.3.14-0ubuntu1 0.3.14-0ubuntu1
2010-09-25 13:54:40 status unpacked libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:40 status half-configured libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:40 status installed libindicator1 0.3.14-0ubuntu1
2010-09-25 13:54:40 status triggers-pending libc-bin 2.12.1-0ubuntu6
2010-09-25 13:54:40 configure libappindicator1 0.2.9-0ubuntu1 0.2.9-0ubuntu1
2010-09-25 13:54:40 status unpacked libappindicator1 0.2.9-0ubuntu1
2010-09-25 13:54:40 status half-configured libappindicator1 0.2.9-0ubuntu1
2010-09-25 13:54:40 status installed libappindicator1 0.2.9-0ubuntu1
2010-09-25 13:54:40 configure indicator-application 0.2.9-0ubuntu1 0.2.9-0ubuntu1
2010-09-25 13:54:40 status unpacked indicator-application 0.2.9-0ubuntu1
2010-09-25 13:54:40 status half-configured indicator-application 0.2.9-0ubuntu1
2010-09-25 13:54:41 status installed indicator-application 0.2.9-0ubuntu1
2010-09-25 13:54:41 trigproc libc-bin 2.12.1-0ubuntu6 2.12.1-0ubuntu6
2010-09-25 13:54:41 status half-configured libc-bin 2.12.1-0ubuntu6
2010-09-25 13:54:41 status installed libc-bin 2.12.1-0ubuntu6
---

Bye.

Lapin (fred-lacombe) wrote :

bugs appears after upgrading ia32-libs.
Managed to solve it removing read permission on libpulse.so.0.12.2 and libpulse-simple.so.0.0.3 (in /usr/lib32)

see README file from skype-static archive on skype site for details

Gerwin (gerwin-kramer) wrote :

Works for me too:

cd /usr/lib32
sudo chmod ugo-r libpulse.so.0.12.2
sudo chmod ugo-r libpulse-simple.so.0.0.3

Don't have to downgrade ia32-libs

igeecomputer (igeecomputer) wrote :

cd /usr/lib32
sudo chmod ugo-r libpulse.so.0.12.2
sudo chmod ugo-r libpulse-simple.so.0.0.3

works for me toooo thx

cd /usr/lib32
sudo chmod ugo-r libpulse.so.0.12.2
sudo chmod ugo-r libpulse-simple.so.0.0.3

also worked for me :D, thanks!

Wolf (tehwan) wrote :

sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.2

I did not need to remove read access to libpulse-simple.so.0.0.3, and it worked.

Triwanto Simanjuntak (lu176) wrote :

Solution from Wolf work for me, thanks :D.
sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.2

Hopefully in the future update, or in the final release, this problem will be fixed out of the box.

innervision (dguaraglia) wrote :

Wolf's solution (sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.2) works here too. Skype working now.

Roadi (road-runner) wrote :

also working at me: sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.2

Thanks a lot .

I hope there are no negativ side effects .....

Peace75 (markspost) wrote :

Well using 'sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.2', seems to do the trick for most applications but something else is wrong because flash has no sound, sites such as youtube are muted, or it grabs all sound and leaves the whole system muted. The only full fix/workaround for me is still downgrading.

Kostis (kkyzir) wrote :

I also did the chmod and youtube was muted....
So downgrading to 20090808ubuntu4 seem to be the only working solution.

Ant (anthonyvigh) wrote :

ATTENTION!!!

This is a major kernel problem and should be HIGH PRIORITY- the bug does not only affect skype but affects critical programs- such as Evolution Mail, PITIVI Video Editor and Crossover Pro Linux, something appears to be blocking the initialization scripts for all these programs!!! It is obviously related to PyGTK GTK packages.

Regards

Chris Coulson (chrisccoulson) wrote :

Ant, that is absolute nonsense. Please disregard the above comment.

This is actually the same as bug 647484 (which is caused by libx11-xcb1 being missed out of ia32-libs)

affects: skype (Ubuntu) → ia32-libs (Ubuntu)
Changed in ia32-libs (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in ia32-libs (Ubuntu Maverick):
milestone: none → ubuntu-10.10
Changed in ia32-libs (Ubuntu Maverick):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Triaged → Fix Committed
Ant (anthonyvigh) wrote :

Sorry Chris, My apologies. I over reacted a bit. The work that Ubuntu developers do is fantastic! Just trying to help. I am no linux guru or developer but I was getting program crashes with the programs I identified and when I ran them in terminal, all reported a problem with GTK. All the best and goodluck with the development release. 10.10 is looking really good and am confident any regressions experienced will be fixed before release. Not trying to scare anyone away from Ubuntu just trying to help.

Regards
Ant

maik stolle (ms090780) wrote :

works also for me :D

regards maik

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu6

---------------
ia32-libs (20090808ubuntu6) maverick; urgency=low

  * Fix LP: #646862 - Skype crashes after signing in. Add libx11-xcb1 and
    libxcb-atom1 now that Pulse seems to need them
 -- Chris Coulson <email address hidden> Sun, 26 Sep 2010 13:16:47 +0000

Changed in ia32-libs (Ubuntu Maverick):
status: Fix Committed → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

Hi Chris,
  Thanks ubuntu6 works for me sound (as per my bug 647538)

(ubuntu5 and 6 between them seem to have also fixed bug 626943 for me - mesa)

One thing, during the update I noticed the following warning, it doesn't seem to have had any noticeable effect so far:

Setting up ia32-libs (20090808ubuntu6) ...
g_module_open() failed for /usr/lib32/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jasper.so: libjasper.so.1: cannot open shared object file: No such file or directory

Dave

Jacob Litewski (hackhalotwo) wrote :

Chris,

ubuntu6 fixed the problem wonderfully! Great job!

Søren Holm (sgh) wrote :

ubuntu6 works for me too.

sblatt (stefan-blatter) wrote :

thx alot! works again!

Kevin Jadin (marcspitz) wrote :

Confirming that Skype works again with ia32...ubuntu6 release.
Thanks

Steffen Rusitschka (rusi) wrote :

Skype works here too, again with ubuntu6

Chris Samuel (chris-csamuel) wrote :

Skype no longer crashes with ubuntu6 but there is no audio until I remove read access to that file.

Turns out that upgrading Kubuntu to Maverick reinstalled PulseAudio after I'd purged it previously. :-(

Leo Milano (lmilano) wrote :

Here the workaround was enough to let me start skype but I had no audio (mic/speakers) in skype. The new ia32libs restored audio, good enough to complete a call (however I never undid the workaround, that is I didn't restore the original file permissions)

Triwanto Simanjuntak (lu176) wrote :

Confirming that Skype fully works with ubuntu6 update (didn't undue the previous workaround).

Jacob Litewski (hackhalotwo) wrote :

@Leo Milano and @Triwanto:

Can you try restoring the read permission to libpulse.so.0.12.2? Since @Chris Samuel still has some problems, I want to make sure that it's not a problem with ia32-libs so I can update the bug report I made over at Skype.com about this. If this is still a problem with ia32-libs, I'll remove the bug report over there.

Thank you!

--Jacob "HACKhalo2" Litewski

Gerwin (gerwin-kramer) wrote :

I updated to the latest ia32-libs and restored the read permission to libpulse.so.0.12.2 and skype is still okay.

Tabris (theangeltabris) wrote :

After updating to the latest ia32-libs, how can I restore the permissions to the libraries?

Gerwin (gerwin-kramer) wrote :

cd /usr/lib32
sudo chmod ugo+r libpulse.so.0.12.2
sudo chmod ugo+r libpulse-simple.so.0.0.3

Changed in ia32-libs (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in ia32-libs (Ubuntu Maverick):
assignee: Chris Coulson (chrisccoulson) → nobody
21 comments hidden view all 101 comments
Anton (ademaro-mail) wrote :

Skype crash after send url (Ubuntu Natty x64, Skype 2.2)...

$ skype
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

(<unknown>:5193): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Loading IM context type 'ibus' failed
(<unknown>:5193): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Loading IM context type 'ibus' failed
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

(<unknown>:5193): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: неправильный класс ELF: ELFCLASS64
(<unknown>:5193): Gtk-WARNING **: Loading IM context type 'ibus' failed

Archie (archvile) wrote :

Skype still crashes on me (Ubuntu 10.10 x64, Skype 2.2.0.25-1maverick1, ia32-libs 20090808ubuntu9.1)

I tried:

cd /usr/lib32
sudo chmod ugo-r libpulse.so.0.12.3
sudo chmod ugo-r libpulse-simple.so.0.0.3
cd /usr/lib
sudo chmod ugo-r libpulse.so.0.12.3
sudo chmod ugo-r libpulse-simple.so.0.0.3

but Skype still drops out:

(<unknown>:11252): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:11252): Gtk-WARNING **: Loading IM context type 'ibus' failed
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
Aborted

Alex Sidorenko (asid) wrote :

It seems that now skype uses slightly different pulse-related libraries. I was able to start skype from the command line after several (4 or 5) attempts. After that:

# lsof -c skype | fgrep pulse

It did not show libpulse-simple, but I disabled it as well anyway. After that:

# cd /usr/lib32
# chmod a-r libpulse.so.0.12.3 libpulsecommon-0.9.22.so libpulse-simple.so.0.0.3

Now Skype starts fine.

FYI: I did this on Ubuntu/Natty (beta2) rather than Maverick, but it seems that maverick has the same versions of libpulse libraries.

Cheers,
Alex

Archie (archvile) wrote :

Alex's approach worked for me.

# lsof -c skype | fgrep pulse

showed two libraries in use, so I did:

# sudo chmod a-r /usr/lib32/libpulsecommon-0.9.21.so /usr/lib32/libpulse.so.0.12.2

Skype works fine now with sound, microphone and chat. Nice :-)

Skype 2.2.0.25, Ubuntu 10.10 Maverick Meerkat, 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux

Cheers,
Andy

I have the same problem in 10.10.
I too tried the solution suggested:

# sudo chmod a-r /usr/lib32/libpulsecommon-0.9.21.so /usr/lib32/libpulse.so.0.12.2

So far it seems stable.

Cheers,
Thomas

openzin (openzin) wrote :

Same problem exist for me (I'm 2 years user of Ubuntu and "love" it!). As I'm software developer too, I understand that and hope finally it' be fixed. With some of workaround above it disable Ubuntu audio controlling options. Currently I'm using the following very simple script to start skype:

sudo chmod ugo-r /usr/lib/libpulse.so.0.12.2 /usr/lib/libpulse-simple.so.0.0.3
skype
sudo chmod ugo+r /usr/lib/libpulse.so.0.12.2 /usr/lib/libpulse-simple.so.0.0.3

At least this after using skype it will return these libraries to "normal" stage and Ubuntu audio controlling functions work fine.

Thanks for this little fix! It is indeed a very simple solution.

Daniel Marynicz (xaweryz) wrote :

This Also affects Ubuntu Natty amd64 :(

foxy123 (foxy) wrote :

I also have this problem on 11.04 amd64. However, if I start Skype from terminal it does not crash.

twins (ramadan) wrote :

This seems to be a ia32-libs issue, because it affects other programs that use it. I am able to make audio and video calls, chats and almost everything but when I send a file skype just crahes. I started skype from a terminal window an I got this output::
:~$ skype
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

(<unknown>:3148): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:3148): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Loading IM context type 'ibus' failed
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

(<unknown>:3148): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): Gtk-WARNING **: Loading IM context type 'ibus' failed

=============this is when I click Send File in the conversation window=============

/usr/lib/gio/modules/libgiobamf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiobamf.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

(<unknown>:3148): Gtk-WARNING **: Error loading theme icon 'gtk-ok' for stock: Unable to load image-loading module: /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: wrong ELF class: ELFCLASS64

(<unknown>:3148): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (<unknown>:3148): CRITICAL **: murrine_style_draw_render_icon: assertion `base_pixbuf != NULL' failed

(<unknown>:3148): Gtk-CRITICAL **: IA__gtk_style_render_icon: assertion `pixbuf != NULL' failed

(<unknown>:3148): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(<unknown>:3148): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(<unknown>:3148): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed
Aborted

Also note that when I encountered the skype-crash-at-login bug, I just did a: aptitude reinstall ia32-libs , and skype worked fine again.

worldmind (world-mind) wrote :

I use Ubuntu 10.10 long time without any problem, but today my skype crashed and can't start, it crashed after start, see error messages below

worldmind@host:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
worldmind@host:~$ uname -a
Linux host 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux
worldmind@host:~$ skype

(<unknown>:3910): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3910): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:3910): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3910): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:3910): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3910): Gtk-WARNING **: Loading IM context type 'ibus' failed
Aborted
worldmind@host:~$

skep (skep) wrote :

same problem for me as well, since today...

Botond Szász (boteeka) wrote :

Same here. One interesting thing is that I had skype running for a couple of hours and then it suddenly crashed and I can not start it anymore. It starts but after a couple of seconds it crashes with the same error messages as worldmind mentioned above in reply #73.

Wildev (dmitry-s) wrote :

I have the same Ubuntu 10.10 x86_64. The same problem with Skype started today about an hour ago.

kasim (kasim) wrote :

I have the same problem in Ubuntu 10.10 x86_64 too. Help! Help!

Botond Szász (boteeka) wrote :

Oh, and I am on Natty 64bit (11.04) not Maverick (10.10).

Gary Malouf (malouf-gary) wrote :

+1

gary@lion:~$ skype

(<unknown>:25486): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:25486): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:25486): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:25486): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:25486): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:25486): Gtk-WARNING **: Loading IM context type 'ibus' failed
Aborted

Same here, 10.10 x86_64, after the latest update (rdesktop and chrome, I think) skype refuses to start.

Thorsten Kunz (sfire) wrote :

Same here. Skype was working just fine the other day and now it is failing with the same error as mentioned in #73.

Priit Pihus (ppihus) wrote :

Same here

Benoe (benoe77) wrote :

Same here, Ubuntu Maverick 64bit.

Priit Pihus (ppihus) wrote :

Oh never mind. Skype's own problem.
http://twitter.com/#!/Skype/status/73718207676022784

grenadecx (grenadecx) wrote :

This is a skype problem, it started for me today, but I didn't do any updates

Wildev (dmitry-s) wrote :

This helps:
mv ~/.Skype/shared.xml ~/.Skype/shared~.xml
Then start Skype as usual.

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml

Worked for me too, thanks!

Ubuntu 10.10x64

Jonathan Yip (helkaluin) wrote :

Confirming workaround from #86, on Natty-64 bit.

Ronald Rios (rdrios) wrote :

Same here. The issue just started today. But, if you run skype as root user it works!

Confirmed fix from #86 here, too. Thanks Wildev!

Unc0nn3ct3d (netflow) wrote :

Yup, confirming #86 works as well, although when skype starts I still see the following errors:
(<unknown>:26816): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:26816): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:26816): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:26816): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:26816): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:26816): Gtk-WARNING **: Loading IM context type 'ibus' failed

although it doesn't seem to impede functionality

Maax-l (maax-l) wrote :

Used fix from #86 , skype logs in , but crashes after going to place an IM,

args used for cario dock on skype shortcut

sh -c 'export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype'

mav 10.10 , 2.6.35.28 acer 5734Z

Paul Ortman (portman) wrote :

Used fix from #86, all seems to work well for me as well. Don't know that I had any updates that introduced this problem, but it worked for me now.

egidijus (ags666egis) on 2011-05-28
Changed in ia32-libs (Ubuntu):
assignee: nobody → egidijus (ags666egis)

Skype's gdk loader complaints about 64-bit arch are just a red herring. The real problem is that Skype messed up its configuration file. To fix it, simply delete it, or move it elsewhere.

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml

Maybe there should be a bug filed against the gdk loader to make it shut up about arch mismatches unless it actually fails to load the library it needs, so that the whole world isn't lead astray when trying to debug Gnome apps...

redtux (redtux2000) wrote :

Please, reopen this bug instead of marking it as fixed and only close it when Microsoft releases a patch for Skype.

As the above posts confirm, Daniel Marynicz is totally correct: "This Also affects Ubuntu Natty amd64." (2011-05-03 #69; see also #64)

Beside the option of removing the shared.xml settings file (for those of us affected by the "Skype issue" on May 26), you might also try the fix proposed before. For me it actually worked (and Flash videos have still sound):

redtux@nostrix:~$ sudo chmod ugo-r /usr/lib32/libpulse.so.0.12.3
redtux@nostrix:~$ sudo chmod ugo-r /usr/lib32/libpulse-simple.so.0.0.3

For anyone affected by this bug: Please, report when the bug has been fixed for you by an update (be it skype, ia32-libs or whatever).

redtux@nostrix:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

redtux@nostrix:~$ uname -a
Linux nostrix 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

redtux@nostrix:~$ dpkg -s skype | grep Version
Version: 2.2.0.25-1

redtux@nostrix:~$ dpkg -s ia32-libs | grep Version
Version: 20090808ubuntu13

Gargoulf (pasquiernoterdaeme) wrote :

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml
also worked for me.
Ubuntu 10.10 32bits on Dell M6500

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml

Also worked for me too, thanks!

Ubuntu 10.10x64

mv ~/.Skype/shared.xml ~/.Skype/shared~.xml

Also worked for me too, thanks!

Ubuntu 11.04, 64bits

neuromancer (neuromancer) wrote :

Skype crashes after start. Same error output as reported on #73.
Also reinstalling and deleting profile (.Skype) doesn't fix the problem.

Also disabling Ubuntu audio controlling options as reported on #67 doesn't work (chmod ugo-r /usr/lib/libpulse.so.0.12.2 /usr/lib/libpulse-simple.so.0.0.3).
Lastly no success moving away configuration file of Skype (mv ~/.Skype/shared.xml ~/.Skype/shared~.xml) as reported on #94.

Skype is imploding after microsoft acquisition... We need an easy, open and cross-platform alternative solution.

Yuriy Voziy (yuretsz) wrote :

Seems to be a regression:

skype
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3216): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64

(<unknown>:3216): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

(<unknown>:3216): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:3216): Gtk-WARNING **: Loading IM context type 'ibus' failed

yurka@homeserver:~$ uname -a
Linux homeserver 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Hey!

Bedankt voor je mail! Ik ben er even tussenuit geknepen naar een lekker warm land! Ik beantwoord je mail na mijn vakantie (11 oktober).

Groetjes!

Ruben

Displaying first 40 and last 40 comments. View all 101 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers