Hardware Testing app hangs

Bug #202460 reported by Jeremy Wilkins on 2008-03-15
102
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lshw
Fix Released
Unknown
hwtest (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Eduard Grebe
Hardy
Undecided
Unassigned
lshw (Ubuntu)
High
Brian Murray
Nominated for Intrepid by Eduard Grebe
Hardy
High
Brian Murray

Bug Description

Binary package hint: hwtest

Working through the hwtest app, I get to to the 'is your mouse working' screen. Choose yes, click 'Next' and the app appears to hang. I left it for a while before killing it with xkill.

Hardy Alpha 6, updated to 15/03/08

Related branches

Jeremy Wilkins (jeb-jdwilkins) wrote :

Hardware is a Dell XPS 1330m laptop.

yegle (cnyegle) wrote :

I can confirm this.
my hardware is Dell XPS 1210m

yegle (cnyegle) on 2008-03-16
Changed in hwtest:
status: New → Confirmed
Gabriele Rota (gabro86) wrote :

Same thing on my HP Pavilion dv6249eu

brownknight (ramilclarin) wrote :

I can confirm this. Im using a Dell E1505 Laptop.

Jim Qode (jimqode) wrote :

Confirmed on Dell M1330. The problem is with the lshw binary. If I kill that binary I can continue with the other steps.

lshw also hangs when I run it from console.

EinKinder (julien-tremblay) wrote :

Same here, Dell Inspiron 6400/e1505

Seems like a lot of Dell computers, isn't it?

Gabriel (giovino) wrote :

Same here, Dell XPS M1710

I am having the same problem on my hp dv9000 laptop running hardy beta.

Alfred Rossi (alfredr) wrote :

same here, laptop: toshiba satellite u305

confirm !

acer aspire 5520
trust optical wireless mini mouse

Taygeto (taygeto) wrote :

Same for HP dv9253ea laptop (same series as freebios) running hardy beta

peni (p-golik) wrote :

confirm. exatcly the same situation on lenovo 3000 n100 laptop.

Yet again I have to remind people to not "confirm" bugs like this, it only adds useless noise.

peni (p-golik) wrote :

tell us how to contribute then instead. do developers need some specific debug output like dmesg?

peni (p-golik) wrote :

p.s. the app hangs only when using ethernet adapter

$ lspci
05:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

when switching to wireless adapter, network detection works fine and the tool perfectly terminates.

$ lspci
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

I believe that this bug is caused by result of lshw hang while it was run in su mode, since hwtest uses lshw.

See also http://www.ezix.org/project/ticket/340 which was fixed and milestone was set to lshw B.02.13.

Brian Murray (brian-murray) wrote :

I was able to recreate this bug using lshw version 02.12.01-2ubuntu1 on my laptop. I then added the patch from the upstream report and created an updated version of the package. Testing again on my laptop it was then possible to use 'sudo lshw'.

Changed in lshw:
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Triaged
James Westby (james-w) wrote :

Hi,

I can confirm that Brian's fix works.

Thanks,

James

Brian Murray (brian-murray) wrote :

I've also uploaded lshw to my ppa which you can find at https://launchpad.net/~brian-murray/+archive . Please feel free to test it and report back here.

Timo Jyrinki (timo-jyrinki) wrote :

New hwtest landed in the archive btw, does it help anything with this or is the problem in lshw causing this still?

Martin Olsson (mnemo) wrote :

I'm also seeing this, on a HP DV6000 laptop. lshw hangs both from hwtest and from terminal. I tried to install the fixed .deb but gdebi said "later version already installed and there was no 'override' button" so I don't know how to install it :-/

crashsystems (crashsystems) wrote :

I just ran the newest version of the hwtest on my Dell Inspiron 1420 running 8.04, and the test finished perfectly, unlike before. Kudos to whoever fixed the problem!

Martin Olsson (mnemo) wrote :

"lshw" works for me too but "sudo lshw" still hangs.

On Tue, 2008-04-22 at 19:45 +0000, crashsystems wrote:
> I just ran the newest version of the hwtest on my Dell Inspiron 1420
> running 8.04, and the test finished perfectly, unlike before. Kudos to
> whoever fixed the problem!
>

Hi,

Thanks for testing, but the new upload wasn't intended to fix this
issue as far as I know. It is possible that some change affected
this issue, but the underlying bug with lshw is still present.

As I understand it Brian's fix has been approved for an upload in
to hardy-proposed, which after sufficient testing will make it in
to hardy-updates, and then be included in the 8.04.1 release.

Could those who are still affected by this bug please be patient,
it is being worked on, and we hope to have the fix available to you
soon after the release.

Thanks,

James

Changed in lshw:
status: Unknown → Fix Released
Steve Langasek (vorlon) on 2008-04-25
Changed in lshw:
milestone: ubuntu-8.04 → ubuntu-8.04.1
Changed in hwtest:
status: Confirmed → Invalid
Kees Cook (kees) wrote :

Based on my memory of IRC-approval and James's comment above, I've sponsored this upload into -proposed. Thanks Brian!

Changed in lshw:
assignee: nobody → brian-murray
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test. Since this is hardware specific (doesn't hang on mine, for example), we depend on feedback from affected people. Please use the actual packages in hardy-proposed, once they actually hit the archive.

Payteer (prowan) wrote :

The modification works now on the Lenovo 3000 V100 model.

Works on a Dell 640m / E1405

Stefano Angeleri (weltall) wrote :

the commited fix to proposed fixed my freeze problems with lshw (executed as root) on acer 5920G

BlackAdder (jan-doornaert) wrote :

The lshw-update currently in "hardy-proposed" fixed the issue in my case too (unresponsive/hung after mouse test, before network card detection). Thanks!

Martin Olsson (mnemo) wrote :

I saw the lshw hang on my machine before. I updated to the hardy-proposed version and now I can run the hardware testing wizard with no problems and "lshw" and "sudo lshw" both finished just fine without any hang.

I got a HP DV6000 laptop and my network cards are these:
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)

Jeremy Wilkins (jeb-jdwilkins) wrote :

works fine now on an Dell XPS 1330m

jeb

On Tue, Apr 29, 2008 at 9:14 PM, mnemo <email address hidden> wrote:
> I saw the lshw hang on my machine before. I updated to the hardy-
> proposed version and now I can run the hardware testing wizard with no
> problems and "lshw" and "sudo lshw" both finished just fine without any
> hang.
>
> I got a HP DV6000 laptop and my network cards are these:
> 02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
> 06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
>
>
>
> --
> Hardware Testing app hangs
> https://bugs.launchpad.net/bugs/202460
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Paul Shiryaev (pshiryaev) wrote :

works fine now - HP Pavilion DV9000 AMD Turion 64x2

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in lshw:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

unmarking as 'fix committed' for the Ubuntu task, AFAIK the fix is not yet committed anywhere for intrepid.

Changed in lshw:
milestone: ubuntu-8.04.1 → none
status: Fix Committed → Triaged
mpfleger (mikepfleger) wrote :

Hi.

wtt the hanging; I never had a hang or any other issue with it until today.

After installing the (Hardy) lshw update last night, my hardware config was completely wonked on restart. This meant:
no network - until I manually installed forcedeth
video config is utterly humped - I'm typing this on a 640x480 desktop :(
no sound
a whole bunch of other things missing (I have a printed ref of lsmod o/p)
*and*
now I have pata_acpi and pata_amd showing up in there which is interesting since I've never had or apparently needed them previously =/

machine details:
ASUS M2N-VM DVI
4GB RAM
AMD AM2 Athlon X2 CPU
using onboard GeForce 7050PV video
(network provided via nForce 630 chipset)

gah.

Martin Pitt (pitti) wrote :

mpfleger, that can't possibly be lshw, since it does not affect the boot process, network, etc. It rather sounds like you updated the kernel at the same time, to 2.6.24-17.

What does this show:

  dpkg -l 'linux*' | cat

Martin Pitt (pitti) wrote :

Copied hardy-updates to intrepid.

Changed in lshw:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.