Ubuntu

Missing firmware for bcm43xx/b43 driver during install

Reported by Arthur Peters on 2006-01-24
34
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Medium
Unassigned
hw-detect (Ubuntu)
Medium
Unassigned

Bug Description

On AMD64 using daily dapper 20050124.

During the install the installer offers to configure the bcm43xx device on my laptop, but the search for wireless networks fails to find any networks. The message simply says no networks could be found, but investigation shows that the firmware for the device could not be loaded, because it is not available.

Ideally the firmware should be included, but that is probably imposable because of licensing so the bcm43xx device should probably not be listed as a usable network device during the install. Just my $.02

Colin Watson (cjwatson) wrote :

I'm leaving it this way for now in case some solution for firmware materialises; I'll revisit this later in the release cycle.

Gaëtan Petit (gaetanp) wrote :

i'm quite surprised i have a mini pci wifi card
with a BCM4309 chipset
And the firmware are included and nicely loaded by Dapper Flight 3
(a good news for my laptop)

What is your chipset number?

Arthur Peters (amp) wrote :

Same (lspci -v output below).

I checked in the installer environment for the firmware and it was not there and I had to extract them and copy them to /lib/firmware myself on the main install to make it work once installed.

They may be in Flight 3, but unless I missed something. They are not in the current daily.

-Arthur

0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
        Subsystem: Hewlett-Packard Company: Unknown device 12f4
        Flags: bus master, fast devsel, latency 64, IRQ 11
        Memory at e0104000 (32-bit, non-prefetchable) [size=8K]

Matt Zimmerman (mdz) wrote :

Rejecting spurious bug task; don't panic, the bug remains open

Changed in hw-detect:
status: Unconfirmed → Confirmed
Susan Cragin (susancragin) wrote :

On my Acer 4005 AMD64, loaded edgy on 8/7 and updated today using wire. But have two wireless cards, internal and Belkin PCMCIA. Neither work.
On bootup, various error messages flash by relating to bcm43xx not loading.
PCMCIA card has never lit up.
In Gnome, when I try System / Administration / Networking i get a system crash, but that's
Bug 55458.
Want any error ? Tests? just let me know.

Xamusk (ronanpaixao) wrote :

If the bug will not be fixed in the install, at least the firmware could be included in the Restricted Drivers Manager, to make installing it easier.
After all, that's what the Restricted Drivers Manager is for.
As of now, it's not there.

Timothy Smith (tas50) wrote :

Is there any way you can test this with the new restricted device manager in Gusty Alpha 2. There have a been a lot of changes involving the firmware for the Broadcom cards that may affect this bug.

zeddock (zeddock) wrote :

What tests would you like for me to do?
My 4309 still is not working on Tribe 5

zeddock

zeddock (zeddock) wrote :

I believe this has now been fixed. My 4309 now works with restricted firmware updated in Gusty.

zeddock

John Simons (sloujon) wrote :

Does anybody know where to get the "firmware" that goes with "bcm43xx". This Ubuntu install is starting to drive me nuts. John @ "<email address hidden>"

Arthur Peters (amp) wrote :

Install the package "bcm43xx-fwcutter" from universe. It will automatically download and extract the firmware during the install process.

Once you have universe enabled (this is default on Gutsy I think) run:

$ sudo aptitude install bcm43xx-fwcutter

I hope this works for you (and other who find this in the future).
-Arthur

Przemysław Kulczycki (azrael) wrote :

This bug is very annoying because it's an absurd to require a network connection to install a network driver. If you don't have another network interface then you're stuck and have to use another computer or another operating system.
The b43-fwcutter downloads 2 files from openwrt.org:
http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
and http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
Maybe the guys from openwrt.org could be asked if redistribution of this files is possible. If not, then maybe Canonical could ask Broadcom for permission to redistribute these files.

Przemysław Kulczycki (azrael) wrote :

Also see Bug 220223

Conrad Knauer (atheoi) wrote :

Przemysław Kulczycki wrote: "This bug is very annoying because it's an absurd to require a network connection to install a network driver. If you don't have another network interface then you're stuck and have to use another computer or another operating system."

I installed Ubuntu for my father-in-law and had to initially use a wired connection for the very same reason. In the past I've done demos for people on their noteboooks where I've been bitten by this bug. Annoying, yes; absurd, no. The main problem as I understand it is that the diver with the firmware is not fully redistributable, otherwise it could be in restricted and thus put on the CD. I also had a similar firmware issue with an Agfa-branded scanner a while back (driver with firmware files was free to d/l from the Agfa site, but NOT to redistribute).

This is not really Ubuntu's fault; Ubuntu wants to be free of cost *and* fully redistributable. Unfortunately that means you will run into cases like this.

What can really be done is to either get Broadcom to allow full redistribution of the firmware or to get someone to implement a libre equivalent.

Oh and here's a link to the discussion on ubuntu-devel-discuss:
https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-July/004678.html

Colin Watson (cjwatson) wrote :

We've already talked to Broadcom; no luck. The wl driver and various reverse-engineering efforts are the only way we're going to get redistributable firmware here.

Przemysław Kulczycki (azrael) wrote :

Bug #487393 has been filed about packaging openfwwf: reverse-engineered open firmware for broadcom wireless cards.

Przemysław Kulczycki (azrael) wrote :

Bug #218922 is a similar bug in Jockey.

Changed in debian:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.