driver-injection-disk script needs to support disk and usb-partition devices

Bug #1332187 reported by Kent Baxley on 2014-06-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hw-detect (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

14.04 LTS (and older) does not support driver injection via micro deb (udeb) package when mounted from iLO virtual media.

iLO does not present an OEMDRV device with a partition, therefore, the Ubuntu installer overlooks that media as being viable. Instead of a usb-partition, the device is seen as a disk. Running "list-devices disk" and then a blkid against that disk will reveal the OEMDRV label.

Instead of just probing for usb-partitoin in list-devices, the driver-injection-disk script also needs to check the "disk" device via list-devices.

I'll post a possible fix via bzr merge proposal shortly.

This will need to go into 14.10 as well as an update in 14.04 LTS

Related branches

Kent Baxley (kentb) on 2014-06-19
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hw-detect (Ubuntu):
status: New → Confirmed
Adam Conrad (adconrad) wrote :

I'd assume the following 1-line patch would achieve the same result:

--- driver-injection-disk.sh.orig 2013-10-04 03:38:29.000000000 -0600
+++ driver-injection-disk.sh 2014-06-27 10:25:29.546558043 -0600
@@ -29,7 +29,7 @@
 }

 #try to mount possible driver disk
-for device in $(list-devices usb-partition); do
+for device in $(list-devices disk; list-devices usb-partition); do
  label=$(block-attr --label $device 2>/dev/null || true)
  if [ "$label" = "OEMDRV" ]; then
   db_input high driver-injection-disk/load || true

Adam,
Looks good to me.

-- mikem

On Fri, Jun 27, 2014 at 11:26 AM, Adam Conrad <adconrad@0c3.net> wrote:

> I'd assume the following 1-line patch would achieve the same result:
>
> --- driver-injection-disk.sh.orig 2013-10-04 03:38:29.000000000 -0600
> +++ driver-injection-disk.sh 2014-06-27 10:25:29.546558043 -0600
> @@ -29,7 +29,7 @@
> }
>
> #try to mount possible driver disk
> -for device in $(list-devices usb-partition); do
> +for device in $(list-devices disk; list-devices usb-partition); do
> label=$(block-attr --label $device 2>/dev/null || true)
> if [ "$label" = "OEMDRV" ]; then
> db_input high driver-injection-disk/load || true
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1332187
>
> Title:
> driver-injection-disk script needs to support disk and usb-partition
> devices
>
> Status in “hw-detect” package in Ubuntu:
> Confirmed
>
> Bug description:
> 14.04 LTS (and older) does not support driver injection via micro deb
> (udeb) package when mounted from iLO virtual media.
>
> iLO does not present an OEMDRV device with a partition, therefore,
> the Ubuntu installer overlooks that media as being viable. Instead of
> a usb-partition, the device is seen as a disk. Running "list-devices
> disk" and then a blkid against that disk will reveal the OEMDRV label.
>
> Instead of just probing for usb-partitoin in list-devices, the driver-
> injection-disk script also needs to check the "disk" device via list-
> devices.
>
> I'll post a possible fix via bzr merge proposal shortly.
>
> This will need to go into 14.10 as well as an update in 14.04 LTS
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/hw-detect/+bug/1332187/+subscriptions
>

Kent Baxley (kentb) wrote :

Thanks, Adam. Refactored my bzr merge proposal to reflect a much cleaner way to handle this.

Adam Conrad (adconrad) wrote :

Fixed up the typo and uploaded to both trusty and utopic.

Hello Kent, or anyone else affected,

Accepted hw-detect into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/hw-detect/1.95ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in hw-detect (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hw-detect - 1.95ubuntu4

---------------
hw-detect (1.95ubuntu4) utopic; urgency=medium

  * driver-injection-disk.sh: also probe disks for OEMDRV label (LP: #1332187)
 -- Kent Baxley <email address hidden> Fri, 27 Jun 2014 11:52:43 -0500

Changed in hw-detect (Ubuntu):
status: Confirmed → Fix Released
Kent Baxley (kentb) wrote :

Thanks, Adam.

Kent Baxley (kentb) wrote :

Tested the trusty-proposed package with two scenarios:

1) Whole-disk with an OEMDRV label (i.e. /dev/sdb) and driver packages contained therein.

2) usb-partition with an OEMDRV labe (i.e. /dev/sdb1) and driver packages contained therein.

In both cases the new driver injection disk package postinstall script picked up both disks and installed packages accordingly.

Setting to verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hw-detect - 1.95ubuntu2.1

---------------
hw-detect (1.95ubuntu2.1) trusty; urgency=medium

  * driver-injection-disk.sh: also probe disks for OEMDRV label (LP: #1332187)
 -- Kent Baxley <email address hidden> Fri, 27 Jun 2014 11:52:43 -0500

Changed in hw-detect (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for hw-detect has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers