systemd-modules-load.service fails: /etc/modules contains nonexisting module "rtc"

Bug #1317077 reported by N1ck 7h0m4d4k15 on 2014-05-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hw-detect (Ubuntu)
Undecided
Dimitri John Ledkov
kmod (Ubuntu)
Undecided
Unassigned

Bug Description

Since day one, when I have switched on systemd as PID 1 , the service [systemd-modules-load.service] always exited with a FAILURE status=1.

:~$ systemctl list-units --failed
UNIT LOAD ACTIVE SUB DESCRIPTION
systemd-modules-load.service loaded failed failed Load Kernel Modules

:~# systemctl status systemd-modules-load.service
systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Τετ 2014-05-07 14:39:26 EEST; 38min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 337 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)

I have ran the service directly via:

:~# /lib/systemd/systemd-modules-load

and the errors was

Module 'fuse' is builtin
Failed to find module 'rtc'
could not find module by name='off'
Failed to insert 'off': Function not implemented
could not find module by name='off'
Failed to insert 'off': Function not implemented

I have searched/found and removed the affected modules from

/etc/modules (which is a symlink on /etc/modules-load.d/modules.conf)

Now [systemd-modules-load.service] is exiting with a SUCCESS status=0.

Certainly I didn't add these modules manually at the related directories and I am thinking if this is a bug on how the affected modules should be loaded and how the related configuration files should be written.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: systemd 204-10ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.2-0ubuntu2
Architecture: amd64
Date: Wed May 7 15:16:23 2014
InstallationDate: Installed on 2014-03-24 (43 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140323)
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)

N1ck 7h0m4d4k15 (nicktux) wrote :
tags: added: systemd-boot
description: updated
description: updated
Martin Pitt (pitti) wrote :

Ah, thanks for filing that. It was on my TODO list for a week, but didn't get to it yet :)

The root cause is that "rtc" has stopped being a module ages ago. Plan:

  - fix hw-detect to not put it into /etc/modules any more. While being on that, let's also remove lp, as cups/cups-browsed's init scripts/jobs already load it.

 - Remove "rtc" (and "lp") on upgrades. I think kmod's postinst would be an appropriate place for that.

affects: systemd (Ubuntu) → hw-detect (Ubuntu)
Changed in hw-detect (Ubuntu):
status: New → Triaged
Changed in kmod (Ubuntu):
status: New → Triaged
summary: - [systemd] systemd-modules-load.service always fail
+ systemd-modules-load.service fails: /etc/modules contains nonexisting
+ module "rtc"
Changed in hw-detect (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in hw-detect (Ubuntu):
status: Triaged → Fix Committed
Dimitri John Ledkov (xnox) wrote :
Martin Pitt (pitti) wrote :

Nik,

I don't get this on a standard installation:

could not find module by name='off'
Failed to insert 'off': Function not implemented

can you please attach your /etc/modules file?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hw-detect - 1.95ubuntu3

---------------
hw-detect (1.95ubuntu3) utopic; urgency=medium

  * Drop "Register rtc module on i386 and amd64". Kernel dropped this
    module. (LP: #1317077)
  * Drop "Register lp module on i386 and amd64." as cups now ships
    /etc/modules-load.d/cups-filters.conf which loads lp modules.
 -- Dimitri John Ledkov <email address hidden> Wed, 07 May 2014 09:32:31 +0100

Changed in hw-detect (Ubuntu):
status: Fix Committed → Fix Released
Changed in kmod (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 16-2ubuntu4

---------------
kmod (16-2ubuntu4) utopic; urgency=medium

  * On upgrade to this version, remove rtc module from /etc/modules. rtc
    is obsolete and doesn't exist anymore. This is a clean up after,
    older versions of installers that unconditionally added it to modules.
    LP: #1317077
 -- Dimitri John Ledkov <email address hidden> Wed, 07 May 2014 15:19:40 +0100

Changed in kmod (Ubuntu):
status: Fix Committed → Fix Released
N1ck 7h0m4d4k15 (nicktux) wrote :

Martin,

my /etc/modules file has been modified by me, when I tried to fix the failure of the service. But I can assure you that didn't contain anything related to "off" or similar. Now it has only 'lp' module there. Maybe it was related to 'rtc' ? because when I removed 'rtc' module the warning:

Failed to insert 'off': Function not implemented

disappeared.

Also, if you can take care off this fuse.conf file inside /lib/modules-load.d/ directory it would be better. I mean, this configuration file has the same impact on the systemd-module-load.service, it causes its failure.

Thanks

On 7 May 2014 17:08, Nik.Th. <email address hidden> wrote:
> Martin,
>
> my /etc/modules file has been modified by me, when I tried to fix the
> failure of the service. But I can assure you that didn't contain
> anything related to "off" or similar. Now it has only 'lp' module
> there. Maybe it was related to 'rtc' ? because when I removed 'rtc'
> module the warning:
>
> Failed to insert 'off': Function not implemented
>
> disappeared.
>
> Also, if you can take care off this fuse.conf file inside /lib/modules-
> load.d/ directory it would be better. I mean, this configuration file
> has the same impact on the systemd-module-load.service, it causes its
> failure.
>

That would be a separate bug. At least on my machine i get:

$ dpkg -S /lib/modules-load.d
osspd, fuse: /lib/modules-load.d

Yet, there aren't suppose to be any.

--
Regards,

Dimitri.

N1ck 7h0m4d4k15 (nicktux) wrote :

Dimitri,

on my machine I get

fuse: /lib/modules-load.d

Should I open a separate bug about this ?

I don't have OSS Proxy Daemon installed (it's not installed by default) , but I think FUSE it is. (it has a standard priority instead of optional).

Did you get any errors on osspd module load ?

Regards

Martin Pitt (pitti) wrote :

Nik.Th. [2014-05-07 16:08 -0000]:
> my /etc/modules file has been modified by me, when I tried to fix the
> failure of the service.

Right, and I was interested in whether you modified it in a way that
is supposed to be compatible with kmod, or it really was an invalid
syntax.

> But I can assure you that didn't contain anything related to "off"
> or similar. Now it has only 'lp' module there. Maybe it was related
> to 'rtc'

Yes, it definitively was related to rtc, that's what Dimitri's updates
fixed (i. e. removes rtc on new installs and upgrades).

> Also, if you can take care off this fuse.conf file inside /lib/modules-
> load.d/ directory it would be better. I mean, this configuration file
> has the same impact on the systemd-module-load.service, it causes its
> failure.

Not here. Can you please show me "systemctl status systemd-module-load"?
That ought to have an error message about that.

Thanks!

N1ck 7h0m4d4k15 (nicktux) wrote :

Martin,

Ok, that was my mistake obviously. It is just a warning like

'fuse' is builttin

the systemd-module-load.service is exiting with a SUCCESS status despite this.

I will update the description (removing the fuse.conf related paragraphs).

Thanks.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers