libhunspell-1.1-0 1.1.5-6: Incompatible ABI change

Bug #111940 reported by Bryan Donlan on 2007-05-03
144
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
hunspell (Ubuntu)
High
Unassigned
openoffice.org (Ubuntu)
High
Matthias Klose
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libhunspell-1.1-0

After upgrading libhunspell-1.1-0 from 1.1.4-7 to 1.1.5-6, firefox began crashing whenever I began entering text. On the console, this was emitted:
/usr/lib/firefox/firefox-bin: symbol lookup error: /usr/lib/firefox/components/libmyspell.so: undefined symbol: _ZN8Hunspell5spellEPKc

It seems that there was an incompatible ABI change, and thus the soname of the library must be changed (or the package name itself if that hasn't occured upstream).

Emmet Hikory (persia) wrote :

firefox rebuild is being processed as bug #107340.

openoffice.org doesn't appear to have an active bug, but needs a rebuild (and perhaps porting).

Changed in hunspell:
status: Unconfirmed → Confirmed
Bryan Donlan (bdonlan) wrote :

Shouldn't the name of the binary package be changed, and set to conflicts/replace the original, so as to prevent someone from unwittingly installing a bad combination of packages, and to help catch any packages which were missed in the transition?

Emmet Hikory (persia) wrote :

In general, yes. This early in the development cycle for gutsy, and with only two packages affected, I'm not sure if that step will be taken.

Bryan Donlan (bdonlan) wrote :

This package was in feisty, however, so it's not the same as if you had a new package introduced early in gutsy, then the ABI changed; or am I mistaken?

Emmet Hikory (persia) wrote :

The goal is to ensure that all released and supported pacakges can never reach an unstable state. When a large number of packages is affected, the name change and conflicts may be used (or a false soname bump) to ensure that there is no problem, and that no packages are missed. When a small number of packages is involved, sometimes the migration is handled without such changes. When upgrading to 7.10 from 7.04, updated libhunspell, firefox, and openoffice.org-core packages will all be delivered simultaneously, so that a user of either release should never encounter this situation.

I'm not sure you're mistaken, just that practice is sometimes different than theory. The final solution may well include a change to package names.

Giedrius (giedrbac) wrote :

OOo has same bug as firefox. OOo bug #112901. It is sort of duplicate, but I am not sure if it should be marked as such or not.

Giedrius (giedrbac) wrote :

Bug #112372 is also the same OOo bug. Sorry for the spam, forgot this one when adding last comment.

Emmet Hikory (persia) wrote :

This bug is for hunspell, which managed the transition differently than is preferred. Even if the transition was handled in an ideal manner, there would be bugs against firefox and OOo to be updated to link against the new library. This bug may be closed when any of the following conditions is met:

1) Both packages that depend on libhunspell have been build against linhunspell 1.1.5-6 or later
2) libhunspell is updated such that the old interface is used (and perhaps again updated with new binary names)
3) libhunspell is packaged to conflict with versions of dependent packages compiled against the old interface

Emmet Hikory (persia) wrote :

firefox 2.0.0.3+3-0ubuntu1 includes all necessary changes

Changed in firefox:
status: Unconfirmed → Fix Released
Christian Reis (kiko) wrote :

Updating based on status of bug 107340. I added the tasks to this bug because this is the "right" way to monitor work that needs to happen across multiple packages to solve a single bug. I'm going to file a bug about making the adding of package tasks for a distro easier.

Changed in hunspell:
importance: Undecided → High
Emmet Hikory (persia) on 2007-05-12
Changed in openoffice.org:
status: Unconfirmed → Confirmed

This very issue plaugud me with Thunderbird 2. I am running feisty and wanted a thunderbird 2.0 on my system. I added gutsy repos into the sources.lsit, added a default release into apt.conf and happily installed thunderbird 2.0. It upgraded libhunspell as a dependecy. And now oo crashes. So thunderbird is a third on the list of "small number of packages involved". Changing package names and/or handling a parrallel installation of this lib with two different versions for different application versions would help to track only a part of development release of Ubuntu.
Sorry, I cannot track the whole one, I am working on this system.
Thanks.

John Vivirito (gnomefreak) wrote :

Dennis using gutsy repos with feisty or any repo that is unofficial for your version of ubuntu is not supported nor is it ever recommended due to the very problem you are having. thunderbird 2 was not built and added into feisty for a few reasons, I cant say yet if it will ever make it into feisty in the backports repo as there has not been a date set when mozilla will stop support for the 1.5 branch. When they set a date we will talk about it.

John Vivirito (gnomefreak) wrote :

Why is this bug filed against libhunspell? the version of libhunspell is the correct version that will be in gutsy. The only thing that this bug is about is anything that depends on hunspell 1.1.5-6 needs to be respun/merged using build-depend on gutsys version of hunspell and that will happen during the devel process.

John Vivirito (gnomefreak) wrote :

thunderbird has been built using correct hunspell.

Changed in thunderbird:
status: Unconfirmed → Fix Released
Emmet Hikory (persia) on 2007-05-18
Changed in openoffice.org:
importance: Undecided → Medium
Emilio Pozuelo Monfort (pochu) wrote :

Closing hunspell task, since it's not a bug in it.

Changed in hunspell:
status: Confirmed → Rejected
Emilio Pozuelo Monfort (pochu) wrote :

11:20 < persia> pochu: Why are you rejecting hunspell in bug 111940? The maintainer should have bumped the soname for the ABI change, no?

Looks like there _is_ a bug in hunspell too :)

Changed in hunspell:
status: Rejected → Confirmed
John Vivirito (gnomefreak) wrote :

Yeah sorry about that i heard about this last week its the soname issue and afaik it hasnt been worked out yet.

Matt Zimmerman (mdz) on 2007-05-21
Changed in openoffice.org:
importance: Medium → High
Alexander Sack (asac) wrote :

debian hunspell soname is now in sync with upstream and i doubt that we want to change that for ubuntu alone. If we really want a soname bump we should probably ask hunspell upstream instead of debian and explain the situation to them.

 - Alexander

Emmet Hikory (persia) wrote :

Given the small size of this transition, working with upstream to generate a soname bump is not likely required: more important is coordination between affected packages to ensure that a stable system is released. This remains a bug in hunspell, as a changed ABI was released without a change to either the soname or the binary package name, but at this point the least painful solution is to wait for the next revison of openoffice.org, rather than adjusting hunspell (as otherwise, other libhunspell clients must again be rebuilt).

Emilio Pozuelo Monfort (pochu) wrote :

By the way, there is an OOo 2.2.1 RC1. Maybe it's worth to upload it, fixing this bug and testing that release candidate.

http://development.openoffice.org/releases/2.2.1rc1.html

Wolf Halton (saphil) wrote :

I have tried RC1 on my own box, and it says it can't run swriter bexause openoffice is not installed.

Francesc Vicent (fransex) wrote :

I guess that we will wait until 2.2.1, now it is in release candidate 2: http://development.openoffice.org/releases/2.2.1rc2.html

If you need OOo in gutsy, just install libhunspell 1.1.4 from feisty: http://launchpadlibrarian.net/5769050/libhunspell-1.1-0_1.1.4-7_i386.deb

Francesc Vicent (fransex) wrote :

(but in case you install libhunspell for feisty, you will not be able to use current firefox and thunderbird in gutsy)

Anderson (amg1127) wrote :

"(but in case you install libhunspell for feisty, you will not be able to use current firefox and thunderbird in gutsy)"

You are right.

A possible workaround is:

# wget http://launchpadlibrarian.net/5769050/libhunspell-1.1-0_1.1.4-7_i386.deb
# dpkg --extract libhunspell-1.1-0_1.1.4-7_i386.deb .
# cp usr/lib/libhunspell* /usr/lib/openoffice/program/

So only OpenOffice.org uses the old libhunspell.

Emilio Pozuelo Monfort (pochu) wrote :

Matthias has already merged OOo with Debian (OOo 2.2.1~rc3).

Changed in openoffice.org:
assignee: nobody → doko
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

we will rebuild things against the new hunspell and leave this as it is.

Changed in hunspell:
status: Confirmed → Rejected
Matthias Klose (doko) wrote :

fixed in openoffice.org 2.2.1~rc3-1ubuntu3

Changed in openoffice.org:
status: Fix Committed → Fix Released
Anderson (amg1127) wrote :

A warning for those people that made my workaround....
Now, you must remove old libhunspell from the system.

# rm /usr/lib/openoffice/program/libhunspell*

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions