color regression: no colors in default panel icons

Bug #450825 reported by Kees Cook on 2009-10-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
humanity-icon-theme (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: humanity-icon-theme

The default panel icons have lost all their color, making them difficult to see and understand. (E.g. volume and signal indicator use grey vs light-dark to indicate levels!) This is a regression from Jaunty where the icons were colorful like the rest of the panel, menus, and desktop. All modern video cards made this century can handle 32bit color -- dropping to grey-scale as the default seems to be a mistake. The prior panel icons used color to fill in empty grey bars for volume/signal, etc. This appears to be a regression in that it wildly deviates from the expected theme; to quote: "elementary icons is one of the most recognized and influential icon themes in the open source world." https://wiki.ubuntu.com/Artwork/Incoming/Karmic/Humanity_Icons

This should be fixed in conjunction with bug 450809, which is another color regression.

ProblemType: Bug
Architecture: amd64
Date: Tue Oct 13 16:05:16 2009
DistroRelease: Ubuntu 9.10
Package: humanity-icon-theme 0.4.1ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: humanity-icon-theme
Uname: Linux 2.6.31-13-generic x86_64

Kees Cook (kees) wrote :
tags: added: regression-potential
Vish (vish) wrote :

This was a design decision. The reasons where:
- The notification area icons a constant presence and the use of color draws undue attention to these icons.
- But rather , if the use of color [red] is restricted to only errors and warnings, when these icons gain color for the errors and warnings more attention is grabbed by these icons , which would lead the users to react more quickly.

Marking it as incomplete , because , any change for Ubuntu needs to be directed by the UX team.

Changed in humanity-icon-theme (Ubuntu Karmic):
status: New → Incomplete
Kees Cook (kees) wrote :

Crash report icon is light grey. It should at least be red by this design. :P

Changed in humanity-icon-theme (Ubuntu Karmic):
status: Incomplete → New
Vish (vish) wrote :

Nice catch ;)
Could you file a separate bug for that? We can push the fix by today.

Loïc Minier (lool) wrote :

See also bug #430277 for discussion of this topic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.4.1ubuntu4

---------------
humanity-icon-theme (0.4.1ubuntu4) karmic; urgency=low

  [ Kenneth Wimer ]
  * Moving this to ubuntu-art-pkg team
  * Editing apport icon to red ; LP: #450825 .
  * Adding 24px Bluetooth icon and renaming previous greyscale icon to
    bluetooth-active. Removed app icons from Humanity-Dark which are no longer needed ; LP: #437162
  * Edits to user status icons to avoid using English characters in the bubbles ; LP: #439743
  * Adding gpm-* icons ; LP: #449334
  * Adding U1 icons ; LP: #438641
  * Correcting drive-* label ; LP: #436462
  * Different icons for volume mute and volume-0 , LP: #444548
  * updated to include various small changes to documents-*, synaptic actions
  * merged into release packaging and ready for upload

  [ Martin Pitt ]
  * debian/control: Add Vcs-Bzr: header.

 -- Kenneth Wimer <email address hidden> Wed, 14 Oct 2009 19:05:08 +0200

Changed in humanity-icon-theme (Ubuntu Karmic):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers