Battery monitor is red even when 30% charge remains

Bug #32921 reported by Matthew East
86
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-power
Unknown
Medium
human-icon-theme (Ubuntu)
Low
Kenneth Wimer

Bug Description

When I have over 30% battery life remaining, the battery applet from gnome-power-manager is showing extremely low and red. This is quite confusing, because I have to hover my mouse over it to find out that I have another hour or so of battery life.

Matt

Revision history for this message
Richard Hughes (richard-hughes) wrote :

Please attach a gnome-power-maanger verbose trace to this bug report.

See http://www.gnome.org/projects/gnome-power-manager/bugs.html

Thanks.

Revision history for this message
Matthew East (mdke) wrote :

I will try and do that. I assumed that it was a simple choice made by the program designers to have the battery applet go red when the battery is under 35% or so. If that is not the case, I'll certainly produce a trace.

Matt

Revision history for this message
Richard Hughes (richard-hughes) wrote :

35% seems a little high. How long does your battery last?

Revision history for this message
Matthew East (mdke) wrote :

My battery lasts about 2 and a half hours, although that is quite a rough guess.

Revision history for this message
Matthew East (mdke) wrote :

A bit more information: I currently am on a Breezy installation, with 33% of battery left: this is equivalent to 47 minutes according to the gnome-applet. The gnome applet is still green, which seems to me to make good sense. At most, I could understand if it were orange, but certainly not red.

Revision history for this message
Daniel Silverstone (dsilvers) wrote :

The icon theme system changed considerably in the latest version (2.13.92-0ubuntu1) can you please confirm if this is still an issue?

Revision history for this message
Matthew East (mdke) wrote :

Yes, the icon is still very pessimistic: I have 42% (just over an hour) remaining at the moment, and the icon is already orange and about a quarter of the little battery is filled up. I will wait and see when it turns red.

Revision history for this message
Richard Hughes (richard-hughes) wrote :

Can you have a look at http://live.gnome.org/GnomePowerManager/Icons and tell me what you think please. Thanks.

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 32921] battery monitor is red even when I have over 30% battery left

On Thu, 2006-03-23 at 16:38 +0000, Richard Hughes wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/32921
>
> Comment:
> Can you have a look at http://live.gnome.org/GnomePowerManager/Icons and
> tell me what you think please. Thanks.

Sure: my thought is that failing to make a distinction in the percentage
of fill between low and critical time remaining is not a good idea. The
percentage fill should broadly reflect the percentage battery time
remaining, in my opinion.
--
<email address hidden>
gnupg pub 1024D/0E6B06FF

Revision history for this message
Richard Hughes (richard-hughes) wrote : Re: battery monitor is red even when I have over 30% battery left

Can you add that to the wiki, underneath please. I want to get lots of opinions on this so we can properly fix this for 2.15.x. Thanks.

Revision history for this message
Matthew East (mdke) wrote :

So is this not going to be fixed for Dapper? it is rather disconcerting to have a red battery icon which is nearly empty when I actually have plenty of battery time left. If this won't get fixed, I will probably go back to the gnome applet, because I only use the icon for telling how much battery I have left anyhow (I don't use the right-click features).

Sorry to be pedantic, but for me this is a regression since Breezy, and it sounds like it is an unnecessary one.

Revision history for this message
Trent Lloyd (lathiat) wrote :

Yeh the gnome-power-manager icons are not fantastic, and having icons with a granularity of 3 is bad, it should do them custom or something to make it nice, or at least have say, 6 icons

For me, being orange when jus under 50% is ridiculous, and red under 30% too

It should be oragne at maybe, 35 and red and say 15, and the icons should give you a much better idea of the actual charge, e.g. at 49% it looks like im <1/3rd

Revision history for this message
Richard Hughes (richard-hughes) wrote :

Trent, can you add to the wiki (http://live.gnome.org/GnomePowerManager/Icons) your suggestions please. Many thanks.

Revision history for this message
Matthew East (mdke) wrote :

If we post the comments we've made on this bug to the GNOME wiki, will it improve the chances of this bug being fixed for Dapper? If so, I'll be very happy to go and register for that wiki.

If not, might I suggest that we set gnome-power-manager's battery icon to 'never' and include the gnome battery applet by default where the user is on a laptop (I think this is already included by default)?

Matt

Simon Law (sfllaw)
Changed in gnome-power-manager:
status: Unconfirmed → Confirmed
Revision history for this message
Crispin Flowerday (crispin-flowerday-deactivatedaccount) wrote :

This is still a problem in edgy, the Human icon theme seems to think that less than 50% battery deserves an orange icon that looks to be about 30% full, and less than 30% is a red icon.

My laptop can last almost 4 hours, so 30% equates to over an hour of power left, I hardly think that is a critical problem.

I would dump the gpm-primary-000 icons, and effectively move the rest down one level (e.g. 020 -> 000, 040 -> 020, 060 -> 040) and then create a new 060 one that is between the current 060 one and the 080 one. This would be much closer to the hicolor theme which has

Revision history for this message
Crispin Flowerday (crispin-flowerday-deactivatedaccount) wrote :

Any progress on fixing the icons in the Human theme for feisty?

They still imply that things are much worse than they are. The theme designers should compare the icons in the hicolor theme and the ones in the Human theme and notice that the ones in the hicolor theme don't start going orange till the 020 icon whereas the Human ones go to orange in the 040 one, hence the confusion.

Revision history for this message
hackel (hackel) wrote :

Just thought I would add the requisite "this is not fixed under Hardy either" message. I echo others' comments that it's quite disconcerting to see your battery power in orange when you're basically half-full, or red when down to only 1/3. Red means panic, everybody's gonna die! Hurry up before your machine hibernates on you in the middle of what you were doing! Perhaps we could even have...(drum roll please)...a *fourth* colour! Something between green and orange, or even two shades of green. Just an idea. It seems like these are rather trivial graphical changes here, we just need someone to take a look at it.

Also, I believe the 100% icon is not ideal either, as to me it looks like it's not 100%, but rather 1 notch down (90%?) as there is a tiny bit of grey that appears above the green, even though there is the darker grey band that's meant to represent the top of the scale, it seems confusing to me. I think the green needs to go to the very top of the battery icon in this case.

Finally, I wish the Human theme included proper SVG icons for gnome-power-manager that scale smoothly when I resize my panel.

I changed the package to human-icon-theme as that's where the major issue really lies. If we want to have more steps for the icons, then that should be a separate g-p-m feature request.

Revision history for this message
marco.pallotta (marco-pallotta) wrote :

The same bug is present in Hardy Heron x86-64

Revision history for this message
Matthew East (mdke) wrote :

This bug is still present in Ubuntu 8.10. The icons for gnome-power-manager are still extremely poor and don't reflect the actual state of the battery.

In the attached screenshot the icon seems to indicate that I am very low on battery and have around 20%, in fact I have 49.6% battery left, nearly two hours.

Has a policy decision been taken to keep these icons despite all the comments in this bug report?

Revision history for this message
Matthew East (mdke) wrote :

I'd opened a bug upstream on gnome-power-manager, but have realised that this bug is indeed just a bug in the Human icon set, and is therefore Ubuntu specific. I'll raise it on the mailing list to see if anyone is willing to fix it.

Revision history for this message
Matthew East (mdke) wrote :

Here's another example screenshot - icon shows red and empty when the correct state is in fact 26%.

Changed in gnome-power:
status: Unknown → Invalid
Mat Tomaszewski (mat.t.)
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Alejandro Vidal (mancvso) wrote :

this doesn't happend me now using elementary or elbuntu

https://wiki.ubuntu.com/Artwork/Incoming/Karmic/elebuntu_Icons

for me. it seems to be a lack of icon states only... AM I wrong?

Revision history for this message
The Wind Blows (zachanimerulz) wrote :

The Battery color should be time based.

Some laptop's netbooks have up to 6 hrs of battery life.
35% of that is around 2 hours.

Possibly just having a percentage overlay on top of the battery icon that can be quickly read.

Otherwise tapping into notifications a warning that appears.
First "Warning" : 45 minutes of battery remaining.
Second "Warning" : 30 minutes of battery remaining.
Third "Warning" : 15 minutes of battery remaining.
Fourth "Warning" : 10 minutes of battery remaining.
Fifth "Warning" : 5 minutes of battery remaining.

With the Fourth. Plug in your Laptop NOW or close all applications and shutdown.
With Fifth Warning. Ask the user to go into hibernation to save all their active work until they can charge the laptop.
If the user doesn't respond to the Fifth Warning in two minutes the laptop will automatically hibernate.

Of course the issue with the fifth warning is if hibernation doesn't work on the laptop in which event the best solution left is to repeat the Fourth Warning idea.

Changed in hundredpapercuts:
milestone: none → round-4
Revision history for this message
Michael Keppler (bananeweizen) wrote :

I fully agree with the last commenter that the percentage based approach is just plain wrong and the "threat" level should be calculated by remaining time instead of remaining percentage.

Revision history for this message
Johan Kiviniemi (ion) wrote :

Giving some kind of notification a good while before the battery is drained empty (perhaps around 33 %) would be a good thing, since a battery can only handle a certain number of full discharges.

http://batteryuniversity.com/parttwo-34.htm

Of course, users would need to be educated. How about a red notification icon with a tooltip that says “The battery is at 33 % capacity. You still have n hours, n minutes of runtime, but if you have the chance to connect the computer to mains now, it will prolong your battery lifetime.”

Revision history for this message
Bratwurstler (j-sage) wrote :

Do we need a colored icon? Maybe a monochrome/black high contrast icon would do a better job. At low (<10%) percentage this could turn red. As the battery icon doesn't need too much visual attention, as long as it isn't necessary to charge, a black one would do a good job.

Monochrome status icons do a pretty awesome job in OS X. The current Ubuntu panel has too much colores, hasn't it? Even if this is a GNOME-issue, please think about it. :)

Revision history for this message
Wouter Stomp (wouterstomp-deactivatedaccount) wrote :

Bratwurstler, I filed a separate bug for that: bug 408029

summary: - battery monitor is red even when I have over 30% battery left
+ Battery monitor is red even when 30% charge remains
Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Ken, can you reserve the color red for battery icons indicating <= 10% remaining?

Changed in human-icon-theme (Ubuntu):
assignee: nobody → Kenneth Wimer (kwwii)
Revision history for this message
Kenneth Wimer (kwwii) wrote :

We need to make an informed decision as to which states really need color to denote the battery level. We discussed this during the Jaunty cycle and changed things accordingly, now things seem to be problematic again ;(

Revision history for this message
Soren Hauberg (hauberg) wrote :

I can't help but think that you are looking at the wrong problem. When I have plenty of power on my battery I have a big green thingy at the top of my screen that is highly visible, but when I'm low on power I have a small red thingy that isn't all that visible. Instead of the applet focusing on how much of the battery I have spend, it should focus on how much I have left; it is really the only thing I care about. I'm not quite sure how to do that though :-(

Revision history for this message
Omer Mano (mermerico-gmail) wrote :

I would just like to add that ubuntu is not quite ready for a time-based approach. Currently, the power manager thinks I have 10 hours of battery life left with 10% remaining. Obviously this is not true. Other, non-papercut bugs must be fixed before we go to time-based warnings.

Revision history for this message
Michael W. Koehler (mkoehle1) wrote :

Just expanding on these ideas....I just unplugged my laptop from the power source to test out the problem at hand. I noticed that within two minutes, the battery level dropped 1/3 - Turns out that this is equal to my percentage. In the two minutes since I unplugged my computer, the battery level dropped from 2 hours 20 minutes remaining (100%) to 1 hour 30 minutes remaining (66.6%). Now it's down to 1 hour 10 minutes remaining (61.2%). FYI - my laptop battery lasts for about 2 hours and 15 minutes.

I realize that the problems in this post are mainly related to the human icon theme, but there are issues with power estimation.

Revision history for this message
corcov (gax) wrote :

Hi, I have read that you should discharge your battery only to 50% (if possible) so that might be the reason for delivering a red colour that early. I like this the way it is. Greetings, corcov

Revision history for this message
Vish (vish) wrote :

Fix released, as the default icon theme is now , Humanity icon theme and the red color is used only at 20% and below

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Revision history for this message
Chris (chainzster) wrote :

Hi all, I know this bug is now labelled as fixed, but it still is a problem for me. My Icon shows as almost empty (red and 2 pixels high) even though I have %25 and around 1.5 hrs remaining. I am using the default icons.
Can we change this bugs status back to Confirmed and readdress it?
Cheers

Revision history for this message
Vish (vish) wrote :

@Chris :
The humanity icons are designed different. The icons for 20% and 0% alone are red. Which was not how it was with human icon theme.
That was what this bug was about and was fixed.

You can see the different icons in the /usr/share/icons/Humanity/status/24/ folder
If the wrong icon is used by the power manager , then it is a bug in the gnome-power-manager.
Kindly open a separate bug for that.

Changed in gnome-power:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.