Please merge the package htop 0.8.3(universe) from debian unstable(main)

Bug #385862 reported by Bhavani Shankar on 2009-06-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
htop (Ubuntu)
Wishlist
Chris Coulson

Bug Description

Binary package hint: htop

Debian has a new version to be merged

 htop (0.8.3-1) unstable; urgency=low

   * New upstream release:
     - 0.8.2 (LP: #385862):
       - Integrated lsof output. (Closes: #426003)
       - Handling of absend CPU should work now. (Closes: #494057, #476273)
       - Fixed a crash when sorting by USER column. (Closes: #526362)
       - Fixed display of gigabyte-sized values.
       - Fixed incremental search. (Closes: #521376)
       - Option to display hostname in the meters area.
     - 0.8.3
   * debian/control:
     - Suggested strace and ltrace. (Closes: #530449)
     - Bumped Standards-Version to 3.8.2, no changes needed.
   * debian/patches:
     - 700-ltrace-support.patch: modified to not contradict with new upstream
       release, the hotkey for ltrace output changed from 'l' to 'L'.
   * debian/README:
     - Added with note about ltrace support.

 -- Eugene V. Lyubimkin <email address hidden> Mon, 29 Jun 2009 13:08:39 +0300

Bhavani Shankar (bhavi) on 2009-06-11
Changed in htop (Ubuntu):
assignee: nobody → Bhavani Shankar (bhavi)
status: New → In Progress
Bhavani Shankar (bhavi) on 2009-06-11
Changed in htop (Ubuntu):
assignee: Bhavani Shankar (bhavi) → nobody
status: In Progress → New
summary: - Please update the package to 0.8.2
+ Please update the package to 0.8.3

I think since upstream has added ubuntu ram alignment patch we can sync it through...

Bhavani Shankar (bhavi) wrote :

Can you please test build the debian source?

Yes, it works

Daniel Holbach (dholbach) wrote :

Bhavani: where did Upstream add the Ubuntu ram alignment patch? Can you point me to it?

Bhavani Shankar (bhavi) wrote :

Fix display of gigabyte-sized values
  (thanks to Andika Triwidada)

I think the above change implies the same as ubuntu one.. Sorry if I am wrong ....

Regards

Krzysztof Klimonda (kklimonda) wrote :

@dholbach: The upstream bug is here: http://sourceforge.net/tracker/index.php?func=detail&aid=2577889&group_id=108839&atid=651633
Now, the problem is that the patch that was applied upstream isn't the same that was applied by us.
Citation from From bug 327664:
"on a second thought, field width 4 "%4.1fG" is more proper than my previous one "%3.1fG", so new patch"
but the patch that was send, and has been applied by upstream developer uses "%3.1fG" and not "%4.1fG"
Unfortunately neither do I have a system with enough ram to test if fix is working nor do I have time to investigate it further in following days :/

Changed in htop (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Bhavani Shankar (bhavi) wrote :

okay converting to a merge...

summary: - Please update the package to 0.8.3
+ Please merge the package htop 0.8.3(universe) from debian unstable(main)
description: updated
Bhavani Shankar (bhavi) on 2009-07-09
Changed in htop (Ubuntu):
status: Incomplete → Confirmed
Bhavani Shankar (bhavi) wrote :
Changed in htop (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package htop - 0.8.3-1ubuntu1

---------------
htop (0.8.3-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #385862)
    - debian/patches/910-ubuntu-64bit-ram-alignment.patch
      + Refresh patch.

 -- Bhavani Shankar <email address hidden> Thu, 09 Jul 2009 11:32:08 +0530

Changed in htop (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.