[Feisty] Starting HPLIP Toolbox in DVD edition or after update through internet: No python-qt3, but plenty of space on DVD or internet repository

Bug #86893 reported by Laurent GUERBY on 2007-02-21
108
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Medium
Till Kamppeter
ubuntu-meta (Ubuntu)
High
Ubuntu Release Team

Bug Description

Binary package hint: hplip

On feisty with all updates to date, in the control center clicking on "HPLIP Toolbox" does nothing.

Using command line I got:

$ hp-toolbox
error: PyQt not installed. GUI not available. Exiting.
error: PyQt/Qt initialization error. Please check install of PyQt/Qt and try again.

So I did:

$ sudo apt-get install python-qt3

And then it worked (a bit ugly but ...).

I suggest adding dependencies so that HPLIP works out of the box.

Sincerely,

Laurent

At least we should have the dialog window back that indicated: "the python-qt3 package must be installed for this program to work".

hplip (1.7.1-1ubuntu1) feisty; urgency=low

  * 61_noqt_message.dpatch: Removed, functionality implemented upstream.

 -- Till Kamppeter <email address hidden> Mon, 29 Jan 2007 12:58:47 +0000

Changed in hplip:
importance: Undecided → Medium
status: Unconfirmed → Confirmed

This bug is not a duplicate of #67892.
Bug #67892 is about duplicate HPLIP Toolbox entries in the gnome menu while bug #86893 is about the fact that nothing happes when the user clicks on the HPLIP Toolbox entry in the menu because python-qt3 is not installed.

Bug #88290 is NOT a duplicate of this bug.

Bug #86893 deals with hp-toolbox not working if python is not installed.

Bug #88290 deals with an icon not showing up because the filename does not match the Icon attribute in the desktop entry.

Till Kamppeter (till-kamppeter) wrote :

See my suggestion for a new dialog box in bug 89413.

Till Kamppeter (till-kamppeter) wrote :

We should make one new HPLIP package with the following fixes:

1. Remove hp-toolbox.desktop and add "NoDisplay=true" to hplip-desktop (bug 67892)

2. Correct the writing of the icon file names in the .desktop files (bug 88290)

3. Add a dialog which pops up when starting an HPLIP GUI tool without python-qt being installed. The dialog should have a button for installing python-qt (bug 86893)

As I am not familiar with Python GTK stuff (needed for 3), I appreciate if someone can make such an HPLIP package.

Alessio Caiazza (nolith) wrote :

If someone tells me the command to run for starting package manager with python-qt selected for install I can try to implement this.

I think that the fastest way should be using Tk interface which should be implemented by default in python.

Bye

Someone writes:

If python-qt is missing (default live session or installation from Ubuntu/Xubuntu/Edubuntu desktop CD) pop up a Window as follows:

------------------------------------------------------------

To run the HP Toolbox the python-qt package is nedded to be installed which does not ship with the desktop CD due to space reasons.

Do you want to install it now?

[ Install python-qt ] [ Abort running HP Toolbox ]

------------------------------------------------------------

If the user decides to install the package manager is started and the python-qt package gets installed. After that HP-Toolbox gets started.

Till Kamppeter (till-kamppeter) wrote :

Please test the packages on

http://www.linux-foundation.org/~till/tmp/ubuntu/feisty/hplip/binary/

They are on their way into Feisty.

Changed in hplip:
status: Confirmed → Fix Committed

I installed (on up to date Feisty) all the packages listed at the above URL, but no luck, the menu icon still doesn't start anything...

Till Kamppeter (till-kamppeter) wrote :

This is strange, I have tested with installed python-qt3 and with python-qt3 removed and I got the correct reaction, either the main window of the tool or an error message window telling that python-qt needs to be installed. Can you attach the following files:

/usr/share/applications/hplip.desktop
/usr/share/applications/hp-fab.desktop
/usr/share/applications/hp-sendfax.desktop

Can you post the output of

dpkg -l '*hplip*'

and of

ls -l /usr/share/applications/hp-toolbox.desktop

Are you sure you have installed all files with "sudo dpkg -i <file>.deb"?

> Can you attach the following files...

Attached...

> Can you post the output of
> dpkg -l '*hplip*'
> and of
> ls -l /usr/share/applications/hp-toolbox.desktop

$ dpkg -l '*hplip*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii hplip 1.7.3-0ubuntu1 HP Linux Printing and Imaging System (HPLIP)
un hplip-base <none> (no description available)
ii hplip-data 1.7.3-0ubuntu1 HP Linux Printing and Imaging - data files
un hplip-doc <none> (no description available)
un hplip-ppds <none> (no description available)

$ ls -l /usr/share/applications/hp-toolbox.desktop
ls: /usr/share/applications/hp-toolbox.desktop: No such file or directory

> Are you sure you have installed all files with "sudo dpkg -i <file>.deb"?

No, I didn't use the command line, I just double clicked on all the .deb files/packages one by one, and let Gdebi do the job.

Can you do the following:

sudo dpkg -r --force-depends hplip

Then look into your menues whether there are still entries for the HPLIP tools (hp-toolbox, hp-sendfax, ...). If so, please tell here and remove the entries with the menu editor (System -> Preferences -> Main Menu). Then install the hplip package again

sudo dpkg -i hplip_1.7.3-0ubuntu1_i386.deb

or double-click your downloaded file. Then open the menu editor again and activate the hidden menu entries of HPLIP: HP Toolbox in System -> Preferences and the two HP fax tools in Applications -> Office.

> Can you do the following:
> sudo dpkg -r --force-depends hplip

Done.

> Then look into your menues whether there are still entries
> for the HPLIP tools (hp-toolbox, hp-sendfax, ...).

The "HP Tool box" icon is gone indeed.

> Then install the hplip package again

Done.

> Then open the menu editor again and activate the hidden
> menu entries of HPLIP: HP Toolbox in System -> Preferences
> and the two HP fax tools in Applications -> Office.

Okay, I found all these icons, and enabled them all. So far so good ! ;o)

...but, the HP Toolbox still won't come up... :-/
I tried the HP fax icon, and it doesn't start either. Instead it gives a warning message asking to install python-qt3 to get the GUI working.

What happens if you run

sh -c 'STARTED_FROM_MENU=yes /usr/bin/hp-toolbox'

on the command line?

Can you also look up the HP Toolbox manu entry in the menu editor, right-click it, choose "Properties" and then post the contents of all the fields of the dialog here?

> What happens if you run
> sh -c 'STARTED_FROM_MENU=yes /usr/bin/hp-toolbox'
> on the command line?

It pops up the warning message about Python-qt3.

> Can you also look up the HP Toolbox manu entry in the menu editor,
> right-click it, choose "Properties" and then post the contents
> of all the fields of the dialog here?

The command is just "/usr/bin/hp-toolbox".
I attached a screenshot of the menu editor anyway, if that helps.

What is in your ~/.local/share/applications/ directory?

If there is a file hplip.desktop, hp-toolbox.desktop, or any other hp-*.desktop, delete them. This should fix your problem. If nothing happens immediately, log out and log in again.

Till - I just tried the following:

Used Synaptic to uninstall py-qt3, hplip, hplip-data and hpjis packages.

Installed hpijs-ppds_2.7.2+1.7.3-0ubuntu1_all.deb,
hpijs_2.7.2+1.7.3-0ubuntu1_i386.deb, hplip-data_1.7.3-0ubuntu1_all.deb and
hplip_1.7.3-0ubuntu1_i386.deb from your link above by downloading them and
double-clicking them in synaptic. None of these called in python-qt3, so
when starting hp-toolbox from the command-line, I still get the error
message about midding python-qt3. And I notice that by looking at the
properties of package hplip in Synaptic, it both suggests and recommends
python-qt3 but does not depend on it. Installing python-qt3 of course fixes
the toolbox and it runs fine then.

On 27/03/07, Till Kamppeter <email address hidden> wrote:
>
> What is in your ~/.local/share/applications/ directory?
>
> If there is a file hplip.desktop, hp-toolbox.desktop, or any other
> hp-*.desktop, delete them. This should fix your problem. If nothing
> happens immediately, log out and log in again.
>
> --
> [Feisty] Clicking on HPLIP Toolbox in gnome menu does nothing
> https://launchpad.net/bugs/86893
>

Ahhh, indeed I had 3 desktop entries in my home directory, for some reason.
I deleted them and restarted Gnome, now I do get the Python warning for the hp-toolbox. Next step: display hp-toolbox itself, rather than a warning ! ;o)

Trouilliez vincent, this bug is now fixed, as the HP-Toolbox entry in the menu does not do nothing any more. With python-qt3 installed the toolbox shows up and otherwise a message clearly informing the user that python-qt3 needs to be installed.

That HPLIP does not require python-qt3 is another story. python-qt3 needs another 20 MB on the live CD of Ubuntu, Xubuntu, and Edubuntu. Therefore it is not on these CDs. The problem before fixing this bug was that the user did not get informed about that python-qt3 is needed, instead there was no answer at all to the user's click on the hp-toolbox menu entry.

Can you do the tests described in bug 98520 (2nd posting)? This way we can decide whether we solve this problem bia HPLIP 1.7.3 or by patching HPLIP 1.7.1.

Tollef Fog Heen (tfheen) on 2007-03-30
Changed in hplip:
assignee: nobody → till-kamppeter

This will be fixed as sson as a decision on bug 98520 is made. So in Feisty it will be fixed.

Changed in hplip:
status: Fix Committed → Fix Released
Nathan Adams (nadams) wrote :

Getting back to the intent of this bug, Bug #86893: I reproduced the problem on Ubuntu 6.10 - the Edgy Eft.

$ hp-toolbox
error: PyQt/Qt initialization error. Please check install of PyQt/Qt and try again (the python-qt3 package must be installed for this program to work).

The hp-toolbox package just needs to depend on the python-qt3 package; no fancy pop-up dialogs required.

Please read the bug report... it clearly states that the missing dependency will NOT be installed, because it takes up huge space, which is not available on the Install CD.
HOWEVER.... it is also missing on the DVD AFAICR, despite there is obviously plenty of space available on the DVD !
Then there is also the case where one upgrade from Edgy to Feisty over the internet, using the dist-upgrader, in this case there is no space limitation, as no physical media is used. Same applies when installing (from scratch) from the network.
So although the case of the CD is not debatable anymore, we should at leat make sure that the missing dependency are installed in all other cases (dist-upgrader via internet, or net install, or DVD).

Trouilliez vincent, I have assigned this problem to the ubuntu-meta package now. python-qt should really be on all DVDs and on the internet updates.

Changed in ubuntu-meta:
assignee: nobody → ubuntu-release
importance: Undecided → High
status: Unconfirmed → Confirmed

Reported your problem on

https://www.stgraber.org/ubuntu/isotesting

as it is an issue of the ISOs.

According to

http://cdimage.ubuntu.com/dvd/current/feisty-dvd-i386.list

python-qt3 is even on the DVD, problem is that it is not automatically installed. All installation types (Live session, Ubiquity, direct installation, OEM installation) need to be checked.

TomasHnyk (sup) wrote :

I am sorry but this seems to be still an issue with Feisty - at least for me running hplip-toolbox from system>preferences silently failed after a clean install of Feisty.

That's odd. I did a fresh install of feisty from the "alternate" installer
CD, and I get a suitable pop-up telling me what package needs installing to
get the HPLIP GUI and the command to do it.

@ThomasHynk
This is a dist-upgrade issue if you upgraded from Edgy to Feisty, on a clean Feisty install this will not happen.

Please remove hplip.desktop and/or hp-toolbox.desktop from ~/.local/share/applications/
HPLIP Toolbox is hidden from the menus by default, you need to show it by clicking System > Preferences > Main Menu then select System > Preferences > HPLIP Toolbox.

Since hplip.desktop has NoDisplay=true we will always have to show it in the menus through System > Preferences > Main Menu which creates a copy of the desktop file in ~/.local/share/applications/ with NoDisplay=false.
So this is a bug in hplip, on a dist-upgrade hplip.desktop and hp-toolbox.desktop under ~/.local/share/applications/ should be removed for all users.
Reopening hplip task.

Changed in hplip:
status: Fix Released → Confirmed
TomasHnyk (sup) wrote :

Oh, I see, I did a clean install, but I kept my /home directory.

Jeffrey Baker (jwbaker) wrote :

I think the real question is why we need this useless program cluttering up the Preferences menu. It doesn't work well, it doesn't fit in with the Ubuntu look-and-feel, its icon is a hideous, meaningless vendor logo, and in general the program is a user-hostile insult.

Jeffrey Baker (jwbaker) wrote :

Oh, by the way, this is still a problem in Gutsy. Perhaps the bug title could be updated.

steve.horsley (steve-horsley) wrote :

You work for an HP competitor perhaps? I agree that it cold be prettier, but
having an HP printer myself, I find being able to check the ink levels
rather useful.

On 24/08/07, Jeffrey Baker <email address hidden> wrote:
>
> I think the real question is why we need this useless program cluttering
> up the Preferences menu. It doesn't work well, it doesn't fit in with
> the Ubuntu look-and-feel, its icon is a hideous, meaningless vendor
> logo, and in general the program is a user-hostile insult.
>
> --
> [Feisty] Starting HPLIP Toolbox in DVD edition or after update through
> internet: No python-qt3, but plenty of space on DVD or internet repository
> https://bugs.launchpad.net/bugs/86893
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Changed in hplip:
status: Confirmed → Fix Committed
description: updated

hplip (2.7.7.dfsg.1-0ubuntu2) gutsy; urgency=low

  * debian/control, debian/hplip.install, debian/hplip-gui.install,
    debian/rules:
    Moved menu entries for the GUI utilities into the new hplip-gui package.
    This package requires python-qt3 and so the menu entries can never appear
    if python-qt3 is not installed. Let the main package (hplip) recommend
    hplip-gui instead of python-qt3 now. Fixes: LP: #67892, LP: #86893,
    LP: #134480, LP: #137168

 -- Till Kamppeter <email address hidden> Wed, 5 Sep 2007 10:05:57 +0100

Changed in hplip:
status: Fix Committed → Fix Released
Jonathan Riddell (jr) on 2007-09-07
Changed in ubuntu-meta:
status: Confirmed → Fix Released
Charles IRONS (ironscf) wrote :

As a GUI level user of Ubuntu, I have read all the above discussion and am rather bemused that the HP Toolbox depends on a 20 Mb python-qt3. I installed Gutsy from CD recently and would like to check ink levels and scan documents. My dial-up modem would take far too long to download 20Mb. Am I correct to assume that I should buy a DVD distro next time? I assume they are available in South Africa?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers