Unwanted HPLIP Toolbox entry in gnome menu

Bug #67892 reported by manuel on 2006-10-24
32
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Medium
Unassigned
grub-installer (Ubuntu)
Undecided
Unassigned
hplip (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu Edgy 6.10 RC 10.23.2006 has a broken dependence.

When HPLIP was selected form System /administrator, a dialog display:

PyQt/Qt initialization error. Please check install od PyQt/Qt and try again (the python-qt3 package must be installed for this program to work)

I don't have HP printer but HPLIP was installed. This may be an orphan from 6.06. It was successfully removed now w/out warnings.

Later,
Manuel Soto

I have got the same problem! I installed the package (python-qt3) via synaptic. This works, but then hplip says "No installed HP devices found". Can you confirm this too?

Changed in hplip:
status: Unconfirmed → Confirmed
manuel (manuel-soto) wrote :

Sorry,
   I haven't HP devices. I got this messages from 6.04 but only now I was enabled to uninstall the package.

This issue is still present on a plain vanilla Ubuntu 6.10 Edgy Eft install, on both 1386 and AMD64 architecture.
Package python-qt3 should be required package instead of recommended.

Changed in hplip:
importance: Undecided → Medium
Till Kamppeter (till-kamppeter) wrote :

Current HPLIP (1.6.9 and later) allows most tools to be used in text mode ('-n' option), for faxing one can use for example

hp-sendfax -n -p <fax queue> -f <fax number> <files>

So one can for example pre-configure a GNOME/GTK Fax GUI to use this command line. This could be done by printerdrake when setting up a fax queue.

One could also add ink level check and nozzle cleaning functions to printerdrake, which simply call the appropriate command line tools of HPLIP.

See

https://features.launchpad.net/distros/ubuntu/+spec/printerdrake
https://wiki.ubuntu.com/PrinterDrake

Stu Hood (stuhood) wrote :

Till Kamppeter:

If that is the intended usage of the utilities, then HPLIP should probably not be shown by default in the menu. Especially if we aren't going to install one of its graphical dependencies.

Till Kamppeter (till-kamppeter) wrote :

As the GUI dependencies are available on Kubuntu, we should make them optionally available, separating all files which are oly used by the GUIs and also the menu entry files into an extra package (hplip-gui) which is dependent on Python/Qt. This package we ship only on the Kubuntu CDs and not on the Ubuntu/Xubuntu CDs.

WDYT?

Till Kamppeter (till-kamppeter) wrote :

Don, can you tel us which files are only used by the GUIs and not needed to run the tools in text mode? And which tools do not have text mode at all (like hp-toolbox)?

Hi, Till-

All hp-* tools currently have a non-GUI (text) mode except hp-toolbox. There
would be a small number of files that would not be needed if GUI features
were turned off (<20?). I can provide an exact list if needed.

So, would the user not be able to install the HPLIP GUIs on Ubuntu or
Xubuntu?

-Don

On 12/10/06, Till Kamppeter <email address hidden> wrote:
>
> Don, can you tel us which files are only used by the GUIs and not needed
> to run the tools in text mode? And which tools do not have text mode at
> all (like hp-toolbox)?
>
> --
> HPLIP failed to start PyQt/Qt missing
> https://launchpad.net/bugs/67892
>

Matthias Klose (doko) wrote :

Stu Hood schrieb:
> If that is the intended usage of the utilities, then HPLIP should
> probably not be shown by default in the menu.

yes, that's the default. if it's shown, you explicitely enabled it with
the menu editor.

The HPLIP 1.6.10-2ubuntu1 (current Feisty) contains the following 4 .desktop files:

till@till-laptop:~/ubuntu/hplip/hplip-1.6.10$ dpkg -c ../hplip_1.6.10-2ubuntu1_i386.deb | grep '\.desktop'
-rw-r--r-- root/root 302 2006-12-11 10:54 ./usr/share/applications/hp-fab.desktop
-rw-r--r-- root/root 262 2006-12-11 10:54 ./usr/share/applications/hp-sendfax.desktop
-rw-r--r-- root/root 281 2006-12-11 10:54 ./usr/share/applications/hp-toolbox.desktop
-rw-r--r-- root/root 266 2006-12-11 10:54 ./usr/share/applications/hplip.desktop
till@till-laptop:~/ubuntu/hplip/hplip-1.6.10$

All hp-*.desktop files contain a line "NoDisplay=true", so they do not appear in the desktop menues by default. The hplip.desktop and hp-toolbox.desktop files are identical except that hplip.desktop DOES NOT contain "NoDisplay=true", so this entry always appears.

So my suggestion is to remove hplip.desktop as it is a duplicate and to move the other 3 .desktop files into a separate binary package named "hplip-gui", but with the "NoDisplay=true" lines removed. "hplip-gui" will then depend on python-qt and hplip and it will only be installed by default on the Kubuntu (KDE-based) desktop CD but not on the desktop CDs of Ubuntu (GNOME) and Xubuntu (XFCE). the "hplip" package should recommend/suggest "hplip-gui" so that a package installer tool makes the user aware of the available GUI.

So a user who wants to have the HPLIP GUIs on Ubuntu or Xubuntu has to install only the "hplip-gui" package and everything needed gets installed.

WDYT?

P. S.: Also the /usr/bin/hp-toolbox link can be moved into "hplip-gui".

robepisc (robepisc) on 2006-12-14
Changed in grub-installer:
status: Unconfirmed → Rejected

This is happening with exactly the same error message in Fiesty Herd-2 as of 1/18/07.

Confirmed on Feisty from 27.01.2007 using the daily live CD. It is definitely showing in the GNOME control center and when trying to run it spits out "PyQt/Qt initialization error. Please check install of PyQt/Qt and try again (the python-qt3 package must be installed for this program to work)."

The HPLIP Toolbox icon is DISABLED by default on dapper, edgy and feisty:

$ cat /usr/share/applications/hp-toolbox.desktop | grep NoDisplay
NoDisplay=true

Check if the file ~/.local/share/applications/hp-toolbox.desktop exist, in that case this overrides the desktop file in /usr/share/applications because YOU have activated the hp-toolbox menu item in alacarta.

On a clean installation of dapper, edgy or feisty the file ~/.local/share/applications/hp-toolbox.desktop is not present so HP Toolbox is hidden by default.

Dear Pascal De Vuyst,

would you please be so nice and try to understand what we have written ?

We didn't activate anything or change anything to get something displayed that we then complain about not working. That would be stupid. And we aren't.

All I did is start the feisty herd2 ( I think ) life-cd and the icon was there. And didn't work.

I've just checked the commands you gave us and :

$ cat /usr/share/applications/hp-toolbox.desktop | grep NoDisplay
says:
NoDisplay=true

and $ ls ~/.local/share/applications/hp-toolbox.desktop
says
ls: /home/mheimann/.local/share/applications/hp-toolbox.desktop: No such file or directory

BUT the icon is there.

I've just had a look into alacarte and checked if it was enabled. It was is twice in System - Settings. Once disabled and once enabled. The problem might be the redundancy.

Please show some respect and try it out yourself and come up with some positive feedback or this was my last try to show that the bug is still there.

Thanks,
Michael

The problem is that there is more than one .desktop file to start the hp-toolbox:

----------
till@till-laptop:~/printing/foomatic/lporg-site$ dpkg -S .desktop 2>&1 | grep '/hp'
hplip: /usr/share/applications/hplip.desktop
hplip: /usr/share/applications/hp-fab.desktop
hplip: /usr/share/applications/hp-toolbox.desktop
hplip: /usr/share/applications/hp-sendfax.desktop
app-install-data: /usr/share/app-install/desktop/hplip.desktop
hplip: /usr/share/applications/hplip-kubuntu.desktop
till@till-laptop:~/printing/foomatic/lporg-site$ less /usr/share/app-install/desktop/hplip.desktop
till@till-laptop:~/printing/foomatic/lporg-site$
----------

in total my installation (Ubuntu standard + KDE) contains 4:

----------
till@till-laptop:~/printing/foomatic/lporg-site$ grep -i Exec `dpkg -S .desktop 2>&1 | grep '/hp' | cut -d ' ' -f 2`
/usr/share/applications/hplip.desktop:Exec=/usr/bin/hp-toolbox
/usr/share/applications/hp-fab.desktop:Exec=/bin/sh -c 'STARTED_FROM_MENU=yes /usr/bin/hp-fab'
/usr/share/applications/hp-toolbox.desktop:Exec=/usr/bin/hp-toolbox
/usr/share/applications/hp-sendfax.desktop:Exec=/usr/bin/hp-sendfax
/usr/share/app-install/desktop/hplip.desktop:Exec=/usr/bin/hp-toolbox
/usr/share/applications/hplip-kubuntu.desktop:Exec=/usr/bin/hp-toolbox
till@till-laptop:~/printing/foomatic/lporg-site$
----------

where 2 are already in the hplip package, and assuming that app-install-data makes also part of a Ubuntu live CD there are 3.

Only the following files are deactivated with a "NoDisplay=true" directive:

----------
-till@till-laptop:~/printing/foomatic/lporg-site$ grep -i nodisplay `dpkg -S .desktop 2>&1 | grep '/hp' | cut -d ' ' -f 2`
/usr/share/applications/hp-fab.desktop:NoDisplay=true
/usr/share/applications/hp-toolbox.desktop:NoDisplay=true
/usr/share/applications/hp-sendfax.desktop:NoDisplay=true
till@till-laptop:~/printing/foomatic/lporg-site$
---------

This means for fixing the bug two more .desktop files need to be removed or need the "NoDisplay=true" added:

/usr/share/applications/hplip.desktop (package hplip)
/usr/share/app-install/desktop/hplip.desktop (package app-install-data)

It should also be taken care of

/usr/share/applications/hplip-kubuntu.desktop

in the hplip package. This file is there for Kubuntu (KDE-based) and should not generate an icon in Ubuntu, Xubuntu, or Edubuntu.

As one of the candidates for the unwished icon is in the app-install-data package, I add this package to this bug report.

Note: The source package of app-install-data is gnome-app-install.

Changed in gnome-app-install:
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

Thanks for subscribing me to the bugreport.

app-install-data is only used internaly in the gnome-app-install application on ubuntu. Any changes in a regular deb package desktop file will be semi-automatically merged into the package. Do I just need to sync the desktop file changes? Or is there more required to fix g-a-i?

Thanks,
 Michael

Do you synchronize only with <packagename>.desktop or are you really searching the packages for all .desktop files?

Are the .desktop files in /usr/share/app-install/desktop/ displayed somewhere in the desktop's UI? In a menu, in a tool, ...?

Currently, there are 4 .desktop files in the hplip package:

/usr/share/applications/hplip.desktop
/usr/share/applications/hp-fab.desktop
/usr/share/applications/hp-toolbox.desktop
/usr/share/applications/hp-sendfax.desktop

Three are named by the programs which they start and they have the correct "NoDisplay=true" directive, one is named by the package (hplip) and does not contain the "NoDisplay=true" directive. It also starts hp-toolbox, as hp-toolbox.desktop.

So there are two possibilities to fix the hplip package: Either remove hp-toolbox.desktop and add "NoDisplay=true" to hplip.desktop or remove hplip.desktop. Michael, I am more in favour of removing hplip.desktop as this is more consistent inside the hplip package then. What is better for your app-install-data synchronization, removing hplip.desktop or removing hp-toolbox.desktop?

Michael, once hplip is fixed you should re-synchronize app-install-data.

Michael Vogt (mvo) wrote :

The tool that does the synchronizations gets all desktop files from a package. The files in /usr/share/app-install/desktop/ are only displayed in the "gnome-app-install" application (Applications/Add-Remove).

For gnome-app-install NoDisplay is probably better. OTOH if we install hplib anyway always it does not matter that much.

Cheers,
 michael

Back to my question: Does every package with menu entries need one file with the name <packagename>.desktop to register itself in gnome-app-install? Or can I remove hplip.desktop and keep the other 3 .desktop files?

What I want to have is that each GUI program in the hplip package has exactly one .desktop file.

I would opt for removing hp-toolbox.desktop

The hplip package in Debian contains only hplip.desktop file, this is what caused the duplicate menu entry:
1) On merge of hplip 0.9.11-2ubuntu1 hplip.desktop was renamed to hp-toolbox.desktop, hp-fab.desktop and hp-sendfax.desktop were added by Matthias Klose.
2) On merge of hplip 1.7.1-1ubuntu1 you (Till Kampeter) did copy the missing desktop files from the previous ubuntu package, since hplip.desktop is already in the debian package this leaves us with 4 desktop files: hplip.desktop, hp-toolbox.desktop, hp-fab.desktop and hp-sendfax.desktop.

Since Ubuntu uses co-maintainership we should avoid this problem for future merges from Debian, I suggest we keep the original hplip.desktop file name (add NoDisplay=true for people without HP printers) and remove hp-toolbox.desktop, unless we can convince Debian to rename the file.

If I'm correct the idea behind gnome-app-install is to add/remove an application by menu entry (desktop file).
I don't think that the file name of a desktop file needs to match the package name for gnome-app-install, but Michael should confirm this.
Does gnome-app-install ignore NoDisplay=true so users will be able to remove hplip by finding "HPLIP Toolbox" when they don't want it?

Michael Vogt (mvo) wrote :

@Till: gnome-app-install reads all .desktop files in a package regardless of the name. When there are multiple ones, that is totally valid. I usually do some post-processing and blacklist duplicated desktop files. So if hplip.desktop gets dropped, that will not be a problem for g-a-i

@Pascal: g-a-i will display files even with NoDisplay=true

Cheers,
 Michael

Has Bug #82487 something to do with this?

Yes, there are two .desktop for the hp-toolbox. hplip.desktop and hp-toolbox.desktop.

So let's remove hp-toolbox.desktop an set "NoDispay=true" in hplip.desktop in the next hplip package and everything should work as expected.

VF (vfiend) wrote :

The menu entry is still present and shown by default in latest ubuntu feisty as of today, if it's going to be shown it should at least offer to install its dependency instead of silently failing with a message only available from the command line.

Changed in gnome-app-install:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

I close the gnome-app-install task now. After the latest desktop file update I have only a single hplip toolbox entry in g-a-i

Changed in gnome-app-install:
status: Confirmed → Fix Released

Is this now fixed or not? Please tell me. In Bug https://launchpad.net/ubuntu/+source/hplip/+bug/95762 somebody mentioned that this is still a problem. Thanks.

Please test the packages on

http://www.linux-foundation.org/~till/tmp/ubuntu/feisty/hplip/binary/

They are on their way into Feisty.

Changed in hplip:
status: Confirmed → Fix Committed

Can you do the tests described in bug 98520 (2nd posting)? This way we can decide whether we solve this problem bia HPLIP 1.7.3 or by patching HPLIP 1.7.1.

Changed in hplip:
status: Fix Committed → Fix Released
jask (jaskiern) wrote :

This is still an issue in Gutsy Gibbton Tribe 5.

Changed in hplip:
status: Fix Released → Fix Committed

hplip (2.7.7.dfsg.1-0ubuntu2) gutsy; urgency=low

  * debian/control, debian/hplip.install, debian/hplip-gui.install,
    debian/rules:
    Moved menu entries for the GUI utilities into the new hplip-gui package.
    This package requires python-qt3 and so the menu entries can never appear
    if python-qt3 is not installed. Let the main package (hplip) recommend
    hplip-gui instead of python-qt3 now. Fixes: LP: #67892, LP: #86893,
    LP: #134480, LP: #137168

 -- Till Kamppeter <email address hidden> Wed, 5 Sep 2007 10:05:57 +0100

Changed in hplip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers