Ubuntu

Comment 65 for bug 595650

@Cesare Mastroianni:

Regarding the double-sided printing trouble, have you confirmed you are using the same version of hplip as before the update that gave you the troublesome libusb (check /var/log/apt/history.log for what else was installed in the update that gave you libusb-0.1-4 0.1.12-14ubuntu0.1)? If it's a regression compared to an older hplip, you want to file a bug against it at https://bugs.launchpad.net/ubuntu/+source/hplip/ .

0.1.12-14 was the libusb-0.1-4 released with lucid [the only version available until now], and you observed it broken after downgrading back to that, so it smells like hplip to me.

@world:

I didn't see the ".1" in the original versioning, so my advice to use:
aptitude forbid-version libusb-0.1-4=2:0.1.12-14ubuntu0
will exclude the patched patch too, oops! It should have read:
aptitude forbid-version libusb-0.1-4=2:0.1.12-14ubuntu0.1

If you don't have the lucid-proposed repo enabled, it looks like you can undo this overbroad 'forbid-version' by running:
aptitude install libusb-0.1-4=2:0.1.12-14ubuntu0.2
and saying 'No' to its intention to install libusb-0.1-4=2:0.1.12-14ubuntu0.1 when ...ubuntu0.2 is not available.
Then you can run the correct:
aptitude forbid-version libusb-0.1-4=2:0.1.12-14ubuntu0.1
to only exclude the bad version, and accept ...ubuntu0.2 when it's approved.