HP printers Media Source selection stopped working after upgrade to 9.04

Bug #380858 reported by n3ko on 2009-05-27
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hpijs

Media source selecting seams not effecting the printer. It doesn't mater what source is selected the printer use the default paper tray.
Downgrade to the former (intrepid) version instantly solved the problem.
[code]
wget http://hu.archive.ubuntu.com/ubuntu/pool/main/h/hplip/hpijs_2.8.7-0ubuntu6_i386.deb;
sudo dpkg -i hpijs_2.8.7-0ubuntu6_i386.deb
[/code]

the printer is a HP Photosmart D5360

n3ko (n3ko74) wrote :

fix package hint

n3ko (n3ko74) wrote :

ops. there was nothin to fix. the source package is hplip the binary is hpijs

Till Kamppeter (till-kamppeter) wrote :

n3ko, what is your printer model? Which files did you try to print and with which applications? Can you attach the files?

Can you attach an error_log in debug mode? Please follow the instructions in the "CUPS error_log" section of

https://wiki.ubuntu.com/DebuggingPrintingProblems

Changed in hplip (Ubuntu):
status: New → Incomplete

Architecture: i386
CupsErrorLog:

DistroRelease: Ubuntu 9.04
Lpstat:
 device for HP_LaserJet_3055: hp:/net/HP_LaserJet_3055?ip=192.168.1.83
 device for HP_LaserJet_3055_fax: hpfax:/net/HP_LaserJet_3055?ip=192.168.1.83
 device for Photosmart_D5300_series: hp:/usb/Photosmart_D5300_series?serial=MY8182110G052G
 device for Stylus-DX5000: usb://EPSON/Stylus%20DX5000
MachineType: MICRO-STAR INT'L CO.,LTD. MS-1022
NonfreeKernelModules: nvidia
Package: hplip 3.9.2-3ubuntu4
PackageArchitecture: i386
Papersize: a4
PpdFiles:
 Stylus-DX5000: Epson Stylus DX4800 - CUPS+Gutenprint v5.2.3
 HP_LaserJet_3055: HP LaserJet 3055 Foomatic/hpijs, hpijs 2.8.7
 Photosmart_D5300_series: HP PhotoSmart D5100 Foomatic/hpijs, hpijs 2.8.2
 HP_LaserJet_3055_fax: HP Fax
ProcCmdLine: root=/dev/mapper/Ubuntu-root ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=hu_HU.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :
n3ko (n3ko74) wrote :

the printing command was:
lpr -P Photosmart_D5300_series -o InputSlot=CDDVDTray -o Duplex=None

When job started, the printer asks to close cd tray.

debug mode error_log attached

n3ko (n3ko74) on 2009-06-14
description: updated

The driver is called with the correct MediaPosition parameter. If the printer does not select the correct tray it is an upstream bug of the driver.

n3ko,

Your Photosmart D5300 still seems to use the PPD from Hardy:
Photosmart_D5300_series: HP PhotoSmart D5100 Foomatic/hpijs, hpijs 2.8.2

I would suggest you to remove and reinstall the printer queue.

n3ko (n3ko74) wrote :

The printer remove-reinstall doesnt help.

n3ko (n3ko74) wrote :

replacing the hpijs binary is enough to fix.
so yes it may an upstream driver bug.

the outputs of

gs -dFirstPage=1 -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -dDEVICEWIDTHPOINTS=595 -dDEVICEHEIGHTPOINTS=842 -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="deskjet 5600" -dDuplex=false -r300 -sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=2,PS:MediaPosition=14 -dIjsUseOutputFD -sOutputFile=- Intrepid.ps >p-`strings /usr/bin/hpijs | grep -i '^2.8\|^3.9'`

attached.

The two output files differ only by one byte. The old (working) one has

<ESC>&l14H<ESC>&l7M

near its beginning and the new (not working) one has

<ESC>&l14H<ESC>&l0M

instead.

Note that <ESC>&l14H chooses the input tray and <ESC>&l0M or <ESC>&l7M chooses the media type.

The problem is that the media type does not get selected. <ESC>&l0M means plain paper and <ESC>&l7M printable CDs. The printer probably defaults to the main tray because it gets conflicting settings: <ESC>&l14H to select the CD tray and then <ESC>&l0M to select plain paper, which cannot be fed from the CD tray.

This is an upstream bug in the driver. It needs to be fixed by the HPLIP developers at HP.

Changed in hplip:
status: New → Confirmed
MMarking (cpt-mocha) wrote :

Till,

Glad to see you are involved, hopefully it will be fixed soon. Please see https://answers.launchpad.net/hplip/+question/63943 for a long discussion about this and it is affecting many printers and distros. Thanks.

Aaaron, David, Shiyun, can someone have a look here and find out why this does not work?

Or is the solution the deprecation of the IJS driver and replacement by the CUPS Raster driver (HPLIP 3.9.6)? If so, what is the solution for Jaunty users?

Jason Callough (jcallough) wrote :

All:

I have attempted to reproduce this issue in Fedora 10 and Ubuntu 9.04 using the Photosmart D5360 and will list my findings below.

Fedora 10:
Fedora 10, hplip-3.9.6, native cups drv install through localhost or native cups drv install through hp-toolbox:
Media Size = 4x6
Media Source = Photo Tray
Results: Photo tray was used and the page printed fine on the photo paper.

Fedora 10, hplip-3.9.6, HPIJS ppd install through localhost:
Media Size = 4x6
Media Source = Photo Tray
Results: Photo tray was used and the page printed fine on the photo paper.

Fedora 10, hplip-3.9.6, native cups drv install through localhost or native cups drv install through hp-toolbox:
Media Size = 4x6
Media Source = Upper Tray
Results: Photo tray was not used and the page printed from the default tray.

Fedora 10, hplip-3.9.6, HPIJS ppd install through localhost:
Media Size = 4x6
Media Source = Upper Tray
Results: Photo tray was not used and the page printed from the default tray.

Ubuntu 9.04:
Ubuntu 9.04, hplip-3.9.6, native cups drv install through localhost or native cups drv install through hp-toolbox:
Media Size = 4x6
Media Source = Photo Tray
Results: Photo tray was used and the page printed fine on the photo paper.

Ubuntu 9.04, hplip-3.9.6, HPIJS ppd install through localhost:
Media Size = 4x6
Media Source = Photo Tray
Results: Photo tray was used and the page printed fine on the photo paper.

Ubuntu 9.04, hplip-3.9.6, native cups drv install through localhost or native cups drv install through hp-toolbox:
Media Size = 4x6
Media Source = Upper Tray
Results: Photo tray was not used and the page printed from the default tray.

Ubuntu 9.04, hplip-3.9.6, HPIJS ppd install through localhost:
Media Size = 4x6
Media Source = Upper Tray
Results: Photo tray was not used and the page printed from the default tray.

It appears that with the latest public release, hplip-3.9.6, from our site http://hplipopensource.com/hplip-web/index.html, using the "Photo Tray" not the "Upper Tray", which is used for printing on CD/DVD, and installing through localhost:631 (being sure to select the printer that has "HPLIP" in the name) will yield the proper results.

Jason

MMarking (cpt-mocha) wrote :

Did you try any tests on Ubuntu printing to the CD/DVD tray on a CD/DVD? I don't see any there. It appears all of your tests passed. What does installing the printer though CUPS vs hp-toolbox have to do with it?

I have checked. The problem is still present in HPLIP 3.9.6. The output files still contain the non-working sequence "<ESC>&l14H<ESC>&l0M" (using the HPIJS driver).

I tried it also with the hpcups driver, but I needed to fix the hpcups.drv file so that the CD Tray gets available in the PPD (patch attached). Also here the wrong "<ESC>&l14H<ESC>&l0M" gets inserted.

Changed in hplip (Ubuntu):
status: Incomplete → Triaged
MMarking (cpt-mocha) wrote :

I'm running Ubuntu 9.04 with HPLIP 3.9.2 from the repo, I just replaced the hpijs binary with the 2.8.7 version binary from the Ubuntu 8.10 repo, and it works. I made 3 successful test prints; 1 each to the CD/DVD tray, letter tray, and photo tray.

I'm happy with all 3 trays working again like they did in Intrepid even if this is considered a hack workaround, however I'd like to know what possible side effects might happen by replacing the hpijs binary with a different version from the HPLIP driver? Thanks.

Egbert König (e-kunig) wrote :

The attached patch fixes the problem with CD/DVD printing. As the hplip PPD files do offer the possibility to select the CD/DVD media type and media source settings, I have also added, that media source and media type will be adjusted automatically as soon as the paper size is CD/DVD 80mm or 120mm.

Thank you for the patch.

You probably mean

"As the hplip CUPS PPD files do NOT offer the possibility to select the CD/DVD media type and media source settings, I have also added, ..."

Can you test whether the patch fixes the problem for BOTH the HPLIP CUPS (hpcups) and hpijs drivers? Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.9.6-0ubuntu3

---------------
hplip (3.9.6-0ubuntu3) karmic; urgency=low

  * debian/patches/set-media-type-and-input-tray-for-cd-dvd.dpatch: Let
    the media type CD/DVD and the CD tray automatically get selected if the
    user chooses a CD/DVD size as paper size (LP: #380858).

 -- Till Kamppeter <email address hidden> Mon, 22 Jun 2009 18:32:49 +0200

Changed in hplip (Ubuntu):
status: Triaged → Fix Released
François-Xavier ÉON (xeonvi) wrote :

I installed hplip 3.9.6 and the hpcups driver gives me error with "incorrect paper" whenever i try to print on "tear-off-tab 10x15" photo paper or 120mm CD/DVD. In fact I can't even find tear off tab paper so I tried 4x6 inch with same result => back to 3.9.4 with 2.8.7 hpijs bin ....

Eric Hedekar (stochastic) wrote :

It looks like this bug has regression on the latest Karmic version. Earlier Karmic alphas were working with the CD/DVD tray on my HP Photosmart D5460 but after some recent updates (within the last month or so), no more CD/DVD tray.

Changed in hplip (Ubuntu):
status: Fix Released → Triaged
status: Triaged → In Progress

To the developers at HP: I had to re-introduce Egbert Koenig's patch as in HPLIP 3.9.8 at least the HPIJS driver has the Media Type broken again. The patch applied without problems to 3.9.8. It seems that it did not get applied in 3.9.8.

Changed in hplip (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.9.8-1ubuntu2

---------------
hplip (3.9.8-1ubuntu2) karmic; urgency=low

  * debian/patches/set-media-type.dpatch: Fix media type selection for CD/DVD
    printing with the HPIJS driver, as we still use HPIJS by default. Fixes
    LP: #380858 for the HPIJS driver.

 -- Till Kamppeter <email address hidden> Fri, 9 Oct 2009 18:39:38 +0200

Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
Jodema (john-ubf) wrote :

I am having the same problem printing CD/DVD's on C309a all in one printer on Jaunty (9.04). How can I fix it as this fix is for Karmic?

Do you have a fully updated Karmic? What is the output of

dpkg -l | grep hplip
dpkg -l hpijs

Jodema (john-ubf) wrote :

Sorry I did not make myself clear. I have a fully updated Jaunty but this fix is for Karmic. Can I fix Jaunty with it?

Jodema (john-ubf) wrote :

Thank you for your help.

 I installed the latest HPLIP (3.9.10) from the HP website and now all is working OK.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers