Ubuntu

[jaunty] hplip status service cannot find system tray

Reported by Kamil on 2009-02-27
108
This bug affects 20 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
HP Linux Imaging and Printing
hplip (Debian)
Fix Released
Unknown
hplip (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: hplip

After login to ubuntu hplip status service cannot find system tray. It shows dialog box: "No system tray detected on this system. Unable to start, exiting".

hplip version is 2.8.12-3ubuntu1 on jaunty

I found the same bug reported in Debian
http://<email address hidden>/msg618714.html

Regards

Till Kamppeter (till-kamppeter) wrote :

Fixed in HPLIP 3.9.2.

Changed in hplip (Ubuntu):
status: New → Fix Released
Johannes Rohr (jorohr) wrote :

I see that I have version 3.9.2-3ubuntu3 installed. The bug is still there.

alvinmichael (alvin-michael) wrote :

I have this exact problem. I also have 3.9.2ubuntu3 installed and this bug reveals its self every time I start the GNOME desktop. I have both KDE and GNOME and this does not appear to be an issue using the KDE (Kubuntu) desktop.

Gyorgyi Toth (tgyorgyi27) wrote :

Same here. I have updated from Intrepid to Jaunty RC few days ago, and have the problem since. HPLIP version is 3.9.2

mo (deez) wrote :

Deleting the ".hplip" directory seemed to fix that problem for me:
rm -rf ~/.hplip

Gyorgyi Toth (tgyorgyi27) wrote :

Mo, thank you for the tip, it did not change anything for me. :-(
Seems like sometimes hplip looks for the system tray before it is set up. Sometimes it is a bit slower, and I do not get an error message.

Lukáš Zapletal (lzap) wrote :

Same here. The really big problem is that GNOME does not allow me to login when this error occurs.

After several restarts its always OK. The error appears SOMETIMES. Using upgraded Ubuntu 9.04.

Do you have clean Ubuntu installs or upgrades?

Reopening.

Changed in hplip (Ubuntu):
status: Fix Released → Confirmed
Changed in hplip (Debian):
status: Unknown → New
irv (irv-hbci) wrote :

This error occurs every time I startup. The problem started after upgrading to 9.04 of Ubuntu. I just close the error dialog and everything seem to work OK. I just don't have the icon in the system tray. If I un-install hplip the error goes away. When I reinstall it it comes back so it is in this package.

Gyorgyi Toth (tgyorgyi27) wrote :

The bug did not go away for me either, but I noticed that in the Startup menu, the command line is this:

sh -c "sleep 15; exec hp-systray"

I changed 15 to 45, and ever since no error message at startup. I am just a regular user, so just gave it a try, but maybe somebody knows, whether it is an option that delays startup somewhat, and this way Hplip does not want to climb onto the system tray "too early".

Pacho Ramos (pacho) wrote :

I reported this to upstream but still no response :-(
https://bugs.launchpad.net/hplip/+bug/365531

irv (irv-hbci) wrote :

I tried the:
sh -c "sleep 15; exec hp-systray"

I changed 15 to 45, and it fixed the problem.
Thanks to Gyorgyi Toth.

Pacho Ramos (pacho) wrote :

Still valid with 3.9.8, why hp-systray checks for available systray at all? It also causes to always get this error message when a user doesn't have a systray added to its panel, not behaving like all the others systrays, that simply exit silently

As HPLIP uses Launchpad as bug tracker as well as Ubuntu does you do not need and you should not open a new bug report to forward an HPLIP bug upstream. Please simply add an upstream task, using "Also affects project". I have done so now. Please leave bug 365531 being a duplicate of this bug.

Pacho Ramos (pacho) wrote :

Ah!

I didn't know it, sorry

Thanks for the info

Pacho Ramos (pacho) wrote :

Please try this, it should set a longer delay. In my case, seems to work ok under Gentoo

Good luck

HX_unbanned (linards-liepins) wrote :

Could you, Please, explain to me steps to apply this patch?

HX_unbanned (linards-liepins) wrote :

Also - I am using Ubuntu 9.10 Karmic Koala ..

Pacho Ramos (pacho) wrote :

You can uncompress sources and run on its directory:
patch -p0 <hplip-systray.patch

Maybe it could be also modified in an already installed hplip editing /usr/share/hplip/ui4/systemtray.py by hand, but I haven't tried it :-/

Pacho Ramos (pacho) wrote :

It failed again today :-( (maybe because my login took a long time today)

The problem is at the end of ui4/systemtray.py:
def run(read_pipe):
    log.set_module("hp-systray(qt4)")
    log.debug("PID=%d" % os.getpid())

    app = SystemTrayApp(sys.argv, read_pipe)
    app.setQuitOnLastWindowClosed(False) # If not set, settings dlg closes app

    i = 0
    while i < 60:
        if QSystemTrayIcon.isSystemTrayAvailable():
            break
        time.sleep(1.0)
        i += 1

    if not QSystemTrayIcon.isSystemTrayAvailable():
        FailureUI(None,
            QApplication.translate("SystemTray",
            "<b>No system tray detected on this system.</b><p>Unable to start, exiting.</p>",
            None, QApplication.UnicodeUTF8),
            QApplication.translate("SystemTray", "HPLIP Status Service",
            None, QApplication.UnicodeUTF8))
    else:
        notifier = QSocketNotifier(read_pipe, QSocketNotifier.Read)
        QObject.connect(notifier, SIGNAL("activated(int)"), app.notifierActivated)

        app.exec_()

Looking at:
    i = 0
    while i < 10:
        if QSystemTrayIcon.isSystemTrayAvailable():
            break
        time.sleep(1.0)
        i += 1

I am not sure if would be better to increase time.sleep or "while i <..." ?

What do you think?

Thanks

(well, I would try now time.sleep but I would prefer to wait for suggestions)

Same problem in karmic...

Apparently, it has been resolved in Karmic, I haven't seen this problem for a while...

Gotty (alaniray-hotmail) wrote :

Hmmm, I still have it...

I have seen this intermittently with Ubuntu 9.10 and HPLIP 3.9.8. It seems to be about 50% of the time I boot that I also get the error.

Connor Imes (rocket2dmn) wrote :

I had this problem in Jaunty, and now in Karmic with hplip 3.9.8-1ubuntu2

Changed in hplip (Ubuntu):
importance: Undecided → Medium

I also have this problem with Karmic, a fresh installation from the CD with only HPLIP 3.9.10...

Me too. Proposed patch (workaround) fixes the problem.

is there a patch / workaround working ????

Changed in hplip (Ubuntu):
status: Confirmed → In Progress

Fixed in Lucid, HPLIP 3.9.10-2ubuntu1.

Changed in hplip (Ubuntu):
status: In Progress → Fix Released

Thank you. How can I install the package hplip.3.9.10-2ubuntu1 ? this package isn't on universe.

Fabián Rodríguez (magicfab) wrote :

I hate to state the obvious but someone on my loco team list reported this worked for him:
1) Right click on any panel (top or bottom)
2) CHoose "Add to panel"
3) Double-click "Notification area"

I'll ask him to post his system info to this bug.

Pacho Ramos (pacho) on 2009-12-25
Changed in hplip:
assignee: nobody → HP Linux Imaging and Printing (hplip)
Changed in hplip (Debian):
status: New → Incomplete
Changed in hplip (Debian):
status: Incomplete → Fix Released
Changed in hplip:
status: New → Fix Committed
status: Fix Committed → Confirmed
sami (sa-mi-le) on 2010-08-03
Changed in hplip (Ubuntu):
status: Fix Released → Fix Committed
Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
Fabián Rodríguez (magicfab) wrote :

I came across this problem in Natty (w/latest updates) again today - adding the notification area as noted in my past comment (#31) worked again.

The problem here is that hp-systray needs either to be patched so that it supports Application Indicators (bug 497877) or that the applet gets whitelisted in Unity (bug 744308). Please continue discussion there.

cliff tinker (cliff5555) wrote :

have this problem on maverick

Sean Cleary (seanearlyaug) wrote :
Download full text (8.1 KiB)

I want to keep to the 10.10 level.
I have this problem.
Someone asked for a data dump in one of the various places that lead up to here.

sean@gamer ~ $ hp-check -t

HP Linux Imaging and Printing System (ver. 3.11.3a)

Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP

This software comes with ABSOLUTELY NO WARRANTY.

This is free software, and you are welcome to distribute it

under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:

1. Compile-time check mode (-c or --compile): Use this mode before compiling the

HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies

are installed to successfully compile HPLIP.

2. Run-time check mode (-r or --run): Use this mode to determine if a distro

supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball

has the proper dependencies installed to successfully run.

3. Both compile- and run-time check mode (-b or --both) (Default): This mode

will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------

| SYSTEM INFO |

---------------

Basic system information:

Linux gamer 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:34:50 UTC 2010 i686 GNU/Linux

Distribution:

linuxmint 10

Checking Python version...

OK, version 2.6.6 installed

Checking PyQt 4.x version...

OK, version 4.7.4 installed.

Checking for CUPS...

Status: scheduler is running

Version: 1.4.4

error_log is set to level: warn

Checking for dbus/python-dbus...

dbus daemon is running.

python-dbus version: 0.83.0

------------------------------------

| COMPILE AND RUNTIME DEPENDENCIES |

------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).

note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...

OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...

OK, found.

Checking for dependency: CUPS image - CUPS image development files...

OK, found.

Checking for dependency: DBus - Message bus system...

OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...

OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...

OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...

OK, found.

Checking for dependency: libjpeg - JPEG library...

OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...

OK, found.

Checking for dependency: libpthread - POSIX threads library...

OK, found.

Checking for dependency: libtool - Library building support services...

OK, found.

Checking for dependency: libusb - USB library...

OK, found.

Checking for dependency: make - GNU make utility to maint...

Read more...

Changed in hplip:
status: Confirmed → Fix Committed
Srini RamaKrishnan (cheeni) wrote :

I can confirm this is still an issue in Ubuntu Quantal and Gnome classic. Trying the sleep 45 fix as a workaround.

Srini RamaKrishnan (cheeni) wrote :

Apologies, should have included this information too:

 Kernel: 3.5.0-23-generic #35-Ubuntu SMP Thu Jan 24 13:05:29 UTC 2013 GNU/Linux
 Distribution: ubuntu 12.10
 HPLIP-Version: HPLIP 3.12.11

All the same as Srini

This bug is also a problem in elementary OS Luna Beta 2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.