HP Color-jet CP1700 missing A3 definitions [fix]

Bug #290559 reported by ruehlchr on 2008-10-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Debian)
Fix Released
Unknown
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

With 8.04 we missing the A3 definition in the ppd file for the HP CP1700
this has been fixed locally - Please find and review my attached PPD with A3 support for this printer.

Its tested and work fine.

Regards
Chris

Related branches

ruehlchr (chris-ruehl) wrote :
Till Kamppeter (till-kamppeter) wrote :

ruehlchr, this is fixed in Intrepid, to be released tomorrow.

Changed in hplip:
status: New → Fix Released
Changed in hplip:
status: New → Fix Released
c_ellesley (archelegraph) wrote :

Regression:
my CP1700 doesn't print A3 or legal only A4 using the ppd provided by hplip 3.9.12
- but using the ppd provided by ruehlchr (above) it works just fine!

--> there are 2 definitions for CP1700 in hplip-3.9.12/prnt/drv/hpcups.drv
// <%DJ9xxVIP:Normal%>

ModelName "HP Color Inkjet cp1700"
      Attribute "NickName" "" "HP Color Inkjet cp1700, $Version"
      Attribute "ShortNickName" "" "HP Color Inkjet cp1700"
      Attribute "1284DeviceID" "" "MFG:HP;MDL:hp color inkjet cp1700;DES:hp color inkjet cp1700;"
      PCFileName "hp-color_inkjet_cp1700.ppd"
      Attribute "Product" "" "(HP Color Inkjet cp1700 Printer)"

// <%DJ9xxVIP:LargeFormatSuperB%>
    {
      ModelName "HP Color Inkjet Printer cp1700"
      Attribute "NickName" "" "HP Color Inkjet Printer cp1700, $Version"
      Attribute "ShortNickName" "" "HP Color Inkjet Printer cp1700"
      Attribute "1284DeviceID" "" "MFG:HP;MDL:color inkjet printer cp1700;DES:color inkjet printer cp1700;"
      PCFileName "hp-color_inkjet_printer_cp1700.ppd"
      Attribute "Product" "" "(HP Color Inkjet cp1700 Printer)"
      Attribute "Product" "" "(HP Color Inkjet cp1700ps Printer)"
      Attribute "Product" "" "(HP Color Inkjet cp1700d Printer)"
    }

this means there are 2 ppds for cp1700:
hp-color_inkjet_printer_cp1700.ppd has A3
hp-color_inkjet_cp1700.ppd has not.
but neither prints the A3 area, only A4

Regards
archelegraph

p.s. the ppd for my Officejet 2800 is broken too: only A4 part is printed - see bug https://bugs.launchpad.net/bugs/449581

Changed in hplip (Ubuntu):
status: Fix Released → New
c_ellesley (archelegraph) wrote :

"just fine" should mean that printing large format works at all.
output with the hplip-ppd is of much better quality (e.g diagonal lines are as thin as they should be)
kind regards
archelegraph

Till Kamppeter (till-kamppeter) wrote :

I have informed the HPLIP developers at HP and asked them to fix this in the upcoming HPLIP 3.10.2. Note that Lucid has a release candidate of 3.10.2 where the problem is not yet fixed.The final release will get included in Lucid as soon as it gets available.

Noted with thanks.

X-IT Management Ltd.
Office A, 14/F, Wing Sing Commercial Bldg.
12 Wing Lok Street, Sheung Wan
Hong Kong

3596 7575 PHONE
3585 5118 FAX

Till Kamppeter wrote:
> I have informed the HPLIP developers at HP and asked them to fix this in
> the upcoming HPLIP 3.10.2. Note that Lucid has a release candidate of
> 3.10.2 where the problem is not yet fixed.The final release will get
> included in Lucid as soon as it gets available.
>
>

Mubeen Jukaku (mubeen-jukaku) wrote :

Using PCL viewer I am able to view the A3 testpage. I do not have the printer with me. I used the hpcups ppd. Have you tried printing using hpcups PPD.

-Mubeen

c_ellesley (archelegraph) wrote :

hplip-3.10.2/prnt/drv/hpcups.drv.in still has the double cp1700 definition: one model with A4 only (this one gets installed automatically) and one with A3 as well.

To be able to use a3 I have to manually install the ppd from the second CP1700 entry

trying to print A3 with the
  HP Color Inkjet Printer cp1700, hpcups 3.10.2rc1.9
kills the printer (both LEDs flashing rapidly)

the ruehlchr ppd
  HP Color Inkjet CP1700 Foomatic/hpijs, hpijs 2.8.2
still works fine
     regards archelegraph

Changed in hplip:
status: Fix Released → New
Changed in hplip (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.10.2-2ubuntu1

---------------
hplip (3.10.2-2ubuntu1) lucid; urgency=low

  * debian/control: As we use HPIJS as default printer driver flavor again,
    let the "hplip" package recommend the "hpijs" package and not the
    "hplip-cups" package.
  * debian/patches/remove-duplicate-entry-for-cp1700-in-drv-files.dpatch,
    debian/non-shipped-files.txt: Removed duplicate entry for the HP Color
    Inkjet Printer 1700, the wrong entry missed also the large (A3,
    SuperB, ...) paper sizes (LP: #290559).
 -- Till Kamppeter <email address hidden> Sun, 11 Apr 2010 09:55:18 +0200

Changed in hplip (Ubuntu):
status: In Progress → Fix Released
Changed in hplip (Debian):
status: Unknown → Confirmed
Changed in hplip (Debian):
status: Confirmed → Fix Released
c_ellesley (archelegraph) wrote :

hpijs only:
thank you for fixing - it also prints on the full a3-format!
still there are 2 entries for this printer:
"Color Inkjet Printer CP1700 " - used/comes from foomatic and the correct hplip A3entry
"Color Inkjet cp1700" - hpijs (and wrong A4 hplip entry)
it would be nice to rename the hpijs entry thus having only one "Color Inkjet Printer CP1700"
thank you!

Erik Inge Bolsø (knan-lp) wrote :

ruehlchr ppd still works fine for A3 on kubuntu 12.04. Thanks! Also needed this one time before.

Kubuntu 12.04 ppd for this printer says it does A3, but output is cropped to A4 no matter what you do. Using this PPD instead helps. Thanks, foomatic!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.