Kubuntu: HPLIP unable to find su/sudo utility

Bug #281880 reported by Flavelle on 2008-10-11
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hplip

When accessing the hplip toolbox in kubuntu 8.10, the following error message is produced: unable to find an appropriate su/sudo utility to run hp-setup.

Unable to setup a printer without this utility

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.8.7-0ubuntu6

---------------
hplip (2.8.7-0ubuntu6) intrepid; urgency=low

  * debian/patches/kde4-kdesudo-support.dpatch: KDE 4 does not use "kdesu"
    any more for running applications as root. It uses "kdesudo" now. Added
    support for this change (LP: #281880).

  * debian/control: hplip-gui requires now one of the three packages which
    provide the tools "gksu", "kdesu", and "kdesudo" (LP: #281880). Unneeded
    suggest for these packages in the hplip package removed.

 -- Till Kamppeter <email address hidden> Mon, 13 Oct 2008 11:48:02 +0200

Changed in hplip:
status: New → Fix Released
Danilo (danilo-delorenzo) wrote :

This Bug seems to coming back in Kubuntu Jaunty Beta.
Maybe because Kubuntu Jaunty uses policykit?

I'm using Kubuntu Jaunty Beta, some days ago I sent "sudo apt-get autoremove" and the system uninstalled gksudo. Is that the problem?

Untitled No. 4 (untitled-no4) wrote :

I have the same problem in Kubuntu Jaunty, the final release.
What is really strange is that it did allow me to install the first printer, and only gave the error when I was trying to install the second printer.

Untitled No. 4 (untitled-no4) wrote :

Installing package gksu does not help.

Untitled No. 4 (untitled-no4) wrote :

I've tried it on a second computer and I'm also unable to install a second printer with the same error message.

Víctor R. Ruiz (vrruiz) wrote :

I have the same problem in Ubuntu Jaunty, version: 3.9.2-3ubuntu4. The printer is detected but i cannot download the firmware (hplj1005w)

Jeff Trull (jetrull) wrote :

Still present in Kubuntu Jaunty.

Changed in hplip (Ubuntu):
status: Fix Released → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Do you have hplip-gui installed?

If not, do

sudo apt-get install hplip-gui

Does this pull the needed kdesu/kdesudo tool?

Martin Gamache (martin-gamache) wrote :

Same problem in Ubuntu Jaunty. hplip-gui is already installed...

I solved my problem by uninstalling the kdesudo package, which was installed probably when I added a KDE app to my Ubuntu installation.

Now there is only the sudo package, and evrything is back to normal...

Untitled No. 4 (untitled-no4) wrote :

It's not solved for me. I still get this message when trying to install a second printer. I have tried to reinstall hplip-gui but that didn't help.

Removing kdesudo doesn't seem like a good solution to me (and I haven't tried it) as it will break gdebi-kde and update-manager-kde.

The only way for me to install a second printer is to run sudo hp-setup from konsole.

Untitled No. 4 (untitled-no4) wrote :

I have only now noticed that Martin is using Ubuntu and not Kubuntu.

Sorry, I should have have been more precise, what I did is NOT recommended if you use the KDE desktop.

On the other hand, did you check if there were another sudo package (than kdesudo) installed in Kubuntu ? Maybe that's the problem...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.9.8-0ubuntu7

---------------
hplip (3.9.8-0ubuntu7) karmic; urgency=low

  * debian/hplip-cups.postinst, debian/hpijs.postinst: Let the hpijs package
    migrate queues for the hpcups driver (hplip-cups package) to the HPIJS
    driver when updating PPDs of existing queues. The hplip-cups package
    does not migrate HPIJS queues any more now. We prefer HPIJS for now as
    hpcups has still problems, especially shifted prints on the back side
    of the sheet (LP: #426826), page size confusion with duplex printing
    (LP: #428588) and borderless printing.
  * debian/patches/kde4-kdesudo-support.dpatch: Try also
    /usr/lib/kde4/libexec/kdesu as sudo GUI (LP: #281880).
  * debian/hplip.install, debian/hplip-gui.install: Moved all hp-* utilities
    which do not work in text mode from hplip to hplip-gui (LP: #430539).
  * debian/control: Let hplip recommend hpijs instead of hplip-cups, as this
    is our preferred driver for now. Add to hplip-gui's dependencies
    kdebase-runtime as one of the alternatives to provide a sudo GUI utility
    (LP: #281880). Added versioned depends and conflicts on hplip to hp-gui,
    due to the moving of the GUI-only utilities to hplip-gui.
  * debian/patches/hp-setup-prompt-for-custom-PPD.dpatch: hp-setup did not
    prompt for a custom PPD if the description field of the default PPD is
    empty (LP: #432808).

 -- Till Kamppeter <email address hidden> Thu, 3 Sep 2009 19:22:38 +0200

Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Peter (peter-jiukido) wrote :

i am using kubuntu jaunty and this is what i did to fix it:

cd /usr/local/bin
sudo ln -s kdesudo kdesu

then the hp systray icon worked just fine. maybe adding an alias would be more efficient, but this already worked for me.

Yep that one would work too.. It's a work around, the real problem should be fixed in the code. But all paths except the once not fixing it are good paths ;)..

Cheers Dyna

----- Original Message ----
From: Peter <email address hidden>
To: <email address hidden>
Sent: Wed, October 28, 2009 6:51:39 PM
Subject: [Bug 281880] Re: Kubuntu: HPLIP unable to find su/sudo utility

i am using kubuntu jaunty and this is what i did to fix it:

cd /usr/local/bin
sudo ln -s kdesudo kdesu

then the hp systray icon worked just fine. maybe adding an alias would
be more efficient, but this already worked for me.

--
Kubuntu: HPLIP unable to find su/sudo utility
https://bugs.launchpad.net/bugs/281880
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in “hplip” package in Ubuntu: Fix Released

Bug description:
Binary package hint: hplip

When accessing the hplip toolbox in kubuntu 8.10, the following error message is produced: unable to find an appropriate su/sudo utility to run hp-setup.

Unable to setup a printer without this utility

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers