install.py crashed with ImportError in <module>()

Bug #277005 reported by Katsudon on 2008-10-02
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Undecided
HP Linux Imaging and Printing

Bug Description

Binary package hint: hplip

I cannot say too much when this happened; probably it was when I was trying to install the missing firmware to HP Laserjet 1020.

ProblemType: Crash
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/share/hplip/install.py
InterpreterPath: /usr/bin/python2.5
Package: hplip-data 2.8.7-0ubuntu3
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: python /usr/share/hplip/install.py
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 LANGUAGE=pl
PythonArgs: ['/usr/share/hplip/install.py']
SourcePackage: hplip
Title: install.py crashed with ImportError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/hplip/install.py", line 225, in <module>
     from installer import text_install
 ImportError: cannot import name text_install
Uname: Linux 2.6.27-4-generic i686
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Katsudon (katsudon) wrote :
Savvas Radevic (medigeek) wrote :

Confirming on intrepid 8.10
Happened upon connecting HP LaserJet P1006

Changed in hplip:
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

assigning to hplip (?)

Changed in hplip:
assignee: nobody → hplip
Savvas Radevic (medigeek) wrote :
Download full text (9.0 KiB)

The following contains some errors, it seems that the installed hplip package requires python-qt3 (?) or qt4

$ hp-info

HP Linux Imaging and Printing System (ver. 2.8.7)
Device Information Utility ver. 4.1

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/HP_LaserJet_P1006?serial=AC094VM

HP Linux Imaging and Printing System (ver. 2.8.7)
System Tray Status Service ver. 0.1

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/bin/hp-systray", line 139, in <module>
    from ui import systemtray_qt3
  File "/usr/share/hplip/ui/systemtray_qt3.py", line 33, in <module>
    from ui_utils import load_pixmap
  File "/usr/share/hplip/ui/ui_utils.py", line 32, in <module>
    from qt import *
ImportError: No module named qt
warning: Unable to connect to dbus. Is hp-systray running?

hp:/usb/HP_LaserJet_P1006?serial=AC094VM

Device Parameters (dynamic data):
  Parameter Value(s)
  ---------------------------- ----------------------------------------------------------
  agent1-ack False
  agent1-desc Black toner cartridge
  agent1-dvc 0
  agent1-health 0
  agent1-health-desc Good/OK
  agent1-hp-ink False
  agent1-id 0
  agent1-kind 4
  agent1-known False
  agent1-level 100
  agent1-level-trigger 0
  agent1-sku 35A
  agent1-type 1
  agent1-virgin False
  back-end hp
  cups-printer HP_LaserJet_P1006
  cups-uri hp:/usb/HP_LaserJet_P1006?serial=AC094VM
  dev-file
  device-state 1 ...

Read more...

Savvas Radevic (medigeek) wrote :

Installing python-qt3 does not crash the application and shows the hp-systray icon successfully

You don't need to run install.py after HPLIP is installed. The 2.8.7 version of HPLIP is the Ubuntu pre-installed version of HPLIP.

Till-is there some reason install.py is being installed with HPLIP? It can probably be removed. HPLIP does not install the install.py during the install process.

python-qt3 is not preinstalled with Ubuntu this is a known Ubuntu errata.

Aaron

Sorry, I can reproduce this. But you don't need to run install.py anyway and it should be removed from the ubuntu image.

A

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.8.7-0ubuntu4

---------------
hplip (2.8.7-0ubuntu4) intrepid; urgency=low

  * debian/patches/text-only-without-systray-applet-traceback.dpatch: Let
    hp-systray fail silently, without traceback if we are on a standard desktop
    installation without python-qt3 and hplip-gui (LP: #277005).
  * debian/patches/systray-applet-with-qt4.dpatch: Start hp-systray (system
    tray applet) with the "--qt4" option. Without the option it does not
    integrate in the tray but floats around on the desktop.

 -- Till Kamppeter <email address hidden> Wed, 8 Oct 2008 23:37:02 +0200

Changed in hplip:
status: Confirmed → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Aaron, install.py is really installed by the "make install" process, I did not install it explicitly. I am explicitly removing it in 2.8.7-0ubuntu5.

install.py was never linked to /usr/bin, so usually a user should not come to the idea to start install.py.

I have also suppressed now all warnings and error messages which appear if a command line tool tries to start hp-systray but hp-systray does not start up due to lack of python-qt3 or python-qt4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers