hpps (and other HPLIP components) should not crash in error situations

Bug #1446987 reported by Walter Garcia-Fontes
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
HPLIP
High
Sanjay Kumar
hplip (Ubuntu)
Medium
Unassigned

Bug Description

The filter hpps crashes (Python Traceback) on a broken pipe on stdout when the subsequent filter (the hp backend) errors out due to a network problem (see comment #8). As Linux distributions have automatic crash handling/reporting systems this causes annoying pop-ups which irritate the users giving the impression of a more severe problem.

To the HPLIP developers at HP: Please check all components for possible crashes in error situations.

Original report:

I have a HP Laserjet pro 200 color MFP M276n which was configured and working normally. I have it configured both directly with an USB connection, and through the network with a fixed IP.

Since a recent cups update (I believe), network printing does not work any more but the USB connection still works. When I try to print through the network I get a message telling me that the job has been send, and then I get a crash report. I don't know why apport is not intercepting the crash report, so I attach it manually here. In the "properties" window of the printer I see "Idle - Filter failed" and in the printer queue the job is "held".

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: hplip 3.15.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CupsErrorLog:
 E [22/Apr/2015:07:45:09 +0200] [Job 2625] Unable to queue job for destination "HP-LaserJet-200-color-MFP-M276".
 W [22/Apr/2015:08:45:34 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'hplaserjetpro200mfp276n-Gray..' already exists
 W [22/Apr/2015:08:45:34 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'hplaserjetpro200mfp276n-RGB..' already exists
CurrentDesktop: Unity
Date: Wed Apr 22 09:02:50 2015
InstallationDate: Installed on 2010-10-25 (1639 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
Lpstat:
 device for HP-LaserJet-200-color-MFP-M276: hp:/net/printwalter?ip=10.60.16.199
 device for HP-LaserJet-4250: hp:/net/hp_LaserJet_4250?ip=10.60.40.111
 device for HP-LaserJet-p4515: hp:/net/HP_LaserJet_P4515?ip=10.60.40.110
 device for PDF: cups-pdf:/
 device for USB-laserjet: usb://HP/LaserJet%20200%20colorMFP%20M276n?serial=CND8F7J5J1&interface=1
MachineType: Dell Inc. Precision WorkStation T3400
Papersize: letter
PpdFiles:
 HP-LaserJet-4250: HP LaserJet 4250 Postscript (recommended)
 PDF: Generic CUPS-PDF Printer
 HP-LaserJet-p4515: HP LaserJet p4515, hpcups 3.15.2
 HP-LaserJet-200-color-MFP-M276: HP LaserJet 200 color MFP M276 Postscript (recommended)
 USB-laserjet: HP LaserJet 200 color MFP M276 Postscript (recommended)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-15-generic root=UUID=dadc68cb-c217-4aef-a751-ba0b61137c4a ro quiet splash
SourcePackage: hplip
UpgradeStatus: Upgraded to vivid on 2015-03-09 (43 days ago)
dmi.bios.date: 06/04/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0TP412
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd06/04/2009:svnDellInc.:pnPrecisionWorkStationT3400:pvr:rvnDellInc.:rn0TP412:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation T3400
dmi.sys.vendor: Dell Inc.

Revision history for this message
Walter Garcia-Fontes (walter-garcia) wrote :
Revision history for this message
Walter Garcia-Fontes (walter-garcia) wrote :

Crash report

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Please attach an error_log of a failing job, according to the section "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems.

Changed in hplip (Ubuntu):
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
Revision history for this message
Walter Garcia-Fontes (walter-garcia) wrote :

Here is my error_log file, at 15:02:00 and later I tried print jobs that failed, they are "held" in the printer queue and the printer properties says "filter failed".

Changed in hplip:
status: Incomplete → New
Changed in hplip (Ubuntu):
status: Incomplete → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hplip (Ubuntu):
status: New → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

The reason for the failure is:

D [22/Apr/2015:15:04:04 +0200] [Job 2639] prnt/backend/hp.c 824: ERROR: open device failed stat=12: hp:/net/printwalter?ip=10.60.16.199
D [22/Apr/2015:15:04:04 +0200] [Job 2639] PID 30723 (/usr/lib/cups/backend/hp) stopped with status 1.

Somehow HPs print backand is not able to communicate with the printer.

Please follow the instructions of the section "Network printer" on https://wiki.ubuntu.com/DebuggingPrintingProblems.

Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

To the HPLIP developers at HP: Please make sure that nothing crashes or gives a Traceback if a network error (or some problem in another program), as we have a crash reporting system and so we get crash reports when the problem is somewhere else in reality and users get unneeded crash pop-ups.

See:

D [22/Apr/2015:15:04:04 +0200] [Job 2639] Traceback (most recent call last):
D [22/Apr/2015:15:04:04 +0200] [Job 2639] File "/usr/lib/cups/filter/hpps", line 332, in <module>
D [22/Apr/2015:15:04:04 +0200] [Job 2639] os.write(output_fd, data)
D [22/Apr/2015:15:04:04 +0200] [Job 2639] BrokenPipeError: [Errno 32] Broken pipe
D [22/Apr/2015:15:04:04 +0200] [Job 2639] PID 30722 (/usr/lib/cups/filter/hpps) stopped with status 1.

Revision history for this message
Walter Garcia-Fontes (walter-garcia) wrote :

After further investigation, this issue turned out to be just a disconnected network cable. But of course the crash disconcerted the hell out of me.

Changed in hplip:
status: New → Invalid
status: Invalid → New
Changed in hplip:
status: New → Confirmed
summary: - Hplip crashing when trying to print to network HP printer
+ hpps (and other HPLIP components) should not crash in error situations
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

To the HPLIP developers at HP: See my changed bug description.

description: updated
Changed in hplip:
importance: Undecided → High
assignee: nobody → Suma Byrappa (suma-byrappa)
assignee: Suma Byrappa (suma-byrappa) → nobody
assignee: nobody → Sanjay Kumar (sanjay-kumar14)
Changed in hplip (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers