[SRU] FloatingIpManager in neutron.py missing is_supported method

Bug #1476417 reported by Dina on 2015-07-20
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
horizon (Ubuntu)
Undecided
Billy Olsen
Trusty
Critical
Billy Olsen

Bug Description

The latest update to neutron (Version: 1:2014.1.5-0ubuntu1) caused the
following error every time an instance is launched:

"Unable to connect to Neutron."
The logs didn't show any more errors.

I traced down that string to the "servers_update_addresses" method in
openstack-dashboard/api/neutron.py. I had to add a printout for the exception
string to show where the exception happened:
The modified error message now shows:
Unable to connect to Neutron.'FloatingIpManager' object has no attribute
'is_supported'

It turned out that the latest neutron ubuntu package doesn't have the correct file update. A check is done on the fips.is_supported(), however the method itself is not implemented.

The neutron.py on openstack's icehouse repository has the method implemented
http://git.openstack.org/cgit/openstack/horizon/tree/openstack_dashboard/api/neutron.py

But the source code of the latest ubuntu package doesn't have the method
http://archive.ubuntu.com/ubuntu/pool/main/h/horizon/horizon_2014.1.5.orig.tar.gz

--------------------------------------------------------------------------
[Impact]

 * Unable to display floating IP information when using the horizon UI.

[Test Case]

 1. Install a horizon and OpenStack.
   - bzr branch lp:openstack-charm-testing
   - cd openstack-charm-testing
   - juju-deployer -c default.yaml -v -d trusy-icehouse
 2. Launch an instance
 3. Observe the "Unable to connect to Neutron." message in the error notification bubble.

[Regression Potential]

 * None.
 * Should a regression occur, it would result in the "Unable to connect to
   Neutron." message being shown to the user. Unfortunately, specific the
   specific causes is not easy to discern (since the data is not readily
   stored in the logs, thus the user would think this wasn't fixed.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu):
status: New → Confirmed
TimS (tim-sandquist+ubuntu) wrote :

This affects us as well. I did some investigation to see what was going on.
The new FloatingIpManager code was added in this commit:
https://github.com/openstack/horizon/commit/86a66283ccfe146a9743bb7db9433e1f2166b509.
It was added for bug https://bugs.launchpad.net/horizon/+bug/1349841

Apparently the supporting code that has the missing is_supported() method appears to be from this commit: https://github.com/openstack/horizon/commit/936fc59aa8c9b1a45aaefc9779741c84ed3fea90. It is from bug https://bugs.launchpad.net/horizon/+bug/1292022.

I think https://github.com/openstack/horizon/commit/936fc59aa8c9b1a45aaefc9779741c84ed3fea90 needs to be pulled into the icehouse branch.

Billy Olsen (billy-olsen) wrote :

Thanks TimS for the analysis. It looks like this backport included a portion of a blueprint which was not fully backported (namely not showing the Floating IPs when they are not available). Rather than backporting the full blueprint, dropping the checks for the is_supported and simply assuming it is supported (which is what the previous code did) should be an appropriate fix for the icehouse release.

Changed in horizon (Ubuntu):
assignee: nobody → Billy Olsen (billy-olsen)
description: updated
summary: - FloatingIpManager in neutron.py missing is_supported method
+ [SRU] FloatingIpManager in neutron.py missing is_supported method
Changed in horizon (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Billy Olsen (billy-olsen)
tags: added: landscape
James Page (james-page) on 2015-07-29
Changed in horizon (Ubuntu):
status: Confirmed → Invalid
Changed in horizon (Ubuntu Trusty):
importance: Undecided → Critical
status: In Progress → Triaged
James Page (james-page) wrote :

I've tested and uploaded this fix to trusty proposed for the SRU team to review - as soon as I have IRC access I'll go chase as well.

tags: added: regression-update

Hello Dina, or anyone else affected,

Accepted horizon into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/1:2014.1.5-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
James Page (james-page) wrote :

I've pushed this update into our HA icehouse cloud (serverstack); I was able to confirm the bug pre-update, and confirm resolution post update.

I've also exercised Horizon both as a end-user and as a admin user and it tests out OK.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2014.1.5-0ubuntu2

---------------
horizon (1:2014.1.5-0ubuntu2) trusty; urgency=medium

  * Fix "Unable to Connect to Neutron" error message which is displayed
    in various UI panels. (LP: #1476417)
    - d/p/fix-neutron-connection-error.patch - Removes the erroneous
      usage of the FloatingIPManager.is_supported() method.

 -- Billy Olsen <email address hidden> Mon, 27 Jul 2015 10:37:15 -0700

Changed in horizon (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Dina (dina-salem) wrote :

Verified. Thanks for the update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers