Ubuntu

Kubuntu: HAL doesn't automount USB devices on KDE 3.5.5

Reported by Urtzi Jauregi on 2006-12-03
8
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

Since the last HAL update I can't automount any USB devices; althought the devices are detected by the kernel, no icon shows up on the desktop. I have to mount/unmount manually.

 I had no problems at all with the pre-update HAL. Also, the problem only appears in Kubuntu; Ubuntu Dapper on the same computer detects and automounts everything normally.

The output of dmesg after inserting e.g. my Packard MP3 player is:

----------------------------------------- Begin of dmesg tail output ------------------------------------

[17346874.108000] usb 4-1: new full speed USB device using uhci_hcd and address 5
[17346877.416000] scsi3 : SCSI emulation for USB Mass Storage devices
[17346877.416000] usb-storage: device found at 5
[17346877.416000] usb-storage: waiting for device to settle before scanning
[17346882.420000] Vendor: Packard Model: Portable Player Rev: 0100
[17346882.420000] Type: Direct-Access ANSI SCSI revision: 04
[17346882.424000] SCSI device sda: 2039040 512-byte hdwr sectors (1044 MB)
[17346882.428000] sda: Write Protect is off
[17346882.428000] sda: Mode Sense: 03 00 00 00
[17346882.428000] sda: assuming drive cache: write through
[17346882.440000] SCSI device sda: 2039040 512-byte hdwr sectors (1044 MB)
[17346882.440000] sda: Write Protect is off
[17346882.440000] sda: Mode Sense: 03 00 00 00
[17346882.440000] sda: assuming drive cache: write through
[17346882.440000] sda: sda1
[17346882.448000] sd 3:0:0:0: Attached scsi removable disk sda
[17346882.448000] sd 3:0:0:0: Attached scsi generic sg0 type 0
[17346882.452000] usb-storage: device scan complete

----------------------------------------- end of dmesg tail output ------------------------------------

Similarly, lsusb reports:

---------------------------------- beginning of lsusb output -------------------------------------
Bus 005 Device 001: ID 0000:0000
Bus 001 Device 005: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 005: ID 066f:8252 SigmaTel, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:011d Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
----------------------------------------- end of lsusb output ------------------------------------

Where "Hewlett-Packard" is the mp3 player.

On the kubuntu-users mailing list, I was referred to the following as a possible cause of the problem:
http://tsdgeos.blogspot.com/2006/10/solution-for-kubuntu-355-and-usb-not.html

They suggested that J. Riddell's packages (with a "1" in the end, rather than a "2") solved the problem.

I am using an up-to-date Kubuntu Dapper with the stock kernel 2.6.15-27-686 and KDE 3.5.5 on a HP-Compaq nc6120.

SilentPh03nix (silentph03nix) wrote :

I also have this issue. I will just mirror the above comments and add that this is happening on two of my machines. One a whitebox AMD with a USB2.0 external hard drive and the other an Dell Inspiron 9100 laptop with an iomega USB2.0 hard drive, a Fuji F700 Camera, and a Sandisk Cruzer flash drive. All work fine in GNOME, but KDE sees the device and asks to mount it, but nothing appears after asking for mount. I can use pmount to mount the device from the command line manually. I haven't yet attempted to load the above mentioned fix to see if that fixes the issue on either of my machines. My machines were both loaded with Ubuntu 6.06.1 Dapper with stock kernel, and then added kubuntu-desktop. I then have upgraded both to KDE 3.5.5. Both are kept up to date with update manager.

Urtzi Jauregi (urtzi) wrote :

Solved the problem by installing the HAL version in
 http://kubuntu.org/packages/kde-355/pool-dapper/hal

The relevant package is hal_0.5.7-1ubuntu18.1_i386.deb

mindspin (markus-wimmer) wrote :

I had the same issue and mounted manually until installing the package mentioned above. Now Adept complains about the available update of hal. A bit annoying. I'm sure I will accept the update soon out of routine.

SilentPh03nix (silentph03nix) wrote :

I installed the above package, then dropped to CLI and did aptitude forbid-version hal. That stopped aptitude from complaining about it. Then I opened synaptic and locked the version of hal to the one I installed. I haven't booted back into KDE yet to see if adept complains after I've locked it in those two places. If so, I'm sure there is a way to tell it to lock the version also.

steph_Z (polariscorp) wrote :

Dapper - KDE 3.5.5

Same here hope it will be fix soon

thanks

Konrad Materka (kmaterka) wrote :

Yes, Hal trom Kubuntu's latest KDE repository makes it work again, but hal in "update" have higher number so I always have to cancel update. I don't want to lock, making prioritizing as many people here. Can someone tell me why this upgrade is needed and why it doen't constain scripts form http://kubuntu.org/packages/kde-355/pool-dapper/hal hal?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers