USB drive not detected if booted with drive connected

Bug #49890 reported by GreatBunzinni on 2006-06-15
22
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Medium
Martin Pitt
Nominated for Hardy by Jackflap

Bug Description

I've just noticed that if I boot Kubuntu with the USB drive connected in the USB port, Kubuntu doesn't detect it and the drive isn't mounted. If I unplug and plug the drive again, Kubuntu detects it.

I'm running kubuntu 6.06 with KDE 3.5.3

towsonu2003 (towsonu2003) wrote :

thanks for your bug report...

I'm just guessing the package name (I just can't learn whether it's hal or not ;) )

Brian Murray (brian-murray) wrote :

Thanks for your bug report. With the drive attached could you run 'lsusb' and add the output? Could you also add the output of 'dmesg' after booting the system with the USB drive connected?

Changed in hal:
assignee: nobody → brian-murray
status: Unconfirmed → Needs Info
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in hal:
assignee: brian-murray → nobody
status: Needs Info → Rejected
Parameshwara Bhat (peebhat) wrote :

The above bug exists even on Kubuntu/Ubuntu 7.10

There is an additional point. The USB mouse behaves jerky and slow after this.

There is a behaviour this may be connected to or not.If a USB CD-RW is connected,that is recognised as shown by dmesg and kinfocenter.But as soons as K3B is launched,the drive gets dropped.

This very same behaviour exists in PCLinuxOS.But openSUSE 10.2/10.3 running on the same notebook(Acer TM2400) are not affected either in Gnome or KDE.The drive not getting detected happens with Ubuntu(Gnome) as well.But mouse and K3b behaviour I am not sure on Gnome.

I will attach lsusb and dmesg output next time I boot.

Parameshwara Bhat

GreatBunzinni (greatbunzinni) wrote :
Download full text (27.5 KiB)

I've just installed Kubuntu 7.10 and yes, this bug still persists. I've just booted into Kubuntu with two USB mass storage devices connected (a external HD and a small USB flash drive) and neither is detected.

lsusb output:
rui@ubuntu:~$ lsusb
Bus 002 Device 003: ID 4146:ba01 USBest Technology Intuix Flash Drive
Bus 002 Device 002: ID 067b:2507 Prolific Technology, Inc.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

dmesg output:
rui@ubuntu:~$ dmesg
[ 0.000000] Linux version 2.6.22-14-generic (buildd@crested) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 21:45:15 GMT 2007 (Ubuntu 2.6.22-14.46-generic)
[ 0.000000] Command line: root=UUID=a33e88ec-7cf1-4fa7-91a5-72127ad15d7b ro quiet splash
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[ 0.000000] BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000007bef0000 (usable)
[ 0.000000] BIOS-e820: 000000007bef0000 - 000000007bef3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000007bef3000 - 000000007bf00000 (ACPI data)
[ 0.000000] BIOS-e820: 000000007c000000 - 0000000080000000 (reserved)
[ 0.000000] BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[ 0.000000] Entering add_active_range(0, 0, 159) 0 entries of 3200 used
[ 0.000000] Entering add_active_range(0, 256, 507632) 1 entries of 3200 used
[ 0.000000] end_pfn_map = 1048576
[ 0.000000] DMI 2.4 present.
[ 0.000000] ACPI: RSDP signature @ 0xFFFF8100000F72A0 checksum 0
[ 0.000000] ACPI: RSDP 000F72A0, 0024 (r2 Nvidia)
[ 0.000000] ACPI: XSDT 7BEF30C0, 004C (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: FACP 7BEFB0C0, 00F4 (r3 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: DSDT 7BEF3240, 7E07 (r1 NVIDIA ASUSACPI 1000 MSFT 100000E)
[ 0.000000] ACPI: FACS 7BEF0000, 0040
[ 0.000000] ACPI: SSDT 7BEFB2C0, 0206 (r1 PTLTD POWERNOW 1 LTP 1)
[ 0.000000] ACPI: HPET 7BEFB540, 0038 (r1 Nvidia ASUSACPI 42302E31 AWRD 98)
[ 0.000000] ACPI: MCFG 7BEFB5C0, 003C (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: APIC 7BEFB200, 007C (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] Scanning NUMA topology in Northbridge 24
[ 0.000000] No NUMA configuration found
[ 0.000000] Faking a node at 0000000000000000-000000007bef0000
[ 0.000000] Entering add_active_range(0, 0, 159) 0 entries of 3200 used
[ 0.000000] Entering add_active_range(0, 256, 507632) 1 entries of 3200 used
[ 0.000000] Bootmem setup node 0 0000000000000000-000000007bef0000
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] DMA32 4096 -> 1048576
[ 0.000000] Normal 1048576 -> 1048576
[ 0.000000] early_node_map[2] active PFN ranges
[ 0.000000] 0: 0 -> 159
[ 0.000000] 0: 256 -> 507632
[ 0.000000] On node 0 totalpages: 507535
[...

Parameshwara Bhat (peebhat) wrote :
Download full text (56.0 KiB)

I am pasting below the output of dmesg and lsusb.I booted with problem devices and next time booted and plugged them in.I can see the light on thumb drive going off right as kernel is loading when booted with.

One interesting sidenote : when by mistake I had a USB scanner plugged in with the thumb drive,this problem did not manifest.But with the drives, it repeats whether they are single or together.

   >dmesg when drive not detected
[ 0.000000] Linux version 2.6.22-14-generic (buildd@palmer) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 23:05:12 GMT 2007 (Ubuntu 2.6.22-14.46-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000000f7df000 (usable)
[ 0.000000] BIOS-e820: 000000000f7e0000 - 000000000f7fffc0 (ACPI data)
[ 0.000000] BIOS-e820: 000000000f7fffc0 - 000000000f800000 (ACPI NVS)
[ 0.000000] BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
[ 0.000000] 0MB HIGHMEM available.
[ 0.000000] 247MB LOWMEM available.
[ 0.000000] Entering add_active_range(0, 0, 63455) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 63455
[ 0.000000] HighMem 63455 -> 63455
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 63455
[ 0.000000] On node 0 totalpages: 63455
[ 0.000000] DMA zone: 32 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 4064 pages, LIFO batch:0
[ 0.000000] Normal zone: 463 pages used for memmap
[ 0.000000] Normal zone: 58896 pages, LIFO batch:15
[ 0.000000] HighMem zone: 0 pages used for memmap
[ 0.000000] DMI 2.3 present.
[ 0.000000] ACPI: RSDP signature @ 0xC00E5010 checksum 0
[ 0.000000] ACPI: RSDP 000E5010, 0014 (r0 INSYDE)
[ 0.000000] ACPI: RSDT 0F7F8BE4, 0034 (r1 INSYDE RSDT_000 100 ABCD 10200)
[ 0.000000] ACPI: FACP 0F7FFAC0, 0074 (r1 INSYDE FACP_000 100 0000 10200)
[ 0.000000] ACPI: DSDT 0F7F8E00, 6CBE (r1 Acer EFL50 1 INTL 2002036)
[ 0.000000] ACPI: FACS 0F7FFFC0, 0040
[ 0.000000] ACPI: APIC 0F7FFB50, 0066 (r1 STUPID MAPIC_00 30307830 ABCD 10200)
[ 0.000000] ACPI: MCFG 0F7FFBC0, 003C (r1 INSYDE MCFG_000 30303030 0000 30303030)
[ 0.000000] ACPI: SSDT 0F7F8C18, 01D8 (r1 PmRef Cpu0Cst 3001 INTL 20030522)
[ 0.000000] ACPI: PM-Timer IO Port: 0x1008
[ 0.000000] ACPI: Local APIC address 0xfee00000
[ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[ 0.000000] Processor #0 6:13 APIC version 20
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[ 0.000000] ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
[ 0.000000] IOAPIC[0]: apic_id 1, version 32, address 0xfec00000, GSI 0-23
[ 0.000000] ACPI: IOAPIC (id[0x02] address[0xfec10000] gsi_base[24])
[ 0.000000] IOAPIC[1]: ...

Changed in hal:
status: Invalid → Incomplete
GreatBunzinni (greatbunzinni) wrote :

Incomplete? what's missing?

The bug cannot atleast be
invalid when I have provided so much information and the bug continues to exist.

I think incomplete status is what the developers look for when they decide
to look into the issue.

On 11/11/07, GreatBunzinni <email address hidden> wrote:
>
> Incomplete? what's missing?
>
> --
> USB drive not detected if booted with drive connected
> https://bugs.launchpad.net/bugs/49890
> You received this bug notification because you are a direct subscriber
> of the bug.
>

mannheim (kronheim) wrote :

I have what I think may be the same problem, though in my case it is not 100% reproducible.

Steps to reproduce my situation:

1. Format an external USB drive, with a partition (ext3 in my case) and a volume label "foo" for that partition.

2. Turn off the computer, connect the USB drive, power it on, and boot the PC (into Ubuntu 7.10 in my case).

3. See whether hal has picked up the existence of the external usb disk by doing:

                      hal-find-by-property --key volume.label --string "foo"

Actual results: Sometimes (not always) a blank.
Expected results: something like

              /org/freedesktop/Hal/devices/volume_uuid_5e69384_........

Other remarks: In all other respects, hal is working normally. Also, the label "foo" does appear correctly in /dev/disk/by-label/ and the disk is mountable, using the mount command. Finally, if hal is restarted later, using "sudo invoke-rc.d hal restart", then the USB disk is correctly detected by hal.

I wonder if this happens due to a timing issue: in gutsy, hal is started earlier in the boot process than it was in feisty. Perhaps the USB disk is not detected because something is not ready when the hal daemon starts.

Changed in hal:
importance: Undecided → Medium
status: Incomplete → Confirmed
Jackflap (deriziotis) on 2008-01-29
Changed in hal:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

Can you please generate a hal debug output as described on the second half of https://wiki.ubuntu.com/DebuggingRemovableDevices ? Please boot with the drive already attached and skip steps 5 and 6 (i. e. just let the output settle and then stop hal with Control-C). Thank you!

Changed in hal:
status: Confirmed → Incomplete
Parameshwara Bhat (peebhat) wrote :

Please find attached hal.log as you wanted.

Also is attached similar hal log with opensuse.In opensuse,I do not experience this bug.In case this might be of help.

Jackflap (deriziotis) wrote :

I've actually managed to solve this one by doing something completely different.

I've got a black WD Passport drive formatted as ntfs which uses a small 10cm USB cable. Whenever I'd boot up with the drive plugged in with this cable, it would be detected on boot only half the time. If I used a longer cable, it wouldn't ever be automounted on boot, but would show up in /dev, and I would have to manually mount.

I then bought a Lindy dual-power USB cable (http://www.lindy.co.uk/usb-cable-dual-power-2-x-type-a-to-mini-b-usb-2-1m/31780.html) and that's fixed the problem completely. It ALWAYS automounts when I boot-up. Since the WD Passport drives use the USB connection to power the drive, and it is known that if your USB ports don't provide enough power, the drive won't work properly. In my case, if I plugged the drive into my other add-on PCI USB card, the drive wouldn't even spin-up.

This is on Gutsy with the vanilla install kernel. The question would be, could this phenomena be related to this bug? How many of the other reporter's drives are powered through the usb cable? Could Linux be finicky regarding automounting when the drive isn't fully powered, i.e. spinning at full-speed?

Martin Pitt (pitti) wrote :

The automount magic is not directly tied to power consumption, etc., but it is possible that the effect happens because at the time you connect the drive, the connection is too brittle for a robust file system detection and mount. Maybe it settles down a bit later when all the capacitors get fully loaded and power consumption reduces a little?

In either case, whenever an automount doesn't work, you should usually see some messages in the "dmesg" output (also reflected in /var/log/kern.log), most often USB port resets.

Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in hal:
status: Incomplete → Invalid
Parameshwara Bhat (peebhat) wrote :

Martin,

If you lookup the history of the bug,you see others and I have given so much of inormation.It is you,who as assignee never investigated and called for more input.Now you are closing it for lack of information from reporters!Great indeed and great future for Ubuntu distribution!

Martin Pitt (pitti) wrote :

Comment 13 indicated that it was indeed a hardware problem, and I never got any dmesg output (see comment 14) from Jackflap, which would give some more information about the problem.

Parameshwara, your dmesg output in comment 6 also points to a hardware problem:

  [ 36.652000] usb 5-3: device not accepting address 4, error -110

thus I didn't see anything here which we could fix in hal.

Martin, Thank you.My bluntness comes from numerous bugs which I reported to
Ubuntu,but there was no effort seen to resolve any.

Hopefully,this bug is resolved now.I left Ubuntu because of the bug not
resolved even after a version upgrade.

No,this bug had nothing to do with the hardware.The same pendrive on the
same laptop worked well with opensuse version of that time.

I also reported it occurred only with u(k)buntu and pclinuxos distros.

On Wed, Jan 28, 2009 at 12:37 PM, Martin Pitt <email address hidden>wrote:

> Comment 13 indicated that it was indeed a hardware problem, and I never
> got any dmesg output (see comment 14) from Jackflap, which would give
> some more information about the problem.
>
> Parameshwara, your dmesg output in comment 6 also points to a hardware
> problem:
>
> [ 36.652000] usb 5-3: device not accepting address 4, error -110
>
> thus I didn't see anything here which we could fix in hal.
>
> --
> USB drive not detected if booted with drive connected
> https://bugs.launchpad.net/bugs/49890
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers