[hardy] IBM Thinkpad (T23): no OSD indication for volume control, display inhibit or thinklight

Bug #198197 reported by Christian Becker
62
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Mark Stosberg

Bug Description

In Gutsy there is some OSD indication if you change the volume or the inhibit of the display
In Hardy there is no.

Revision history for this message
Mike (mrawdon) wrote :

I can confirm that I am experiencing the same issue on my T23.

Revision history for this message
Christian Becker (c-becker-88) wrote :

Maybe this is a feature and no bug, if you must enable this anywhere, but for me it looks like a bug.

I reinstalled newest "Hotkey-setup" but this didn't help.

Any Idears?

regards
chris

Revision history for this message
Mike (mrawdon) wrote :

No, but I also noticed that my Thinkpad button doesn't work anymore either. Also I do get an OSD for screen brightness when I switch to battery, but nothing from the function keys.

I know I used the tpb package when I was running Debian, I'm not sure if I ever did under Ubuntu though, probably not as it seems to break Hotkey-setup.

Revision history for this message
Mark Stosberg (markstos) wrote :

I have confirmed this bug on a ThinkPad T23. The bug is being reported on the ThinkWiki as a problem upgrading from Gutsy to Hardy.

Changed in hotkey-setup:
status: New → Confirmed
Revision history for this message
Mark Stosberg (markstos) wrote : Re: [hardy] IBM Thinkpad (T23): no OSD ...workaround is older kernel

I discovered that this bug went away when booting the Gutsy 2.6.22 kernel instead of the Hardy 2.6.24 kernel.

Does that mean this bug should transferred to the ACPI team instead of the hotkey developers?

   Mark

Revision history for this message
Mike (mrawdon) wrote :

Thanks Mark that works for the volume display and the ThinkPad button, but there is no display for brightness or thinklight. I guess there isn't one for display inhibit either, but I can't say I ever used that before so I'm not sure what it even displayed.

I am using kernel: 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Revision history for this message
Fabio Marzocca (thesaltydog) wrote :

Confirming same problem on Thinkpad X31 with Hardy. It was working on Gutsy.

Revision history for this message
Sean "Diggity" O'Brien (seandiggity) wrote :

Confirmed on Thinkpad T30 with Hardy. Had an OSD in Gutsy.

Revision history for this message
Linux Dan (linuxdan) wrote :

Is anyone working on this bug? I don't like reverting to the 2.6.22 kernel because then the battery status app doesn't work. It won't recognize that its plugged in to ac when it is. Anyway I'm just trying to make sure that this bug doesn't get forgotten.

Revision history for this message
Christian Becker (c-becker-88) wrote :

I don't think so...

I think we must wait till 8.10 release...

Revision history for this message
Tore Anderson (toreanderson) wrote :

For what it's worth it does not appear to be fixed in the latest 8.10 alpha.

The only Fn key combinations that work as expected on my X61s is:
- Mute
- Volume up/down (only for unmuting - the actual volume level does not change)
- Keyboard light
- Radio on/off (WLAN+Bluetooth toggle)

I suspect most of these are handled by hardware. I know that at least before brightness up/down and suspend worked in earlier versions of Ubuntu, and kind of miss those... I think volume up/down used to work too.

I can see most of the buttons generate ACPI events when pressing with acpi_listen running, the brightness buttons also generate lines starting with «video LCD0» as well as the normal «ibm/hotkey HKEY» ones.

There's a few exceptions though, the volume up/down and mute buttons does not generate events that are visible from acpi_listen, neither does the back/forward/play/pause/stop ones. All of these (except mute) generate X key presses that can be seen with xev, all NoSymbol.

Hopefully this'll work come October...

Tore

Revision history for this message
Linux Dan (linuxdan) wrote :

I've got some new info on this bug. Sometimes when I resume from a suspend. I see a message simmilar to the following:

thinkpad-acpi and nvram do not agree on display brightness levels

I know this is indicative of an additional bug but I think it might be related to this bug. If either thinkpag-acpi or nvram arn't reporting events properly then then whatever runs the osd wouldn't be able to pick it up right so the bug might be in either of these packages as well.

Hope this info is useful in fixing this bug its starting to drive me nuts.

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

This is possibly related to bug #267682

Revision history for this message
Steve Langasek (vorlon) wrote :

Hello,

Is anyone still seeing this specific problem (no OSD for volume/brightness control) in Ubuntu 8.10? There was a fair amount of work done on thinkpad hotkey support late in the 8.10 cycle, so it's possible this is fixed.

If you're still seeing this problem, could you please follow the steps in https://wiki.ubuntu.com/Hotkeys/Troubleshooting to help pin this down?

Reassigning from hotkeys-setup to hal as a first step, since hotkeys-setup is deprecated.

Revision history for this message
Steven Shiau (stevenshiau) wrote :

I confirmed that It's fixed on my T23 running Ubuntu 8.10.

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

Still no OSD on T42 with KDE. It looks like some keymap problem, press the 'volume down' button and xev detects:

keycode 176 = (keysym 0x0, NoSymbol), state = 0x0
keycode 176 = (keysym 0x0, NoSymbol), state = 0x0
keycode 176 = (keysym 0x0, NoSymbol), state = 0x0
keycode 176 = (keysym 0x0, NoSymbol), state = 0x0

The volume does change so presumably this is handled at a lower level. Amarok is unaware of the volume level changes.

Revision history for this message
Lachezar Dobrev (lachezar) wrote :

Right... A word of warning.
I found out, that I had problems with the keyboard shortcut settings.
In earlier Ubuntu version (can't recall exactly) I had mapped manually the Volume Up and Volume Down buttons using the Keyboard Shortcuts preferences.
Since I updated to 8.10 I lost the volume change display, and only the /proc/acpi/.../volume changed.
I had to manually remap the volume change keys and everything was fine since.

Revision history for this message
Linux Dan (linuxdan) wrote : Re: [Bug 198197] Re: [hardy] IBM Thinkpad (T23): no OSD indication for volume control, display inhibit or thinklight

Finally got upgraded to 8.10. Sadly the OSD is still non-operational for my
T-23.

On Tue, Dec 23, 2008 at 5:15 PM, Steve Langasek <
<email address hidden>> wrote:

> Hello,
>
> Is anyone still seeing this specific problem (no OSD for
> volume/brightness control) in Ubuntu 8.10? There was a fair amount of
> work done on thinkpad hotkey support late in the 8.10 cycle, so it's
> possible this is fixed.
>
> If you're still seeing this problem, could you please follow the steps
> in https://wiki.ubuntu.com/Hotkeys/Troubleshooting to help pin this
> down?
>
> Reassigning from hotkeys-setup to hal as a first step, since hotkeys-
> setup is deprecated.
>
> ** Changed in: hal (Ubuntu)
> Sourcepackagename: hotkey-setup => hal
>
> --
> [hardy] IBM Thinkpad (T23): no OSD indication for volume control, display
> inhibit or thinklight
> https://bugs.launchpad.net/bugs/198197
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

I just tried the Jaunty Kubuntu alpha 3 live CD and install with updates as of 20080130. There is now OSD display for volume control. Not for brightness or thinklight - I do not know if they are supposed to be supported?

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

Jaunty Gnome alpha 3 live CD - there is OSD for brightness, but not volume control or thinklight.

Revision history for this message
Steve Langasek (vorlon) wrote :

OSD status for thinklight is not supported because the key is masked out (by default) by the kernel driver and we don't change this. Unmasking it is a simple thing, but I'm not sure what GNOME will do with it once unmasked - or if unmasking it is the correct thing to do.

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

I did a full install of Jaunty Gnome with latest updates - it now has OSD volume control. I therefore expect this will work in the next live CD.

Revision history for this message
Steve Langasek (vorlon) wrote :

Marking as fixed based on the latest follow-up. If someone is still seeing this issue in jaunty, please reopen the bug.

Changed in hal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers