hald failed to initialize on start up, Gusty

Bug #157258 reported by Johne on 2007-10-25
2
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

After starting up and logging in to GNOME i'm notified that hald has failed to initialize. This makes NetworkManager unable to work, being able to suspend from the logout screen is not possible , and any thing else that uses the hal daemon can not fully function. The current work around from me is to open up a console and run "sudo hald". I'm using and inspiron 1420n that i bought from dell preloaded with feisty, which i upgraded to gusty. I have add no new hardware, and this problem persists since i upgrade to gusty, across the 2.6.20 kernel (from feisty) to the newest gusty kernel. Thank you for your help in advance.

description: updated
Paul Dufresne (paulduf) wrote :

Reassigning to hal (was network-manager).
Let's find out what is the problem with your hald, hoping it will fix your network-manger problem.

I had that problem once, it was caused by me removing haldaemon, you may look at this by:
cat /etc/group|grep hal
and see if a line like:
haldaemon:x:116:
is there (can be an other number than 116).

That said, there can be many other causes.
Read bug #24029, and see what may apply to your case.

Please begin by " dmesg > ~/dmesg.log" ant then attach dmesg.log to this file.

Changed in network-manager:
assignee: nobody → dufresnep
status: New → Incomplete
Paul Dufresne (paulduf) wrote :

Possibly a duplicate of bug #158425.
Please give the output of "dpkg --audit", I hope to see if hal is correctly installed.
Oh well, please also give the output of: "dpkg -l|grep hal"

Johne (simsonloverforever) wrote :

Hey, Paul.
Actually just last week I figured out how to solve my problem. After a bunch of Googling I found this http://ubuntuforums.org/showthread.php?p=3549705 which it turns out is the same issue here. Personally though, since CONCURRENCY=shell worked in feisty I am a bit surprise that it doesn't work in gusty. I guess this bug is solved although it really isn't and switching it seems to be aworkaround of sorts.

Paul Dufresne (paulduf) wrote :

>Personally though, since CONCURRENCY=shell worked in feisty I am a bit surprise that it doesn't work in gusty
Oh, thanks, then this is a duplicate of bug #149881, and I am marking this bug as such.
Any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers