Dell Inspiron 1501 hotkeys are not recognized

Bug #148239 reported by CheolHan Yoon on 2007-10-02
6
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using gutsy. In gutsy my Dell Inspiron 1501 laptop quite works well accept some problem.

I cannot adjust my lcd brightness with Fn + Up(Fn + Down) keys. Its works well in windows. Other keys(Volume control, Battery state, Ejecting CD, etc...) works well, too.

But I can adjust bright manually.

$ cat /proc/acpi/video/VGA/LCD/brightness
levels: 100 37 12 25 37 50 62 75 87 100
current: 0
$ sudo -i

# echo 75 > /proc/acpi/video/VGA/LCD/brightness (decrease brightness)
# echo 87 > /proc/acpi/video/VGA/LCD/brightness (increase brightness)

I collect some information by following https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch.

lcd bright increase key(Fn+Up) code - 0xd4
lcd bright decrease key(Fn+Down) code - 0x65

These key also make acpi events,

when press lcd bright increase(Fn + Up),

[Wed Oct 3 04:41:16 2007] received event "video LCD 00000086 00000000"
[Wed Oct 3 04:41:16 2007] notifying client 8898[107:115]
[Wed Oct 3 04:41:16 2007] notifying client 5377[0:0]
[Wed Oct 3 04:41:16 2007] executing action "/etc/acpi/video_brightnessup.sh"
[Wed Oct 3 04:41:16 2007] BEGIN HANDLER MESSAGES
[Wed Oct 3 04:41:16 2007] END HANDLER MESSAGES
[Wed Oct 3 04:41:16 2007] action exited with status 0
[Wed Oct 3 04:41:16 2007] completed event "video LCD 00000086 00000000"

when press lcd bright decrease(Fn+ Down),

[Wed Oct 3 04:42:00 2007] received event "video LCD 00000087 00000000"
[Wed Oct 3 04:42:00 2007] notifying client 8898[107:115]
[Wed Oct 3 04:42:00 2007] notifying client 5377[0:0]
[Wed Oct 3 04:42:00 2007] executing action "/etc/acpi/video_brightnessdown.sh"
[Wed Oct 3 04:42:00 2007] BEGIN HANDLER MESSAGES
[Wed Oct 3 04:42:00 2007] END HANDLER MESSAGES
[Wed Oct 3 04:42:00 2007] action exited with status 0
[Wed Oct 3 04:42:00 2007] completed event "video LCD 00000087 00000000"

CheolHan Yoon (mait) wrote :

I forgot laptop information

$ sudo dmidecode -s system-manufacturer
$ sudo dmidecode -s system-product-name
$ sudo dmidecode -s system-version

Dell Inc.
Inspiron 1501
Not Specified

Matthew Garrett (mjg59) wrote :

Are you using KDE?

No, Gnome. But when I was using Kubuntu(gutsy amd64), lcd brightness
control doesn't work also.

2007/10/5, Matthew Garrett <email address hidden>:
> Are you using KDE?
>
> --
> Dell Inspiron 1501 hotkeys are not recognized
> https://bugs.launchpad.net/bugs/148239
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
마잇(Mait)

Matthew Garrett (mjg59) wrote :

From a terminal, could you please do

killall gnome-power-manager
gnome-power-manager --verbose --no-daemon

and wait for it to finish printing output, then hit the brightness key and attach whatever it outputs?

CheolHan Yoon (mait) wrote :

When press increase brightness key,

[hal_device_condition_cb] gpm-button.c:390 (02:33:38):
condition=ButtonPressed, details=brightness-up
[emit_button_pressed] gpm-button.c:334 (02:33:38): emitting
button-pressed : brightness-up
[button_pressed_cb] gpm-manager.c:928 (02:33:38): Button press
event type=brightness-up
[button_pressed_cb] gpm-srv-screensaver.c:167 (02:33:38):
Button press event type=brightness-up
[button_pressed_cb] gpm-backlight.c:512 (02:33:38): Button press
event type=brightness-up
[button_pressed_cb] gpm-info.c:695 (02:33:38): Button press event
type=brightness-up

When press decreas brightness key,

[hal_device_condition_cb] gpm-button.c:390 (02:34:56):
condition=ButtonPressed, details=brightness-down
[emit_button_pressed] gpm-button.c:334 (02:34:56): emitting
button-pressed : brightness-down
[button_pressed_cb] gpm-manager.c:928 (02:34:56): Button press
event type=brightness-down
[button_pressed_cb] gpm-srv-screensaver.c:167 (02:34:56):
Button press event type=brightness-down
[button_pressed_cb] gpm-backlight.c:512 (02:34:56): Button press
event type=brightness-down
[button_pressed_cb] gpm-info.c:695 (02:34:56): Button press event
type=brightness-down

2007/10/5, Matthew Garrett <email address hidden>:
> >From a terminal, could you please do
>
> killall gnome-power-manager
> gnome-power-manager --verbose --no-daemon
>
> and wait for it to finish printing output, then hit the brightness key
> and attach whatever it outputs?
>
> --
> Dell Inspiron 1501 hotkeys are not recognized
> https://bugs.launchpad.net/bugs/148239
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
마잇(Mait)

Matthew Garrett (mjg59) wrote :

Hm. That's very odd. Can you attach the output of the lshal command?

CheolHan Yoon (mait) wrote :

Here is lshal's output.

Matthew Garrett (mjg59) wrote :

For some reason, the backlight isn't being picked up. Can you please do

ls /sys/class/backlight

and let me know what's there?

CheolHan Yoon (mait) wrote :

Nothing in there. ls /sys/class/backlight

2007/10/7, Matthew Garrett <email address hidden>:
> For some reason, the backlight isn't being picked up. Can you please do
>
> ls /sys/class/backlight
>
> and let me know what's there?
>
> ** Changed in: hal (Ubuntu)
> Sourcepackagename: hotkey-setup => hal
>
> --
> Dell Inspiron 1501 hotkeys are not recognized
> https://bugs.launchpad.net/bugs/148239
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
마잇(Mait)

Audun Bugge (anbugge) wrote :

I get similar results on a Dell Inspiron 6400, which is a very similar laptop.

I can adjust brightness manually by the method described with /proc/acpi/video/VID/LCD/brightness, or by moving the brightness-slider in power manager (running KDE).
The hotkeys used to work in feisty, and as far as I can remember also in earlier versions of gutsy, but stopped working a few weeks ago. I'm sorry I can't remember which update broke it.

Output from showkey -u:
Fn+up: 0xe0 0x54 0xe0 0xd4 0xe0 0x54 0xe0 0xd4
Fn+down: 0xe0 0x4c 0xe0 0xcc 0xe0 0x4c 0xe0 0xcc

Acpi events:

Fn+up:

[Wed Oct 10 17:06:53 2007] received event "video LCD 00000086 00000000"
[Wed Oct 10 17:06:53 2007] notifying client 5200[107:114]
[Wed Oct 10 17:06:53 2007] notifying client 6199[0:0]
[Wed Oct 10 17:06:53 2007] client has disconnected
[Wed Oct 10 17:06:53 2007] notifying client 6199[0:0]
[Wed Oct 10 17:06:53 2007] executing action "/etc/acpi/video_brightnessup.sh"
[Wed Oct 10 17:06:53 2007] BEGIN HANDLER MESSAGES
[Wed Oct 10 17:06:53 2007] END HANDLER MESSAGES
[Wed Oct 10 17:06:53 2007] action exited with status 0
[Wed Oct 10 17:06:53 2007] completed event "video LCD 00000086 00000000"
[Wed Oct 10 17:06:53 2007] received event "video LCD 00000086 00000000"
[Wed Oct 10 17:06:53 2007] notifying client 5200[107:114]
[Wed Oct 10 17:06:53 2007] notifying client 6199[0:0]
[Wed Oct 10 17:06:53 2007] executing action "/etc/acpi/video_brightnessup.sh"
[Wed Oct 10 17:06:53 2007] BEGIN HANDLER MESSAGES
[Wed Oct 10 17:06:53 2007] END HANDLER MESSAGES
[Wed Oct 10 17:06:53 2007] action exited with status 0
[Wed Oct 10 17:06:53 2007] completed event "video LCD 00000086 00000000"

Fn+down:

[Wed Oct 10 17:06:57 2007] received event "video LCD 00000087 00000000"
[Wed Oct 10 17:06:57 2007] notifying client 5200[107:114]
[Wed Oct 10 17:06:57 2007] notifying client 6199[0:0]
[Wed Oct 10 17:06:57 2007] executing action "/etc/acpi/video_brightnessdown.sh"
[Wed Oct 10 17:06:57 2007] BEGIN HANDLER MESSAGES
[Wed Oct 10 17:06:57 2007] END HANDLER MESSAGES
[Wed Oct 10 17:06:57 2007] action exited with status 0
[Wed Oct 10 17:06:57 2007] completed event "video LCD 00000087 00000000"
[Wed Oct 10 17:06:57 2007] received event "video LCD 00000087 00000000"
[Wed Oct 10 17:06:57 2007] notifying client 5200[107:114]
[Wed Oct 10 17:06:57 2007] notifying client 6199[0:0]
[Wed Oct 10 17:06:57 2007] executing action "/etc/acpi/video_brightnessdown.sh"
[Wed Oct 10 17:06:57 2007] BEGIN HANDLER MESSAGES
[Wed Oct 10 17:06:57 2007] END HANDLER MESSAGES
[Wed Oct 10 17:06:57 2007] action exited with status 0
[Wed Oct 10 17:06:57 2007] completed event "video LCD 00000087 00000000"

Laptop info:
$ sudo dmidecode -s system-manufacturer
$ sudo dmidecode -s system-product-name
$ sudo dmidecode -s system-version

Dell Inc.
MM061
Not Specified

Audun Bugge (anbugge) wrote :

Oh, forgot:

ls /sys/class/backlight/
acpi_video0 acpi_video1

ls /sys/class/backlight/acpi_video0 (and acpi_video1 too)
actual_brightness brightness max_brightness power subsystem uevent

tekg (oldskewlcool) wrote :

I can confirm this bug also with an inspiron 6400 with ati x1300 graphics.

Dell Inc.
MM061
Not Specified

default@default:~$ ls /sys/class/backlight/acpi_video0 (and acpi_video1 too)
bash: syntax error near unexpected token `('
default@default:~$ ls /sys/class/backlight/acpi_video0
actual_brightness brightness max_brightness power subsystem uevent

harrydb (harrydeboer) wrote :

I know that your bios version has influence on the brightness keys; using the latest bios version (2.6.2) the brightness keys do work,with 2.6.1 they don't. However i don't believe that they are picked up by gnome properly because the level is not displayed (alowys zero)

CheolHan Yoon (mait) wrote :

1501 bios upgraded to 2.6.3. But it doesn't work also.

2008/1/14, harrydb <email address hidden>:
> I know that your bios version has influence on the brightness keys;
> using the latest bios version (2.6.2) the brightness keys do work,with
> 2.6.1 they don't. However i don't believe that they are picked up by
> gnome properly because the level is not displayed (alowys zero)
>
> --
> Dell Inspiron 1501 hotkeys are not recognized
> https://bugs.launchpad.net/bugs/148239
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
마잇(Mait)

harrydb (harrydeboer) wrote :
Download full text (5.8 KiB)

Apart from from that the keys do function in that the brightness is changed (bios 2.6.2 and 2.6.3) I can confirm all the output from Mait on my inspiron 1501, except the part from the powermanager. I do see that gnome does not pick up brightness changes (osd does show, but is always zero). In hardy alpha dim when idle does not work, dim when on battery not, etc. I'm on hardy alpha 3 btw.

power manager thingies, brightness down:
[hal_device_condition_cb] gpm-button.c:393 (15:51:18): condition=ButtonPressed, details=brightness-down
[emit_button_pressed] gpm-button.c:337 (15:51:18): emitting button-pressed : brightness-down
[button_pressed_cb] gpm-manager.c:999 (15:51:18): Button press event type=brightness-down
[button_pressed_cb] gpm-srv-screensaver.c:167 (15:51:18): Button press event type=brightness-down
[button_pressed_cb] gpm-backlight.c:515 (15:51:18): Button press event type=brightness-down
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:108 (15:51:26): ERROR: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
*** WARNING ***
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:113 (15:51:26): GetBrightness failed!
[gpm_brightness_lcd_set_hw] gpm-brightness-lcd.c:155 (15:51:26): Setting 0 of 7
[gpm_brightness_lcd_set_hw] gpm-brightness-lcd.c:165 (15:51:34): ERROR: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
*** WARNING ***
[gpm_brightness_lcd_set_hw] gpm-brightness-lcd.c:170 (15:51:34): SetBrightness failed!
[gpm_brightness_lcd_down] gpm-brightness-lcd.c:392 (15:51:34): emitting brightness-changed (0)
[brightness_changed_cb] gpm-backlight.c:690 (15:51:34): Need to display backlight feedback value 0

brightness up:
[hal_device_condition_cb] gpm-button.c:393 (15:52:46): condition=ButtonPressed, details=brightness-up
[emit_button_pressed] gpm-button.c:337 (15:52:46): emitting button-pressed : brightness-up
[button_pressed_cb] gpm-manager.c:999 (15:52:46): Button press event type=brightness-up
[button_pressed_cb] gpm-srv-screensaver.c:167 (15:52:46): Button press event type=brightness-up
[button_pressed_cb] gpm-backlight.c:515 (15:52:46): Button press event type=brightness-up
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:108 (15:52:54): ERROR: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
*** WARNING ***
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:113 (15:52:54): GetBrightness failed!
[gpm_brightness_lcd_set_hw] gpm-brightness-lcd.c:155 (15:52:54): Setting 1 of 7
[gpm_brightness_lcd_set_hw] gpm-brightness-lcd.c:165 (15:53:02): ERROR: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection wa...

Read more...

harrydb (harrydeboer) wrote :
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 RC or later?

Changed in hal:
status: New → Incomplete
harrydb (harrydeboer) wrote :

well, they work, but a bit too well..... it seems keypresses are captured multiple times

Mario Limonciello (superm1) wrote :

Since the keys work in intrepid per the commenter, i'm closing out this bug. The repeating hotkeys bug is known and fixed in intrepid-proposed with the new kernel image. You should update to that for that issue.

Changed in hal:
status: Incomplete → Fix Released
CheolHan Yoon (mait) wrote : hi !

Hi,what is up?
my friend that works at chinese electronic corporation called
"VIP-SHIMAO" tell me: their company is carrying out a promotion
activity,
there are phone,notebook,LCD TV and so on,not only all of goods are
new and original ,but also the price so cheaper,they have received
from customers high praise in the worldwide,
today i get the digital camera that ordered,their service team are so
excelent,shiping time take less than one week,i am very satisfied with
their goods and service.
now i share with you the good news,i believe that you can find what
you need or like there : www.vip-shimao.info
i trust that you will not despair and will get surprising,wish
shopping happily!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers