Ubuntu

A/C Status, CPU Temp, and Battery no longer recognized as present after upgrade to Gutsy in Dell Latitude L400

Reported by Scott Kitterman on 2007-07-23
36
Affects Status Importance Assigned to Milestone
Feisty Backports
Medium
Unassigned
hal (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Matt Hoy
linux (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Matt Hoy
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Matt Hoy

Bug Description

Binary package hint: linux-source-2.6.22

Battery status was recognized in Feisty. It now shows not present after upgrade to Gutsy.

$ acpi -s
     Battery 1: slot empty

When it is not, in fact empty.

Attachments to follow....

Looking into this a little further, I find that ACPI is always reporting A/C online and CPU temp 50c even when on battery:

acpi -V
     Thermal 1: ok, 50.0 degrees C
  AC Adapter 1: on-line

So while there is something HAL related (because of the backport of HAL), I think ACPI is also involved.

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :

Still no battery with 2.6.22-9

Scott Kitterman (kitterman) wrote :

Moving to HAL. Battery status was no longer recognized in Feisty after upgrading to the version in feisty-backports. Reverting to the released HAL in Feisty resolved the issue.

Changed in linux-source-2.6.22:
importance: Undecided → Medium
status: New → Confirmed
Changed in feisty-backports:
importance: Undecided → Medium
status: New → Confirmed
description: updated

Confirmed, exactly the same problem with my Dell Latitude L400.

Perfect/outstanding in 7.04, nothing in 7.10.

Constantly says "running on AC power"

Would appreciate fix by final release. Subscribing to this bug. Will try reverting to old hal, if possible.

Matt Hoy (old-pink) wrote :

Should be in:
https://launchpad.net/ubuntu/gutsy/+package/hal
?

Installing hal and/or hal-info from the Feisty repository (using dpkg -i --force-all), and rebooting, fixes nothing.

If anyone on gutsy HAS managed to fix this, somehow, please let us know in a reply/comment to this.

Matt Hoy (old-pink) wrote :

Booting 2.6.20-16-generic gives me a regular, working battery.

2.6.22-14-generic is the problem.

On Thu, 11 Oct 2007 17:18:26 -0000 Matt Hoy <email address hidden> wrote:
>Should be in:
>https://launchpad.net/ubuntu/gutsy/+package/hal
>?
>
>Installing hal and/or hal-info from the Feisty repository (using dpkg -i
>--force-all), and rebooting, fixes nothing.

Right but installing the feisty-backports version (from Gutsy) in Feisty
causes the same problem. Problem is HAL and something else in Gutsy

Matt Hoy (old-pink) wrote :

>> Scott Kitterman wrote on 2007-10-11: Re: [Bug 127773] Re: A/C Status, CPU Temp, and Battery no longer >>recognized as present after upgrade to Gutsy in Dell Latitude L400
>> Right but installing the feisty-backports version (from Gutsy) in Feisty
>>causes the same problem. Problem is HAL and something else in Gutsy

Booting 2.6.20-16-generic gives me a regular, working battery.

2.6.22-14-generic is the problem. It's the kernel.

2 days until Gutsy release, and I'm worried.

Final kernel has been rolled, so this isn't going to be fixed. With any luck
maybe someone will figure out the problem and it can be added to a kernel
update.

Scott Kitterman (kitterman) wrote :

Booting with acpi=off solved (worked around) that fan problem I was having in Bug #127772. With acpi=off I get the battery icon on my tray (so the presence of the battery is now recognized), but no indication that the system knows when it switches to/from battery or what the battery charge level is.

Scott Kitterman (kitterman) wrote :

Although ancient, the gkrellm is still present in Gutsy. With acpi off, it can get battery status correctly (I expect it doens't use HAL). So that's a work around.

Matt Hoy (old-pink) wrote :

Interesting. What are the downsides of using that?

And I suppose I just edit the grub entry to have "acpi=off" at the end?

On 10/17/07, Scott Kitterman <email address hidden> wrote:
>
> Although ancient, the gkrellm is still present in Gutsy. With acpi off,
> it can get battery status correctly (I expect it doens't use HAL). So
> that's a work around.
>
> --
> A/C Status, CPU Temp, and Battery no longer recognized as present after
> upgrade to Gutsy in Dell Latitude L400
> https://bugs.launchpad.net/bugs/127773
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Matt Hoy
MBHoy.com

Matt Hoy (old-pink) wrote :

Interesting. What are the downsides of using that?

And I suppose I just edit the grub entry to have "acpi=off" at the end?

I'll try it in a bit and report back.

Matthew Garrett (mjg59) on 2007-10-18
Changed in acpi:
status: New → Invalid
Changed in acpi:
importance: Undecided → Medium
status: Invalid → Confirmed
Matt Hoy (old-pink) wrote :

Disabling acpi did nothing. Still always on AC, according to this.

Gutsy release out, no fix, not impressed.

Scott Kitterman (kitterman) wrote :

On Thursday 18 October 2007 14:54, Matt Hoy wrote:
> Disabling acpi did nothing. Still always on AC, according to this.

Install gkrellm and see if it can status the battery (it can for me with
acpi=off). While it's not as integrated as kde-guidance-powermanager, it's a
lot less of a resource hog too.

Matt Hoy (old-pink) wrote :

I understand gkrellm could work as a workaround, but that's not what I'm after. I want the original icon in the panel, from acpi, with the accurate, interesting diagnostics.

Is there any way I can find what aspect of the kernel is at fault here and report back? Or copy something across from the old firmware into the new firmware folder to get it back?

To clarify, 2.6.20-16 works.

Sam Peterson (peabodyenator) wrote :

I'm experiencing this problem as well on a Compaq Presario C571NR. However, I didn't experience the problem until I manually restarted the dbus service. It ran fine before I did this. Restarting the hal service fixes the problem, so that's an annoying work around for the time being.

Mauricio Reinoso (reino182) wrote :

Im having the same problem on my Acer Aspire 5050

I am also having this problem on a Thinkpad Z60t. It worked fine until I restarted a service, and now doesn't recognize the battery at all.
I appears however:

zachary@ibm-2513:~$ cat /proc/acpi/battery/BAT0/state
present: yes
capacity state: ok
charging state: charged
present rate: 0 mW
remaining capacity: 63640 mWh
present voltage: 12439 mV

This is all true information, and doesn't seem to be making it's way to the Gnome-Power-Manager, which as someone mentioned before is a most likely a hal issue

samil (iam312) wrote :
Download full text (4.2 KiB)

After upgrade from feisty to gutsy, I have the same problem on a thinkpad t40.
gnome-power-manager shows always using only AC adapter.
HAL can't detect my battery, but acpi detect battery.

It apears :

(1) iam312@contrabass:~$ lshal | grep battery
(1) iam312@contrabass:~$ acpi -V
     Battery 1: charged, 97%
     Thermal 1: ok, 50.0 degrees C
  AC Adapter 1: on-line
(1) iam312@contrabass:~$

When I logged in gnome, gnome-power-manager shows only AC adapter icon, then I restart 'hald', gnome-power-manager shows AC & Battery.

before restart hald debug message appears :

:
:

Nov 16 09:48:16 localhost NetworkManager: <debug> [1195174096.110329] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/volume_uuid_e05e0baf_96e4_470c_a323_5efbb289e86c').
Nov 16 09:48:16 localhost NetworkManager: <debug> [1195174096.233109] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_CPU').
Nov 16 09:48:16 localhost NetworkManager: <debug> [1195174096.246158] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/pci_8086_24c6_alsa_playback_0').
:
:

after restart hald debug message appears :

:
:

Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.520511] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/volume_uuid_e05e0baf_96e4_470c_a323_5efbb289e86c').
Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.764690] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_BAT0').
Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.790091] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_CPU').
Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.796900] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_AC').
Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.802467] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_brightness').
Nov 16 12:29:00 localhost NetworkManager: <debug> [1195183740.804553] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/storage_model_UJDA745_DVD/CDRW').
:
:

hald added ac, battery.

my kernel is :

(1) iam312@contrabass:/var/log$ uname -a
Linux contrabass 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

system info :

  power_management.acpi.linux.version = '20070126' (string)
  power_management.can_hibernate = true (bool)
  power_management.can_suspend = true (bool)
  power_management.can_suspend_hybrid = false (bool)
  power_management.can_suspend_to_disk = true (bool)
  power_management.can_suspend_to_ram = true (bool)
  power_management.is_powersave_set = false (bool)
  power_management.quirk.s3_bios = true (bool)
  power_management.quirk.s3_mode = true (bool)
  power_management.type = 'acpi' (string)
  smbios.bios.release_date = '06/02/2006' (string)
  smbios.bios.vendor = 'IBM' (string)
  smbios.bios.version = '1RETDPWW (3.21 )' (string)
  smbios.chassis.manufacturer = 'IBM' (string)
  smbios.chassis.type = 'Notebook' (string)
  smbio...

Read more...

samil (iam312) wrote :

I found the order of /etc/rc2.d script was incorrect. It was S12hal S20acpid. May be it was changed when I upgrade feisty to gutsy.
So, I changed S20acpid to S10acpid, and now, gnome-power-manager shows correct AC & BATTERY information.

But, fn+brightness does not yet shows brightness applet.

Scott Kitterman (kitterman) wrote :

Not the problem I had.

DJ Saltarelli (djsaltarelli) wrote :

Perhaps the problem for Dell L400 anyway is that the kernel acpi is misidentifying the battery slots? Under /proc/acpi/battery/ I have BAT1, and no BAT0. Restart of hald shows:

Nov 23 10:26:21 itybity NetworkManager: <debug> [1195842381.209004] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_BAT1').
Nov 23 10:26:21 itybity NetworkManager: <debug> [1195842381.218907] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_CPU0').
Nov 23 10:26:21 itybity NetworkManager: <debug> [1195842381.228033] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_FAN1').
Nov 23 10:26:21 itybity NetworkManager: <debug> [1195842381.233675] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_FAN0').
Nov 23 10:26:21 itybity NetworkManager: <debug> [1195842381.245155] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/acpi_ACAD').

So perhaps it's correct when it reports 'present: no'

/djs

Scott Kitterman (kitterman) wrote :

Well it worked fine in Feisty and non-HAL using software can find it if ACPI
is disabled, so I don't think that's the issue.

DJ Saltarelli (djsaltarelli) wrote :

i wouldn't really fault the software here too much b/c there's no doubt in my mind that there are bugs in the acpi bios on this machine. they just weren't evident under feisty. if i upgraded to the lastest bios under feisty, i would see acpi suspend button events every 30 secs. reverting to the earlier bios fixed that, so maybe i'll try the latest bios under gutsy and see what happens.

DJ

Scott Kitterman <email address hidden> wrote: Well it worked fine in Feisty and non-HAL using software can find it if ACPI
is disabled, so I don't think that's the issue.

--
A/C Status, CPU Temp, and Battery no longer recognized as present after upgrade to Gutsy in Dell Latitude L400
https://bugs.launchpad.net/bugs/127773
You received this bug notification because you are a direct subscriber
of a duplicate bug.

---------------------------------
Never miss a thing. Make Yahoo your homepage.

Gavin McCullagh (gmccullagh) wrote :

On Sun, 25 Nov 2007, DJ Saltarelli wrote:

> i wouldn't really fault the software here too much b/c there's no doubt
> in my mind that there are bugs in the acpi bios on this machine. they
> just weren't evident under feisty. if i upgraded to the lastest bios
> under feisty, i would see acpi suspend button events every 30 secs.
> reverting to the earlier bios fixed that, so maybe i'll try the latest
> bios under gutsy and see what happens.

I see this acpi suspend button problem on my laptop. As a result, I've
disabled acpi. I upgraded feisty to gutsy and I'm afraid it's still there.

If you run acpi_listen, you see two suspend requests together once per
minute (or 30 secs or some such).

Where did you get the older BIOS? Sounds like I want it.

Gavin

Henrik Nilsen Omma (henrik) wrote :

This will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Matt Hoy (old-pink) wrote :

On 12/2/07, Henrik Nilsen Omma <email address hidden> wrote:
>
> This will be retargeted towards the Hardy kernel once it is released.
> I've tagged this as "hardy-kernel-candidate" so that we make sure to
> retarget this report once the new release is out. However against the
> linux-source-2.6.22 package this is being marked as "Won't Fix" as it
> does not meet the criteria for a stable release update. To learn more
> about the stable release update process please refer to
> https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!
>
> ** Tags added: hardy-kernel-candidate
>
> ** Changed in: linux-source-2.6.22 (Ubuntu)
> Status: Confirmed => Won't Fix
>
>
Fair enough. Any chance of seeing this in the backports, or available as a
manual fix to Gutsy users? Appreciate the fact you're working on it, but
seems a shame we'll have to wait until Hardy.

--
Matt Hoy
TopicalMatt.com

Scott Kitterman (kitterman) wrote :

This bug does not affect Feisty. If you are having Feisty problems, you are having a different bug.

Changed in feisty-backports:
status: Confirmed → Invalid
Scott Kitterman (kitterman) wrote :

Silly me. It does affect Feisty because of the HAL backport. Nevermind. Ugh.

Changed in feisty-backports:
status: Invalid → Confirmed
Matt Hoy (old-pink) wrote :

Why remove hardy-kernel-candidate? I thought this was being worked on for
Hardy?

On 12/5/07, Leann Ogasawara <email address hidden> wrote:
>
> ** Tags removed: hardy-kernel-candidate
>
> --
> A/C Status, CPU Temp, and Battery no longer recognized as present after
> upgrade to Gutsy in Dell Latitude L400
> https://bugs.launchpad.net/bugs/127773
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Matt Hoy
MBHoy.com

The 'hardy-kernel-candidate' tag has been removed because the report has appropriately been targeted at the Hardy kernel. As you can see, the bug report has been updated and tasked against the 'linux' package. The 'linux' package is the current Hardy kernel source. The kernel team switched from the 'linux-source-2.6.xx' package naming convention to just 'linux' for this upcoming release. Hope that helps.

Hi All,

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

Note: in step 3 there there are other flavors you can install if you don't want to use the -generic one.

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → Medium
status: New → Incomplete
Scott Kitterman (kitterman) wrote :

It appears to still be a problem. I reinstalled kde-guidance-powermanager and booted into the kernel. I never saw a battery status from it. Let me know when there are new kernels and I'll be glad to continue to test.

Changed in linux:
status: Incomplete → Confirmed
Scott Kitterman (kitterman) wrote :

The good news is that the CPU fan problem described in Bug #127772 appears fixed, so I marked that one taken care of.

The problem is that the proc filesystem (linux kernel) reports no
battery present. What does "cat /proc/acpi/battery/BAT1" from a command
line spit out? It should say "present: yes" and then a bunch of
other info, assuming you have a battery.

On Thu, 2007-12-06 at 03:36 +0000, Scott Kitterman wrote:
> It appears to still be a problem. I reinstalled kde-guidance-
> powermanager and booted into the kernel. I never saw a battery status
> from it. Let me know when there are new kernels and I'll be glad to
> continue to test.
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Confirmed
>

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Confirmed → Triaged
Scott Kitterman (kitterman) wrote :

Works with the Gutsy HAL and the Hardy Kernel, so given that a HAL backport broke Feisty, it looks like some kind of incompatibility. Works now, so marking fix released.

Changed in hal:
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

Tested again with the new linux-image-2.6.24-1-generic and the battery is now recognized as well as the CPU temp and A/C state. Marking fix released.

Changed in linux:
status: Triaged → Fix Released
assignee: ubuntu-kernel-team → nobody

Scott,

Fix released where, Gutsy or Hardy?

If Hardy, can we backport into Gutsy?

On 12/11/07, Scott Kitterman <email address hidden> wrote:
>
> Tested again with the new linux-image-2.6.24-1-generic and the battery
> is now recognized as well as the CPU temp and A/C state. Marking fix
> released.
>
> ** Changed in: linux (Ubuntu)
> Status: Triaged => Fix Released
>
> ** Changed in: linux (Ubuntu)
> Assignee: Ubuntu Kernel Team (ubuntu-kernel-team) => (unassigned)
>
> --
> A/C Status, CPU Temp, and Battery no longer recognized as present after
> upgrade to Gutsy in Dell Latitude L400
> https://bugs.launchpad.net/bugs/127773
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Matt Hoy
MBHoy.com

Scott Kitterman (kitterman) wrote :

Fixed in the 2.6.24 kernel in Hardy. I wouldn't recommend trying to run Gutsy
with the Hardy kernel.

Changed in feisty-backports:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers