wlan zd1201 not started by network manager

Bug #115812 reported by ger heinen on 2007-05-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Medium
Unassigned

Bug Description

i have to manually start the wlan connection in a console session

ProblemType: Bug
Architecture: i386
Date: Sun May 20 16:06:02 2007
DistroRelease: Ubuntu 7.04
Package: hal 0.5.8.1-4ubuntu12
PackageArchitecture: i386
SourcePackage: hal
Uname: Linux catherine-desktop 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

ger heinen (denisem) wrote :
Djainette (djainette) wrote :

I have the same chipset on a USB dongle.
Usualy, waiting for the X session before plugin the device does the trick. If I plug it too soon, I have to do manually
- iwconfig to enter the wep key
- dhclient on the wlan interface
If I wait for the X session, the wlan connection is started automatically

after upgrading to the new release i have a kernel panic when waiting
for the ip adress, the bug is known and a workaround available.
i hope i will succeed implementing this workaround.

Djainette <email address hidden> a écrit :

> I have the same chipset on a USB dongle.
> Usualy, waiting for the X session before plugin the device does the
> trick. If I plug it too soon, I have to do manually
> - iwconfig to enter the wep key
> - dhclient on the wlan interface
> If I wait for the X session, the wlan connection is started automatically
>
> --
> wlan zd1201 not started by network manager
> https://bugs.launchpad.net/bugs/115812
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in hal (Ubuntu):
status: New → Incomplete
DjMix (ilario-gottardello) wrote :

I also have a usb dongle with this chipset and it too won't connect automatically with network manager, nor with dhcp. I have to give it an ip address manually, then it work ok. Tested on Jaunty and Karmik beta (daily updated)

Thank you for updating this. Can you try with the latest daily build of the 10.04 alpha release Lucid Lynx, and if the problem still exists, please connect to the internet, perhaps through ethernet, and execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p linux 115812
This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thank you.

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in hal (Ubuntu):
status: Incomplete → Invalid
Martín Ferrari (tincho) wrote :

I have the same problem in an up-to-date lucid. iIf i run iwconfig as root, I can see that there is no key configured. If I add it by hand, it works.

This same dongle works perfectly in Debian squeeze.

Martín Ferrari (tincho) wrote :

More info,

- After network-manager touched the card I cannot configure it by hand, it misbehaves, does not change channel automatically, gets dissasociated,etc. I had to unplug the card and re-plug it to make it work.

With network-manager, you can see there is no key conigured:

# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:"" Nickname:"zd1201"
          Mode:Managed Channel:1 Access Point: 50:67:F0:89:6A:70
          Bit Rate:11 Mb/s
          Retry RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0/128 Signal level=25/128 Noise level:0/128
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Steps to make it work:

# service network-manager stop
network-manager stop/waiting

(unplug and replug the card)

# iwconfig wlan0 essid Tincho key xxxxxxxxx
# ip l s wlan0 up
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:"Tincho" Nickname:"zd1201"
          Mode:Managed Channel:11 Access Point: 50:67:F0:89:6A:70
          Bit Rate:11 Mb/s
          Retry RTS thr:off Fragment thr:off
          Encryption key:xxxxxxxxxxxxxxxxxxxxx Security mode:open
          Power Management:off
          Link Quality:0/128 Signal level=33/128 Noise level:0/128
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

(Now the key is correctly set)

# dhclient wlan0
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/00:0e:2e:40:f4:0d
Sending on LPF/wlan0/00:0e:2e:40:f4:0d
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPOFFER of 192.168.1.5 from 192.168.1.1
DHCPREQUEST of 192.168.1.5 on wlan0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.5 from 192.168.1.1
bound to 192.168.1.5 -- renewal in 110190 seconds.

apport-collect does not run as the bug is closed. I' ll open and come back in a few minutes

Changed in hal (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
tags: added: apport-collected

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tincho 1281 F.... pulseaudio
 /dev/snd/pcmC0D0p: tincho 1281 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf8500000 irq 16'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,10ec0268,00100003'
   Controls : 13
   Simple ctrls : 8
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=e63efd85-eac9-4a23-bcbb-da98e6241267
MachineType: ATI Herring
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-31-generic root=UUID=105e67f4-e3dd-4ecb-8632-2fc112c4ff79 ro splash quiet
ProcEnviron:
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-31.61-generic 2.6.32.32+drm33.14
Regression: No
RelatedPackageVersions: linux-firmware 1.34.7
Reproducible: Yes
RfKill:

Tags: lucid networking needs-upstream-testing
Uname: Linux 2.6.32-31-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video
dmi.bios.date: 09/26/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 1.0A
dmi.board.name: Herring
dmi.board.vendor: ATI
dmi.board.version: Rev 1
dmi.chassis.asset.tag: None
dmi.chassis.type: 1
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr1.0A:bd09/26/2008:svnATI:pnHerring:pvrRev1:rvnATI:rnHerring:rvrRev1:cvnAMD:ct1:cvrNone:
dmi.product.name: Herring
dmi.product.version: Rev 1
dmi.sys.vendor: ATI

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Martín Ferrari (tincho) wrote :

I am about to upgrade to 11.10, I will follow up later

Clint Byrum (clint-fewbar) wrote :

Affects more than 1 person, marking as Confirmed, medium priority since it is not totally broken for all, but does seem rather inconvenient for those affected.

Changed in hal (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

Martin can you tell us if this affect Ubuntu 12.04 LTS? Thank you!

Changed in hal (Ubuntu):
status: Confirmed → Incomplete
Martín Ferrari (tincho) wrote :

Thomas,

Not really, I am only an occasional Ubuntu user (usually I only run Debian), and I don't even know where that USB dongle went...

Sorry.

Changed in hal (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers